Missing security tab in Windows 2000

Archived from groups: microsoft.public.win2000.security (More info?)

All my files and folders no longer have a "Security" tab; no idea of why. I
probably did something really dumb while trying to tighten security. How do I
get my "Security" tabs to show again?
--
Twas
6 answers Last reply
More about missing security windows 2000
  1. Archived from groups: microsoft.public.win2000.security (More info?)

    See the link below. Possibly you modified permissions on some system files
    including Rshx32.dll. You could use a command line tool like cacls [should
    already be on your computer] or fileacl to check and modify ntfs permissions
    from the command line. Cacls c:\winnt\system32\Rshx32.dll file /e /g
    administrators:f for example may work. The last link is how to restore
    security settings back to default defined levels and note that you can use
    the /area switch for just file system, etc if you do not want to reset all
    security settings. --- Steve

    http://support.microsoft.com/default.aspx?scid=kb;en-us;193826
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;313222

    "Twas" <twas@anon.postalias> wrote in message
    news:A6BC667F-1978-4FBA-BC2D-2DB11DE069F7@microsoft.com...
    > All my files and folders no longer have a "Security" tab; no idea of why.
    > I
    > probably did something really dumb while trying to tighten security. How
    > do I
    > get my "Security" tabs to show again?
    > --
    > Twas
  2. Archived from groups: microsoft.public.win2000.security (More info?)

    Interesting utilty; didn't know it existed. It appeared to run OK, although
    it did report an "Error: 234" "enumerating info for
    machine\system\currentcontrolset\control\CriticalDeviceDatabase"; don't know
    if that represents a problem, since the KB article said to expect some
    (unspecified) error.

    However, I still have no security tabs, and now I'm wondering if I've made
    the system nicely vulnerable while I try to fix it.

    I tried the first time in my usual Admin account; then I tried logging into
    the built-in adminstrator account (which has been renamed for security). Got
    the same exact results -- and still no security tabs anywhere.
    --
    Twas


    "Steven L Umbach" wrote:

    > See the link below. Possibly you modified permissions on some system files
    > including Rshx32.dll. You could use a command line tool like cacls [should
    > already be on your computer] or fileacl to check and modify ntfs permissions
    > from the command line. Cacls c:\winnt\system32\Rshx32.dll file /e /g
    > administrators:f for example may work. The last link is how to restore
    > security settings back to default defined levels and note that you can use
    > the /area switch for just file system, etc if you do not want to reset all
    > security settings. --- Steve
    >
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;193826
    > http://support.microsoft.com/default.aspx?scid=kb;EN-US;313222
    >
    > "Twas" <twas@anon.postalias> wrote in message
    > news:A6BC667F-1978-4FBA-BC2D-2DB11DE069F7@microsoft.com...
    > > All my files and folders no longer have a "Security" tab; no idea of why.
    > > I
    > > probably did something really dumb while trying to tighten security. How
    > > do I
    > > get my "Security" tabs to show again?
    > > --
    > > Twas
    >
    >
    >
  3. Archived from groups: microsoft.public.win2000.security (More info?)

    I don't know offhand what that error means but a log should have been
    generated while you ran the secedit command as described in that KB. If you
    have not done such try using cacls to view and/or modify ntfs permissions on
    the rshx32.dll file. Below is an example of the output on my computer and
    how to use cacls to view permissions on that file. As you can see in a
    default installation users and power users have read and
    system/administrators have full control. Another thing to do is use Event
    Viewer to look in the system and application logs to see if anything
    pertinent has been recorded which may provide a clue as to the problem.

    Windows 2000 is less secure in a default installation than XP Pro or Windows
    2003 but if you keep current with critical updates, use strong passwords,
    use quality up to date antivirus, are careful browsing the web, and use a
    firewall to protect yourself from the internet the risks are greatly reduced
    for the average user. The free tool Microsoft Baseline Security Analyzer [
    Google for MBSA] can also help you in checking the security of your computer
    and recommending specific changes to current security settings. Another
    possibility is that your computer has been infected with malware and you
    should of course scan for malware and parasites [adware/spyware/hijacks]
    being sure to use the latest definitions for any program you use. Rootkit
    infections are another possibility and they are very difficult to
    etect. --- Steve

    D:\Documents and Settings\Steve>cacls d:\winnt\system32\rshx32.dll
    d:\winnt\system32\rshx32.dll BUILTIN\Users:R
    BUILTIN\Power Users:R
    BUILTIN\Administrators:F
    NT AUTHORITY\SYSTEM:F


    "Twas" <twas@anon.postalias> wrote in message
    news:8D2D85F7-361B-4954-AE15-40A29B70329A@microsoft.com...
    > Interesting utilty; didn't know it existed. It appeared to run OK,
    > although
    > it did report an "Error: 234" "enumerating info for
    > machine\system\currentcontrolset\control\CriticalDeviceDatabase"; don't
    > know
    > if that represents a problem, since the KB article said to expect some
    > (unspecified) error.
    >
    > However, I still have no security tabs, and now I'm wondering if I've made
    > the system nicely vulnerable while I try to fix it.
    >
    > I tried the first time in my usual Admin account; then I tried logging
    > into
    > the built-in adminstrator account (which has been renamed for security).
    > Got
    > the same exact results -- and still no security tabs anywhere.
    > --
    > Twas
    >
    >
    > "Steven L Umbach" wrote:
    >
    >> See the link below. Possibly you modified permissions on some system
    >> files
    >> including Rshx32.dll. You could use a command line tool like cacls
    >> [should
    >> already be on your computer] or fileacl to check and modify ntfs
    >> permissions
    >> from the command line. Cacls c:\winnt\system32\Rshx32.dll file /e /g
    >> administrators:f for example may work. The last link is how to restore
    >> security settings back to default defined levels and note that you can
    >> use
    >> the /area switch for just file system, etc if you do not want to reset
    >> all
    >> security settings. --- Steve
    >>
    >> http://support.microsoft.com/default.aspx?scid=kb;en-us;193826
    >> http://support.microsoft.com/default.aspx?scid=kb;EN-US;313222
    >>
    >> "Twas" <twas@anon.postalias> wrote in message
    >> news:A6BC667F-1978-4FBA-BC2D-2DB11DE069F7@microsoft.com...
    >> > All my files and folders no longer have a "Security" tab; no idea of
    >> > why.
    >> > I
    >> > probably did something really dumb while trying to tighten security.
    >> > How
    >> > do I
    >> > get my "Security" tabs to show again?
    >> > --
    >> > Twas
    >>
    >>
    >>
  4. Archived from groups: microsoft.public.win2000.security (More info?)

    You were by chance exploring settings in the Group Policy features?
    There is a setting in the Users branch that will remove the Security
    dialog from the NTFS properties

    --
    Roger Abell
    Microsoft MVP (Windows Server: Security)
    MCDBA, MCSE W2k3+W2k+Nt4
    "Twas" <twas@anon.postalias> wrote in message
    news:A6BC667F-1978-4FBA-BC2D-2DB11DE069F7@microsoft.com...
    > All my files and folders no longer have a "Security" tab; no idea of why.
    > I
    > probably did something really dumb while trying to tighten security. How
    > do I
    > get my "Security" tabs to show again?
    > --
    > Twas
  5. Archived from groups: microsoft.public.win2000.security (More info?)

    True, but that only works on XP Pro and W2003 :( --- Steve

    "Roger Abell [MVP]" <mvpNoSpam@asu.edu> wrote in message
    news:uVvb%23zUeFHA.2664@TK2MSFTNGP15.phx.gbl...
    > You were by chance exploring settings in the Group Policy features?
    > There is a setting in the Users branch that will remove the Security
    > dialog from the NTFS properties
    >
    > --
    > Roger Abell
    > Microsoft MVP (Windows Server: Security)
    > MCDBA, MCSE W2k3+W2k+Nt4
    > "Twas" <twas@anon.postalias> wrote in message
    > news:A6BC667F-1978-4FBA-BC2D-2DB11DE069F7@microsoft.com...
    >> All my files and folders no longer have a "Security" tab; no idea of why.
    >> I
    >> probably did something really dumb while trying to tighten security. How
    >> do I
    >> get my "Security" tabs to show again?
    >> --
    >> Twas
    >
    >
  6. Archived from groups: microsoft.public.win2000.security (More info?)

    Probably, like a novice or worse, I was experimenting with local policies,
    but failed to keep a good log. I knew the registry was dangerous, but didn't
    appreciate the power or the danger of policies. I'm considering wiping the
    partition and restoring it from a backup, but that's a bit drastic.
    --
    Twas


    "Roger Abell [MVP]" wrote:

    > You were by chance exploring settings in the Group Policy features?
    > There is a setting in the Users branch that will remove the Security
    > dialog from the NTFS properties
    >
    > --
    > Roger Abell
    > Microsoft MVP (Windows Server: Security)
    > MCDBA, MCSE W2k3+W2k+Nt4
    > "Twas" <twas@anon.postalias> wrote in message
    > news:A6BC667F-1978-4FBA-BC2D-2DB11DE069F7@microsoft.com...
    > > All my files and folders no longer have a "Security" tab; no idea of why.
    > > I
    > > probably did something really dumb while trying to tighten security. How
    > > do I
    > > get my "Security" tabs to show again?
    > > --
    > > Twas
    >
    >
    >
Ask a new question

Read More

Security Windows 2000 Microsoft Windows