Sign in with
Sign up | Sign in
Your question

System won't shut down & printer causes BSOD

Last response: in Systems
Share
February 27, 2007 10:17:24 PM

Need help on this one:

Whenever I turn on or turn off the printer, I get a momentary BSOD, before it reboots. The BSOD happens so fast, that I can't read anything off of the screen.

Also, my 1 wk old home built system reboots if I try to shut down via windows, which I haven't been to cure either. This happened when I installed the Thermotake PSU in my last computer, but then mysteriously fixed itself after 2 wks.

System (everything stock)
E6600, Asus Commando, Arctic Freezer Pro, Corsair 2 GB PC2-800, 2) WD 150 GB Raptors, 2) 160 GB WD Caviers, Thermotake 750 PSU, GeForce 8800 GTX 768 MB, 2) SATA DVD ROM/Burner, HP Photosmart 7760
February 27, 2007 10:44:21 PM

sounds like driver issues to me. Download the latest drivers including XP, remove the added drivers, do a repair on XP and start one by one. Printer will be last of course and test each stage for a day or so.
February 27, 2007 10:54:56 PM

Remove all USB devices. If it doesn't bsod, then the problem is USB. Try disabling Legacy USB in BIOS. See mobo manual for how.
Related resources
February 27, 2007 11:58:24 PM

-Right click on my computer, select properties
-Click on the 'Advanced' tab
-Click 'settings' in the 'Startup and Recover' section
-Uncheck automatically restart

Now next time it BSOD's write down the error including the driver the error occured with if it is listed and the error code. Let it BSOD a couple of times, if the error is consistant report to us what it is. If it is different every time it will be more difficult to figure out.
February 28, 2007 1:08:53 AM

Thanks guys.

Unchecked restart and now I can read the BSOD:

Problem detected:
Driver_IRQ_NOT_LESS_OR_EQUAL
Disable bios memory options such as caching or shading
Tech info:
Stop:0X000000D1(0X000002C, 0X0000002, 0X0000000, 0XB97D3B8F)
USBPORT.SYS - Address B97D3B8F bsae at B97CA000,Datestamp 41107D62
Physical Memory Dump Complete

Don't know much about address and stuff, but is the USB printer walking over another devices address?
February 28, 2007 1:26:30 AM

Ok, now unplug the printer and uninstall the drivers and all the software for it. Then test your system for stability.

If the problem continues we have another problem.

If not there is something wrong with the printer drivers/software or possibly the printer itself. Reinstall it, but follow the printer installation instructions carefully, for instance, with my printer I needed to install the software BEFORE plugging in the printer for it to work correctly.
February 28, 2007 11:20:02 AM

I unplugged the printer, but didn't have a chance to uninstall the drivers, I'll do that after work tonight.
When shutting down in windows recieved this message:

Driver_IRQ_NOT_LESS_OR_EQUAL
Tech info:
Stop:0X000000D1(0X000002C, 0X0000002, 0X0000000, 0XB97E7B8F)
USBPORT.SYS - Address B97E7B8F base at B97DE000

The address changed from D3 to E7. I believe it is the printer, as that was the last thing I installed, & everything was cool before then. I'll let you know how things go...

Thank you to all for all of the help!

MaxLatG
February 28, 2007 7:57:12 PM

The address isn't important, at least not to me. What's important is the system file that it is crashing on, that system file is your Intel USB drivers from your motherboard. If uninstalling the printer drivers doesn't work (and it might not). The next step is to reinstall The USB divers from your motherboard drivers disk, or update them from the Asus website.
March 1, 2007 2:36:31 AM

Cutthroat,

It was the printer. Just unplugging it from the USB port would BSOD. After I uninstalled the drivers, it shut down normally.
Unplugged the keyboard, mouse, steering wheel, yoke/pedals with no ill effects.

Now what? I was using the latest board and printer drivers - the latest HP driver for Photosmart 7760 was 3 yrs old (also tried the original driver, same result) & I didn't see a specific USB update on the Asus site. I will update the BIOS tomorrow though.

Please don't tell me that my perfectly good 4 yr old printer has to be replaced.

Anyway, your help has beeen appriciated, seeing this through the end.
March 1, 2007 9:46:03 AM

When did your problems start? If it happened when you installed that motherboard I suspect an incompatibility issue. If it happened out of the blue I would suspect your printer just died.

Either way, looks like you're likely going to need a new printer. I got an Epson CX4800 for $60CDN.
March 1, 2007 10:03:12 AM

Started with the new build. I had 0 problems with a older Asus, and a new ASRock.

What sucks is it still works with the Commando - printing like a charm, just that it BSOD when I turn it off and screws up my shut down.

Many thanks,

MaxLatG
March 1, 2007 9:07:07 PM

Looks like your only hope is to wait for a future driver update for your printer or motherboard, whichever is causing the problem. Couldn't hurt to send a ticket off to Asus and HP. I wouldn't keep your hopes up.

You really should try to get hold of another printer to test on your PC. That would narrow down where the problem is.
March 1, 2007 9:18:26 PM

Trying another printer sounds like a good idea. Not that I really want to go that route anyway, but the Commando lacks any legacy printer ports.

I Googled IRQ_NOT_LESS_OR_EQUAL as well as USBPORT.SYS and got a million hits, so I plan to see if any relates to my problem.

Off to update the BIOS!

MaxLatG
March 4, 2007 5:31:39 PM

Tried 3 different HP printers: no go.
Bought a Canon iP6700 & everything is sweet.

Go figuire.

Cheers
March 4, 2007 6:05:42 PM

Maybe Asus & HP don't like each other. :wink:

Whatever, glad the Canon works for you. :D 
August 13, 2008 5:04:05 PM

Having a similiar issue with an HP and an ASUS motherboard, will be working on it tonight!

www.gadgetgal.info
August 24, 2008 6:58:55 AM

Added a larger power supply and validating if issue still remains. Will update soon!

www.gadgetgal.info
!