win2k server /fastdetect does not disable com ports

Archived from groups: microsoft.public.win2000.setup (More info?)

*Running Windows Server 2000
*Clean install
*boot.ini is in default form

Checked the boot.ini file and it contains on the last line
the boot.ini switch, "/fastdetect"

I have a device connected and active on com1 port (which
must remain turned on).

Unfortunately, the com ports are not disabled during the
start up process and the mouse cursor moves inadvertently
around the screen during startup. When rebooting,
restarting and doing a shutdown and boot up the problem
sometimes is intermittent.

I have used 'noserialmice' previously when running windows
NT server and this worked fine.

Does anyone know what troubleshooting i can do to keep my
device connected to com1 and to disable the com1 port so
that no serial mouse detection occurs during startup?

Thanks in advance!
3 answers Last reply
More about win2k server fastdetect disable ports
  1. Archived from groups: microsoft.public.win2000.setup (More info?)

    Ndo

    Have you tried "/fastdetect:com1"? I'm not sure that it will change
    anything, but it could be worth a try. This MS Knowledge Base article
    describes Win2000 boot.ini switches:

    http://support.microsoft.com/?id=833722

    Best regards

    Bjorn
    --
    Bjorn Landemoo - mvp2@landemoo.com - http://landemoo.com/
    Microsoft MVP (Windows Server - File System)

    "Ndo from Oz" <anonymous@discussions.microsoft.com> wrote:

    >*Running Windows Server 2000
    >*Clean install
    >*boot.ini is in default form
    >
    >Checked the boot.ini file and it contains on the last line
    >the boot.ini switch, "/fastdetect"
    >
    >I have a device connected and active on com1 port (which
    >must remain turned on).
    >
    >Unfortunately, the com ports are not disabled during the
    >start up process and the mouse cursor moves inadvertently
    >around the screen during startup. When rebooting,
    >restarting and doing a shutdown and boot up the problem
    >sometimes is intermittent.
    >
    >I have used 'noserialmice' previously when running windows
    >NT server and this worked fine.
    >
    >Does anyone know what troubleshooting i can do to keep my
    >device connected to com1 and to disable the com1 port so
    >that no serial mouse detection occurs during startup?
    >
    >Thanks in advance!
  2. Archived from groups: microsoft.public.win2000.setup (More info?)

    Hi Bjorn,

    Yes i did try your suggestion below, and also com1,2,3 (as
    i have 2 and 3 com ports fitted via PCI card). All
    attempts using the /fastdetect switch seemed to produce
    the same result (mouse cursor moving erratically).

    I found an article on wwww.microsoft.com/resources...
    which suggested the following boot.ini switch:

    "/FASTDETECT=[COMx| COMx,y,z..]"

    Can anyone suggest if the square brackets and the "|" will
    make a difference?

    Cheers!

    >-----Original Message-----
    >Ndo
    >
    >Have you tried "/fastdetect:com1"? I'm not sure that it
    will change
    >anything, but it could be worth a try. This MS Knowledge
    Base article
    >describes Win2000 boot.ini switches:
    >
    >http://support.microsoft.com/?id=833722
    >
    >Best regards
    >
    >Bjorn
    >--
    >Bjorn Landemoo - mvp2@landemoo.com - http://landemoo.com/
    >Microsoft MVP (Windows Server - File System)
    >
    >"Ndo from Oz" <anonymous@discussions.microsoft.com> wrote:
    >
    >>*Running Windows Server 2000
    >>*Clean install
    >>*boot.ini is in default form
    >>
    >>Checked the boot.ini file and it contains on the last
    line
    >>the boot.ini switch, "/fastdetect"
    >>
    >>I have a device connected and active on com1 port (which
    >>must remain turned on).
    >>
    >>Unfortunately, the com ports are not disabled during the
    >>start up process and the mouse cursor moves
    inadvertently
    >>around the screen during startup. When rebooting,
    >>restarting and doing a shutdown and boot up the problem
    >>sometimes is intermittent.
    >>
    >>I have used 'noserialmice' previously when running
    windows
    >>NT server and this worked fine.
    >>
    >>Does anyone know what troubleshooting i can do to keep
    my
    >>device connected to com1 and to disable the com1 port so
    >>that no serial mouse detection occurs during startup?
    >>
    >>Thanks in advance!
    >
    >.
    >
  3. Archived from groups: microsoft.public.win2000.setup (More info?)

    The square brackets means it is an option item. We don't actually
    type in the square brackets,eg, /FASTDETECT=COM1,COM2,COM3,COM4

    -Hung

    > Hi Bjorn,
    >
    > Yes i did try your suggestion below, and also com1,2,3 (as
    > i have 2 and 3 com ports fitted via PCI card). All
    > attempts using the /fastdetect switch seemed to produce
    > the same result (mouse cursor moving erratically).
    >
    > I found an article on wwww.microsoft.com/resources...
    > which suggested the following boot.ini switch:
    >
    > "/FASTDETECT=[COMx| COMx,y,z..]"
    >
    > Can anyone suggest if the square brackets and the "|" will
    > make a difference?
    >
    > Cheers!
Ask a new question

Read More

Windows Server Boot Windows