Sign in with
Sign up | Sign in
Your question

965 Neo-F not recognizing USB?

Last response: in Motherboards
Share
March 3, 2007 2:55:25 AM

Doing a build for a buddy. MSI 965 Neo-F. USB ports won't work.

-fresh OS install on new HDD
-installed newest chipset drivers
-USB cables are hooked up properly on mobo headers (not rocket science there)

Both the front USB and the rear bracket USB won't recognize a USB flash drive, for example.

BIOS setting I'm missing? First time I've ever had this happen in a build. Anyone got ideas?

Much thanks.
March 3, 2007 3:31:09 AM

Try connecting a USB device to the USB ports directly connected to the MB. If those aren't working, then you either have an incorrect BIOS setting (not too likely), or your MB needs to be returned (likely).

You might also want to check the Windows Device Manager to see if any USB ports are recognized.
March 3, 2007 3:42:30 AM

Ya, just checked the Device Manager......gives "Code 39....driver corrupt or not recognized". Weird....I don't see a USB driver listing on the selection menu on the mobo CD....so not sure how it would be corrupt.....though it could be missing.

But I've scoured MSI's website and don't see anything listed specifically for USB....just chipset, BIOS, RAID, audio.


OK, just tried the USB ports in the rear of the mobo. No luck. So, since Device Manager is giving the "!" sign, there must be missing/corrupt USB drivers. So, any idea where to get them? M$? I'm installing WinXP with SP2......
Related resources
March 3, 2007 4:24:53 AM

OK, got it. When all else fails.........

Did an Update Driver, manually browsed off the WinXP disk. Worked like a charm. Very weird though, have never had to do that before....oh well.

Thanks for the input, much appreciated.
March 4, 2007 3:59:53 AM

Glad you got it working, and you're correct when you said that this problem was odd because I don't think I have seen this before.

Since I like to tweak Windows a lot, I usually have to reinstall the OS, updates, and other programs because it's just easier to do that than trying to undo something. I've done this many times and I don't think I have seen the installation process do the same thing twice (meaning, I will get weird errors at times and at others, nothing).

Just gotta love it I guess!
March 4, 2007 4:04:50 AM

Ya, I've had some very weird issues considering the number of installs I've done. This was a new one.

Guess in a weird way it teaches us new things! :roll:

Still not entirely impressed with this board layout though.....guess you get what you pay for ;) 
March 9, 2007 5:54:36 AM

Usually I would agree with the axim, "You get what you pay for", but so many times we find products that are over-priced and underwhleming in performance. I bought an EVGA 680i MB, and while it works OK, there are definitely issues with it. For instance, I had to RMA the first board because the BIOS would keep clearing out. The second one hasn't had that problem, but has instead come up with a new set.

There are 6 SATA ports on the board; two are paired by themselves at the lower edge of the board, and the other 4 run inline vertically above them. The manual lists the order, but the BIOS lists it as something very different. The BIOS also pairs the channels and then calls them channel 1 primary, channel 1 secondary, etc., and the manual says nothing about that.

To make things worse, I think there is something not wired right on the board itself. Those 4 inline SATA ports have the following attached devices (from the top): DVD-RW, 3x WD 2500YS HDD in RAID5. In the BIOS, I have to enable RAID and all the SATA channels, then I have to select which channels have been RAIDed. Since I have the three HDDs hooked to three consecutive ports, one would think that I would just need to select say, channels 4, 5, 6 for the RAID, and channel 3 for the DVD-RW.

Well, you would be wrong.

I had to enable channels 3, 4, and 6, for RAID, and channel 5 for the DVD-RW! (Note: not sure about the actual names for the channels used, but the point is that there is a gap in the sequence). Isn't that weird?

I am thinking about emailing EVGA about it, but as we all know, replacing a MB is a royal bitch!

Word.
!