Sign in with
Sign up | Sign in
Your question

oh ftp, pain in the butt

Last response: in Networking
Share
November 26, 2006 4:06:52 AM

Hello, Im setting up a ftp server so i can access my music from anyware and im running into some problems. My network at home is set up like this. My router is the D-link DI-614+ and that connects my dsl modem and all the computers. The ftp server ip address is 192.168.0.100 and the ftp site is on the same address. My dsl is a dynamic ip address but i signed up on the no-ip site for free service. now when i type in
"ftp://example.no-ip.info" my browser says that my connection was timed out. it works fine if i type "ftp://192.168.0.100". now the router is set to foword port 21 to 192.168.0.100 and i know that the no-ip site works because a nslookup points to my ip address and i can anminister my router by typing in "http://example.no-ip.info:8080". ive tryed many different programs such as serv-u, bulletproof, and microsofts IIS. Right now a prefer to stick with IIS because the site is already setup. Any help or advice is greatly appreciated! :D 

Thanks -Spazo

oh P.S. the ftp server is running windows server 2000 if that helps any.

More about : ftp pain butt

Anonymous
November 26, 2006 11:16:09 AM

You need to forward port 20 as well for dynamic ftp.

Grumpy
November 26, 2006 4:05:56 PM

humm did that still no luck. does toms have a article on ftp or something? ive looked all over the internet. ive also tryed typeing in my ip address **.**.***.***:21 and :20 still no luck.
Related resources
Can't find your answer ? Ask !
November 26, 2006 4:10:34 PM

when i try to connect though internet explorer it says,

Windows cannot access this folder. make sure you typed the file name correctly and that you have permission to access the folder.

Details:
The operation timed out


And I dont think that makes any since because i have every thing setup to an anonymous user can access the server. and like i said before i can access it in my network. im really starting to get confused :?
November 26, 2006 5:36:43 PM

I ran "netstat" on the server and here are some connections,

Proto Local Address Foreign Address State
TCP dimension_4100:ftp Dimension_e510:1382 Established
TCP dimension_4100:netbios-ssn Dimension_e510:1033 Established
TCP dimension_4100:1163 Dimension_e510:netbios-ssn Established
TCP dimension_4100:1193 Dimension_e510:1385 Time_wait
TCP dimension_4100:3389 Dimension_e510:1118 Established

Those are the connections between the server (dimension_4100 or 192.168.0.100) and another computer on the network (dimension_e510 or 192.168.0.101). The server is connected to the internet but right now to internet connections are active. But i can start up something like firefox and it will work. also Right now i am connected to the ftp server though the internal network and im running the server though terminal services. If you know what some of that stuff is i hope that helps also.
November 26, 2006 5:41:28 PM

ok when i disconnect the ftp server and reconnect the internal port changed from Dimension_e510:1382 to Dimension_e510:2019 and reason for that?
November 26, 2006 8:21:26 PM

oh :oops:  Thank you you just saved me a bunch of truble!!!!!
November 26, 2006 8:24:10 PM

Works and every thing!! thanks for the help!
:lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol:  :lol: 
!