Sign in with
Sign up | Sign in
Your question

E6400 and Supreme Commander

Last response: in CPUs
Share
March 10, 2007 2:10:52 AM

Not sure if this fits in CPU discussion or games, but i'll give it a try...

Today after I installed the first time supreme commander and tried it out on the first level I was getting about 60fps on average, I had planned to make a clean installation today and so I did (thought i'd yield even better results aswell), to my surprise I've formatted and installed windows XP twice and Vista once and on XP I keep getting the same results now (about 30-40fps), so I opened task manager and found out that only Core#1 was in use, on vista on the other hand it worked just fine (as far as the use of both cores, but I have a series of issues with vista drivers so that's not a viable option for the time being).

I just reinstalled XP and keep getting the same results as before (using only one core), and the only things I have installed are the motherboard drivers and both service packs.

I do recall installing a microsoft dual-core patch before (that was on my original installation) and changing something in the registry from a guide in gamespot, and I tried redoing what the guide said but it didn't work.

Anyone got any ideas?

CPU = C2D E6400 (never overclocked)

there's nothing wrong with my CPU because it runs perfectly fine other multi-threaded games and this exact problem is happening to my brother (who also owns an E6400).
March 10, 2007 6:03:29 AM

I suspect it is the game. In fact I all but Know it is the game. Ask the devs, but it probably needs a patch for fully functional dual core support. That is a real pain. Other than that I don't know enough. Try googling it if you're desperate.

Ta for the warning, as I'm considering buying an E6400. I think I'll stay away from that game for a while.
March 10, 2007 8:14:11 AM

Supreme Commander should be using both cores, something is wrong if it isn't. That hotfix to use dual core processors doesn't come in a service pack I don't think. I believe you have to install it yourself, so if you haven't done so then of course your performance is going to be lower.
Related resources
March 10, 2007 1:41:48 PM

I've done it on all PCs now, still to no avail... :( 
March 10, 2007 4:43:52 PM

I think it's a combination of the game and using xp. Was it designed for vista?
March 10, 2007 5:55:36 PM

Quote:
Not sure if this fits in CPU discussion or games, but i'll give it a try...

Today after I installed the first time supreme commander and tried it out on the first level I was getting about 60fps on average, I had planned to make a clean installation today and so I did (thought i'd yield even better results aswell), to my surprise I've formatted and installed windows XP twice and Vista once and on XP I keep getting the same results now (about 30-40fps), so I opened task manager and found out that only Core#1 was in use, on vista on the other hand it worked just fine (as far as the use of both cores, but I have a series of issues with vista drivers so that's not a viable option for the time being).

I just reinstalled XP and keep getting the same results as before (using only one core), and the only things I have installed are the motherboard drivers and both service packs.

I do recall installing a microsoft dual-core patch before (that was on my original installation) and changing something in the registry from a guide in gamespot, and I tried redoing what the guide said but it didn't work.

Anyone got any ideas?

CPU = C2D E6400 (never overclocked)

there's nothing wrong with my CPU because it runs perfectly fine other multi-threaded games and this exact problem is happening to my brother (who also owns an E6400).


agree to wha other says
in windows XP you need SP2 and the dual core patch.
March 10, 2007 6:33:33 PM

Yep, this is definately the case, I was have the same problem with my lil' bro's rig, applied the patch and now it hums right along.
March 10, 2007 6:38:57 PM

i'll try reapplying the patch once again... hopefully it'll work
March 10, 2007 6:52:09 PM

It has nothing to do with the game interacting with Windows XP. When Gas Powered Games started making Supreme Commander Microsoft was still calling Vista Longhorn, so no it wasn't designed for Vista. You wont see games designed for Vista (eg, DX10 games) until probably Crysis. Although Supreme Commander will have a patch that enables the use of DX10 sometime in the future, GPG hasn't given any kind of timeframe for it.
March 10, 2007 6:58:12 PM

patch didn't work... I'm so screwed :?
March 10, 2007 7:15:52 PM

Quote:
patch didn't work... I'm so screwed :?


Nope, try this:

Quote:
REMEMBER TO ADD A RESTORE POINT BEFORE DOING THIS!

Requirements:
Dual core CPU (ex. Pentium D or Core Duo)
Windows XP Servicepack 2

What you need:
Download this patch from Microsoft: http://support.microsoft.com/default.aspx?scid=kb;en-us;896256
(language of the patch must be the same as your operating system. In this case the link is for the english one)

How to do:
1. Install the patch and restart.

2. Then press: Start-> Run-> Type "regedit"
Go to:
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession Manager
Under "Session Manager" make a new folder called "Throttle".
Add a new key to the "Throttle" folder. Name it "PerfEnablePackageIdle"
Hex value of the new key should be 1 (enable dual core). To disable dual Core type 0.

3. Now you need to edit the boot.ini
Press: Start-> Run-> Type "sysdm.cpl"
Choose "Advanced" and then options under "Start & Recovery"
Press "Edit"
Add this parameter to the end of the last line: /usepmtimer
Save the boot.ini
Restart and that its.





Here is more information in this thread. But it's mostly flaming. However you should benchmark before and after so you have solid comparison points. How to benchmark is explained in one of my posts in that thread on the first page.
March 10, 2007 7:20:25 PM

I already tried it and it didn't work, that's the patch i was referring
March 10, 2007 7:21:37 PM

Quote:
patch didn't work... I'm so screwed :?


Nope, try this:

Quote:
REMEMBER TO ADD A RESTORE POINT BEFORE DOING THIS!

Requirements:
Dual core CPU (ex. Pentium D or Core Duo)
Windows XP Servicepack 2

What you need:
Download this patch from Microsoft: http://support.microsoft.com/default.aspx?scid=kb;en-us;896256
(language of the patch must be the same as your operating system. In this case the link is for the english one)

How to do:
1. Install the patch and restart.

2. Then press: Start-> Run-> Type "regedit"
Go to:
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession Manager
Under "Session Manager" make a new folder called "Throttle".
Add a new key to the "Throttle" folder. Name it "PerfEnablePackageIdle"
Hex value of the new key should be 1 (enable dual core). To disable dual Core type 0.

3. Now you need to edit the boot.ini
Press: Start-> Run-> Type "sysdm.cpl"
Choose "Advanced" and then options under "Start & Recovery"
Press "Edit"
Add this parameter to the end of the last line: /usepmtimer
Save the boot.ini
Restart and that its.





Here is more information in this thread. But it's mostly flaming. However you should benchmark before and after so you have solid comparison points. How to benchmark is explained in one of my posts in that thread on the first page.

also he might have to 1.- restart computer 2.- reinstall supremecommander :o 
March 10, 2007 7:24:29 PM

alright, i'll try reinstalling supreme commander
March 10, 2007 7:25:46 PM

i just got that game free with a core2 gpu deal a the "Egg" is any good?

are u sure u did all the windows upgrades before installing the game?
March 10, 2007 7:29:46 PM

Quote:
i just got that game free with a core2 gpu deal a the "Egg" is any good?

are u sure u did all the windows upgrades before installing the game?


reinstalling as we speak, I installed windows, SP1, SP2, DX9c, dual core fix, and what not.

Im going to try and use the retail version of the game first and then patch it (I patched it with the latest SupCom patch)

And btw, Im not really an RTS gamer (more of a Shooter + Oblivion kind of guy), but this thing got me hooked right on the first mission. So yeah... I think it's pretty damn good.
March 10, 2007 7:41:48 PM

Quote:
I already tried it and it didn't work, that's the patch i was referring


Did you do this steps too?

2. Then press: Start-> Run-> Type "regedit"
Go to:
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession Manager
Under "Session Manager" make a new folder called "Throttle".
Add a new key to the "Throttle" folder. Name it "PerfEnablePackageIdle"
Hex value of the new key should be 1 (enable dual core). To disable dual Core type 0.

3. Now you need to edit the boot.ini
Press: Start-> Run-> Type "sysdm.cpl"
Choose "Advanced" and then options under "Start & Recovery"
Press "Edit"
Add this parameter to the end of the last line: /usepmtimer
Save the boot.ini
Restart and that its.
March 10, 2007 7:44:16 PM

Quote:
patch didn't work... I'm so screwed :?


Nope, try this:

Quote:
REMEMBER TO ADD A RESTORE POINT BEFORE DOING THIS!

Requirements:
Dual core CPU (ex. Pentium D or Core Duo)
Windows XP Servicepack 2

What you need:
Download this patch from Microsoft: http://support.microsoft.com/default.aspx?scid=kb;en-us;896256
(language of the patch must be the same as your operating system. In this case the link is for the english one)

How to do:
1. Install the patch and restart.

2. Then press: Start-> Run-> Type "regedit"
Go to:
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlSession Manager
Under "Session Manager" make a new folder called "Throttle".
Add a new key to the "Throttle" folder. Name it "PerfEnablePackageIdle"
Hex value of the new key should be 1 (enable dual core). To disable dual Core type 0.

3. Now you need to edit the boot.ini
Press: Start-> Run-> Type "sysdm.cpl"
Choose "Advanced" and then options under "Start & Recovery"
Press "Edit"
Add this parameter to the end of the last line: /usepmtimer
Save the boot.ini
Restart and that its.





Here is more information in this thread. But it's mostly flaming. However you should benchmark before and after so you have solid comparison points. How to benchmark is explained in one of my posts in that thread on the first page.

also he might have to 1.- restart computer 2.- reinstall supremecommander :o 

you're a friggen genius!!!!! its working... my guess is that SupCom 3220 patch was the cause, because I just reinstalled and didn't patch with that crap and bam! 60fps :roll: thanks for the help guys...
March 10, 2007 8:09:01 PM

Quote:
you're a friggen genius!!!!! its working... my guess is that SupCom 3220 patch was the cause, because I just reinstalled and didn't patch with that crap and bam! 60fps :roll: thanks for the help guys...


Your welcome :) 
!