Sign in with
Sign up | Sign in
Your question

No video signal to HDTV with Win7 x64

Last response: in Windows 7
Share
July 19, 2011 10:21:33 PM

Well I guess I just can't win. I just built a new gaming rig with 8gigs of RAM. I made the mistake of installing WinXP Pro x32 on it. I find out that 32 bit OS's can't access 8 gigs of RAM , so I went and bought an OEM Win7 64 bit disk. Come to find out now, Win7 x64 doesn't play well with many HDTV's. Something about they changed the instruction in Win7 to not allow for overriding something called the EDID signal from the HDTV. So now I'm screwed again. Now I got 8gigs of RAM but no video. Great. What now? I need to go and buy a THIRD OS that will work this time? WinXP Pro x64?

Yeah, it's not the video card, the video card drivers, or the TV. It all worked just fine with WinXP Pro x32 installed. And all the cables are plugged in tightly. Win7 x64 will output video signal to a generic VGA monitor. If I set the resolution to like 1024 x 768 or something then swap the VGA cable from the VGA monitor to the HDTV I get video signal. As soon as I reboot, no video signal. I get video for the post screen and the Win7 startup screen. As soon as it trys to boot into the desktop, no video signal. My AKAI TV only says "Not Support". Win7 will not get past the HDTV EDID handshake. Win7 sucks.

Now I find myself looking at the Windows web site HDTV "compatibility list" for Win7. Like trying to work my life around bill gates and his crappy software. Serving Windows instead of it serving me. When will those people ever get it right again after WinXP?

Anyone know of a workaround that will make Win7 override the HDTV EDID handshake?
July 20, 2011 4:14:14 AM

List your system specs, including graphics card please. What else is connected to the graphics card and how? Is your TV Primary or secondary display? What is the resolution of your TV. Whenever I get 'Not supported' it turns out to be a resolution issue. Are you using an HDMI cable?
m
0
l
July 20, 2011 6:15:18 PM

Win7 64 bit OS
AMD x4 3.2ghz
8gigs of dual channel RAM
Visiontek Radeon HD 5670 video card with VGA/HDMI/DVI outputs
Akai 32" 720p HDTV
(All drivers are up to date. The rig output video fine with WinXP Pro 32 bit installed.)

The problem occures using either the VGA or HDMI connection. And I only have one cable connected at a time so the PC must be seeing it as a primary monitor. I get a "not supported" after win logon screen.

I forgot to mention that I do get video to the HDTV from Win7 in SAFE mode, with some kind of basic drivers loaded for SAFE mode. I can even adjust the screen resolution to whatever I want in SAFE mode. Must be a software/driver issue.

I tried fiddling with various combinations of all the video resolution and frequency settings in the Visiontek Catalyst software and the windows side software. No go.

I got a similar issue on my sons 26" Visio HDTV. I actually did get video to the Vizio, but the "no signal" message was floating around on the screen simultaneously. So it was unusable. Weird.

I've been doing a lot of googling. I'm gonna go into Device Manager/Monitors and fiddle around in there with the drivers. I found this on google:
http://www.tek-tips.com/viewthread.cfm?qid=1618084&page...

Info update: In WinXP on my laptop, with no other monitors connected to my laptop, in Device Manager/Monitors, I have 3 instances of "Plug and Play Monitor" listed. In Win7, in Device Manager/Monitors I have one monitor listed, "Generic PnP monitor". I wonder why there are three "Plug and Play" monitors listed on my laptop with only 1 display screen connected, the laptop screen itself. My laptop outputs VGA video just fine to any HDTV I have (I only have a VGA connector on my laptop, no HDMI). This is all deffintiely some kind of defeciency with Win7 and how it handles plug and play monitors.
m
0
l
Related resources
a b $ Windows 7
July 20, 2011 8:05:52 PM

edit: update your drivers, get the latest catalyst control centre and install everything it asks you too (apart from the games)

that should fix it

thats odd ?

im runing my win7 x64 professional on a hdtv

32" samsung, just plugged lead in graphics card and tv didnt have to touch any settings it auto detected everything
m
0
l
July 21, 2011 1:19:51 PM

I have a Radeon HD 5770 connected to both a Samsung 24" Monitor and Sony 1080P TV. No conflicts or problems.

Your TV might require a custom resolution. If you have a monitor, connect that to your PC and set the resolution to 800 X 600. Shut your computer down and then connect to the TV via HDMI. Turn your system back on in normal mode. If you can get past login with 800 x 600 then your problem is resolution.

Using google I found this :

http://pbtech.co.nz/index.php?z=p&p=TVAKA0832

This indicates that your resolution should be set to 1366 X 768. However, the supported PC resolutions listed on the page stop at 1024 X 768. Try what I said above and change resolution to 800 X 600, then connect to TV. If that works then change resolution to 1366 X 768.

If that doesn't work please post TV model number.

Good luck!
m
0
l
July 23, 2011 7:53:05 PM

(solved)

Problem solved.

Thanks for the replies you guys. Sorry about the delay in my response to your replies.

Using this information, http://www.tek-tips.com/viewthread.cfm?qid=1618084&page... and this information, http://windows.microsoft.com/en-US/windows7/why-is-my-s... I fixed the problem.

I think your HDTV will have to have either a VGA or DVI connection to get the problem corrected as generic PnP monitors only have VGA or DVI connectors. The problem here is that the software (on the Windows side I believe) is detecting the HDTV as a generic plug and play monitor, not a generic NON plug and play monitor, aka., a digital flat panel. To solve the problem you need to force Windows to see the monitor as a digital flat panel non-pnp monitor. Since you will have to get windows booted from safe mode to get a video signal, and since widows only loads some kind of generic VGA video driver for safe mode, then I think it would be impossible to boot Windows in safe mode with a HDMI cable connection. Windows does not have any kind of generic HDMI driver that I know of that would load up in safe mode. If you have the same problem as I did and your HDTV doesn't have a VGA connection, then I think you're out of luck. When I buy an HDTV I specifically search for one with a VGA connector in case I want to connect my laptop to it.

You have to get one instance of Windows running in NORMAL mode, connected to your HDTV via VGA, and with your video card display adapter driver installed and running in order to do this proceedure. "Monitors" does not show up in device manager with your video card adapter uninstalled, and with only the Windows generic VGA driver running. In order to fix the problem, you must go through Monitors in device manager with your HDTV connected via the VGA connection to force Windows to see the HDTV as a digital flat panel NON-PnP monitor. ( I tired to force Windows to see a generic (non-HDTV) display that I had video signal to, to identify the generic monitor as a digital flat panel, hoping that it would stick so that I could just plug it in to my HDTV afterwards. It did not work.)

With the HDTV connected via a VGA connection, here are the steps I took to solve the problem:

1) Boot into safe mode by pressing F8 when the Windows start up screen appears.

2) Go to Start/Control Panel/Device Manager.

3) Find "Display Adapters" and expand.

4) Right click on your video card display adapter you have installed (example: ATI Radeon HD 5670) and go to "Uninstall".

5) Very important: Put a check mark in the box next to "Delete driver for this device from you system" and click "OK". If you don't do this, the video card display adapter will load again when Windows boots and cause you not to get a video signal in normal mode again.

6) Reboot. Windows will now load a standard VGA driver that will allow Windows to boot into normal mode, not safe mode.

7) Go to Start/Control Panel/Programs and Software (I think) and find the "Add/Remove Programs" function. (Sorry, writing this step from memory). Find your video card display adapter software in Add/Remove Programs, uninstall your video card software. For the Radeon HD 5670 it's called like Catalyst. You cannot Add/Remove a program in safe mode.

8) Now, using the disk that came with the video card (or a newer version download from the video card manufacturer's web site), RE-install the video card software and drivers.

9) Reboot as instructed after the video card display adapter software and driver installation. You should now have Windows booted into normal mode WITH your video card display adapter drivers installed and running. If you reboot for any reason at this point, you will loose your video signal again and will have to start all over.

10) Very Important: Go to Start/Control Panel/Device Manager and find and expand "Monitors". It will say "Generic PnP monitor". Right click on "Generic PnP monitor" and click on "Update driver software".

11) Click on "Browse my computer for driver software".

12) Click on "Let me pick from a list of device drivers on my computer"

13) Uncheck "Show compatible hardware".

14) Leave "Standard monitor types" highlighted in the left pane. Go to the right pane and select "Digital flat panel (xxxx by xxx) according to your HDTV resolution and frequency. For my HDTV I selected "Digital flat panel 1024 x 768 60hz". I don't think it really needs to be that specific, as long as "Standard monitor types" gets associated with a "digital flat panel" of whatever resolution or frequency. Click "Next" and/or "Ok" accordingly.

15) Reboot into Windows normal mode. You should now have full video signal output in Windows normal mode. VGA, HDMI, DVI. Go to Start/Control Panel/Device Manager, expand Monitors and you will now see that "Generic PnP monitor" has changed to "Generic NON PnP Monitor".

Done. You should get video signal to any HDTV now. This fix should work if you are having this problem and you are just using your onboard video too. Just subsitute your onboard video driver in the sequence.


m
0
l
July 26, 2011 11:30:09 PM

Update:

I have to revise my conclusions from my last post. Although the steps above fixed the problem with the Visio 26" LCD 720p HDTV, I am still having the same problem with the Akai 32" LCD 720p HDTV.

I stated that the steps taken to fix the Visio would fix the whole issue and that you should get video signal to any HDTV after that. That was an erroneous statement. I had NOT yet tested the Akai TV yet when I said that.

Still working on the problem and asking questions on the manufacturers forums. The Visiontek forum and the AMD forum. The thing is, I get video signal to the Akai with the Win7 generic VGA drivers loaded and with the ATI Radeon display adapter uninstalled. So that makes me think the problem is with the Radeon drivers for Win7 x64. But I had the same problem with the onboard video drivers, the Nvidia drivers. I have Nvidia onboard video. If I had the same problem with the nvidia drivers installed, which is entirely separate from the Radeon drivers, then that makes me think the problem is with Win7 x64.

I wish a tech expert who writes the drivers for the video cards for Win7 knew about this issue. I'm sure they would have a clue.
m
0
l
July 27, 2011 2:12:24 AM

When you install a monitor, sould have a driver disc, anything basically can be plugged, and wirelessly connected to a computer needs drivers, unless on the OS.

XP Pro i think can hold more then 8gs, in all honesty, cause last i remember i was still going to get in terms of the issue of memory use cause it still was higher then a lower 7 and vista release of max memory. So what your issue, i dont know.

But of it though with what you are saying, if the OS doesnt use your monitors, but you can use them, just when it comes to HD you are kinda out.

Other then defualting part of which in use at all is with the issue seems to be working or not working.

I have this issue when i format/reformat, the video card to say anyways, has new driver install, but still receive video.

So of it, you need to make sure that your monitors are plugged in within your useable plug-ins, VGA to VGA and DVI-to DVI, adapters i think only combine the signals more then anything. But drivers might be useful.

Otherwise you just plug-in for the adpater, but probably isnt the issue really to say.

But you gotta be careful though, HDTVs seem to be variant of interest and use.

But should just be able at any one time of whats been said so far, to just install drivers and plug-in.

Think HDTV is more your issue then what you are using, but that could be argued.

Safe Mode you might be able to uninstall in it, but i think more then anything you just to do other efforts within the uninstall process, which is probably better placed within use of the idea of uninstall of the issue probably more then likely.
m
0
l
July 27, 2011 2:26:10 AM

If anything completely ignore the top post:

Try one monitor at a time and maybe work within ideas of uninstall/formatting/reformatting for each one use. And just for them. Each time.

Since at a time you've been able to get something to work.

And work from there and isolate what might be a problem, cause the problem might have a good chance of being within the issue. To say.

You've said alot and im only going from somethings to say.
m
0
l
July 27, 2011 5:52:51 PM

K-zon said:
If anything completely ignore the top post:

Try one monitor at a time and maybe work within ideas of uninstall/formatting/reformatting for each one use. And just for them. Each time.

Since at a time you've been able to get something to work.

And work from there and isolate what might be a problem, cause the problem might have a good chance of being within the issue. To say.

You've said alot and im only going from somethings to say.


K-zon, your advice to unistall/format/reformat is totally erroneous and useless advice. If you don't know what you're talking about, then maybe you should withhold the advice. (Do you have a part time job working as a manufacturer support tech in India or something?)

WinXP 32 bit will not read more than 4 gigs of RAM. I had WinXP 32 installed already, and it only acknowledged 4 gigs of the 8 gigs of RAM that I had installed. Trust me.

All monitors and all TV's (that I am aware of) are made to be plug and play. Do you know what plug and play means? It means that they are made to run on generic plug and play drivers that all Windows operating systems already have incorporated into their system. And I presume MAC's also. This means that the monitor and HDTV manfacturers have no need to distribute drivers for their products.

Right now I'm starting to think the whole mess is related to some kind of maddening WQRL issue/incompatibility issue with Microsofts digital signatures or something really stupid like that. Or something even stupider. Some kind of sutpid security thing in Win7 that sees my HDTV EDID as some kind of intrusion threat. I noticed all the annoying security warning in Win7 every time I tried to run a program... any program. Yeah, already turned that nonsense off.

You see, the wonderful success of the operating system WinXP Pro was that they took into account the disaster of imcompatibility issues with previous OS's they wrote like Win98. So when they wrote WinXP Pro, their focus was on c o m p a t i b i l i t y. Understanding so far? They wrote WinXP to make IT compatible with OTHER non microsoft devices. They loaded up WinXP with hundreds of drivers for third party devices. Compatiblity with the outer world of third party divices was their primary focus. Now with OS's like WinVista and Win7, they've gone back to their old selfish ways. They are making the disasterous mistakes they made in the past. Now microsoft wants everyone to make THEIR devices compatible with microsoft software (Ok, makes sense to a certain point), instead of Microsoft making IT'S software compatible with everything that's already out there in the world.

All I know is this. The Radeon video card driver + WinXP Pro worked fine. No problems. The Radeon video card driver + Win7 is not working fine. Is the problem with the Radeon driver that was written for Win7? Or is the problem with Win7 irregardless of the Radeon driver? That is the question.
m
0
l
July 28, 2011 1:10:41 AM

See, you might as well say then it only reads to 2g and get left with what is able to be done with that on the issue.

Which with all that installed, but should uninstall and use one. And uninstalling wasnt working. And repair, modify and install didnt seem to also be an option, yes?

Rather of updating or not. Right?

So of ideas of compatibility then are not of place rather with any hardware at all, or the right hardware. With 1st, 2nd, or third party. Or more.

To say any video card set and drivers is different for the interest would only be in place of what the interest is probably for and if not, on ideas of updates, yes?

Which again didnt seem to work, for whatever reason, but something did work, right? Hence the furtherly applied effort of question, right? on why something else didnt work, and instead of asking why nothing works at all, which was almost intial, yes?

So, i dont know issue, other then "HDTV" for this one, and with the use of it will probably be for later, but not till then cause it wont fit for the issue...

Cause in terms of drivers for the formats and hardware, the card is to small or the Monitor is too big. And the ram cant make a difference of either.
m
0
l
!