Sign in with
Sign up | Sign in
Your question

FTP Client Software FileZilla vs SmartFTP

Tags:
  • Routers
  • FTP
  • Switch
  • Software
  • NAS / RAID
  • Networking
Last response: in Networking
Share
December 19, 2006 7:48:11 PM

I have been testing my Hardware setup and discovered FTP clint software throughput varies greatly.
Setup:
3.2P4 w/ Gigabit port, 250gig SATA Hitachi
Snap4500 NAS, 1.6T Raid 5 (1.03T Usable) has dual gigabit ports.
Netgear FVS338 Router
Dlink DGS1216T Gigabit switch.

The P4 and Snap4500 is connected to the switch. And 1 cat5e is run from the router to the switch. No other hardware connected to the switch.
Info Says the Switch and P4 gigabit port support Jumbo packets, NAS Unknown.

File is a 750meg IMG located on P4's HD

Speed reported in MB/sec. This is substained speeds, I dis-regarded the cache starts and only recorded the ave speeds.

Client Software ------> SmartFTP --- FileZilla
Jumbo Frame size
0 ................................... 10.9 .......... 15.1
4088 ............................. 10.6 .......... 15.7
9000 .............................. 2.8 .......... 15.3

Findings FileZilla is 33.33% faster than SmartFTP.
And Smart FTP has a problem with 9k jumbo frames.

Has any one else done any testing with FTP clinet software and any recommendations.

More about : ftp client software filezilla smartftp

December 20, 2006 5:09:43 PM

What kind of hdd do you have in the PC? 15MB/s seems pretty slow for gigabit. You might try some kind of hdd benchmark to see if you have a disc bottleneck.
December 20, 2006 5:59:53 PM

The HD is a Hatichi 250gig SATA, the MB is a Asus P5GDC-V deluxe. I know the HD does not support Cmd quing, and is partitioned into 2 parts. The first part is where XP-home resides and all application & data. The second 1/2 (80gig) is used to store image files only. Which I have been moving up to my NAS. This pc had a clean install at the first part of this month. Everything was wiped clean, just like a new HD. Using Avira AV and Comodo FW.

I know this is not the fastest PC by any means it was built for bussiness use, and www. Using the built in video.

update: I did another test using my builtin 100baseT nic on my 3ghz P4, NB, w/7200 rpm drive.

It transfered at 10.4 MB/s with FileZilla, which is pretty much max for a 100 base network. Failed to run SmartFTP.

I will do a direct connect to the NAS when I get some time. This will eliminate the router and switch.
December 20, 2006 7:12:58 PM

Might also try turning off the AV and F/W.
December 20, 2006 11:57:03 PM

Was unable to do a direct connect, for some reason static settings would not work. I did turn off AV & FW Filezilla reported 16.2MB/s transfer speeds.

I ran a bench on my HD reported 54MB/s empty and 34MB/s toward empty.

I ran Sandra2007 and it only reported a 16MB/s between my PC and NAS.

I have a netgear PCI Gigabit card, will try that next to see if any improvements. I know this will only have a bandwidth of ~54MB/s, PCI slot.
December 21, 2006 4:29:44 PM

I would try the crossover cable again, there must be some setting that wasn't set correctly. I can't think of any reason why it wouldn't work that way, I'm assuming you did at least get link lights with the crossover cable?

Also, isn't PCI something like 133MB/s? I think you might be thinking of WiFi with that 54 number. Although you're contending with every other device on the PCI bus. The builtin NIC on the motherboard might be PCI itself, so who knows what kind of difference it would actually make.
December 21, 2006 5:23:37 PM

Did some more test with QoS service.

My managed switch has option for QoS Normal or High. I set both ports (pc & NAS) to high. Normal actually work better. With QoS off there seam to be no impact.

Transfers from my NAS to PC were in the neighborhood of 22MB/s with 4k packets, 20MB/s with 0k.

The pci nic card that I thought was Gig was actually a Fast (100), so i have not tried another card yet.

With the crossover cable I was able to do a direct connect from PC to NAS (lan2), but could not get a dir listing. With std cable would not established a connection.

More work to do.
December 22, 2006 12:00:12 PM

Quote:

Findings FileZilla is 33.33% faster than SmartFTP.
And Smart FTP has a problem with 9k jumbo frames.

Has any one else done any testing with FTP clinet software and any recommendations.


Interesting. I've tried Novell's NetDrive, and it's a cool tool, but unfortunately caps somewhere around 2 GB files. Besides that, so far I've only tried the built-in Windows 2000 command line ftp utility. I've managed to do > 100 MB/s through it, so I didn't think there would be much more to gain with another tool. I'll give FileZilla a try when I have some time.
January 6, 2007 4:23:18 PM

Update:

Purchased a USR Gigabit PCI card, after installing found out it did not support 9k packets. But it gave you 1k steps, 1-7k not just 4 & 9k. But it was better than my built-in. The USR maxed out at 19.3MB/s with 7k jumbo, 17.9 MB/s with 4k jumbo. I even installed the card in my old Win98 PC and got impressive numbers of 20.4 to 21 with jumbo disabled, dropped to 18.3 with 4k jumbo.

I found some updated drivers for my Yukon Nic, built-in. Made a little improvement. Maxed out at 16.5MB/s with jumbo disabled. So progress is being made. With external card showing a major increase, I need to dig further in to this 915g MB. A chipset driver update may correct some of the bottle necks. Still haven't taken the time to do direct connect to my NAS, eliminating the managed switch. Used FileZilla for testing. Data is for PC to NAS, NAS to PC values are higher, + 5MB/s.

Update:

Have been playing with XP drivers. Have backup to v7.23 and my speeds have increased to 25MB/s with 4k jumbo. And going the opposite direction I have close to 30MB/sec. So it appears that I have a driver issue. The version I am using does not have a pulldown menu for frame size. You have to enter the number value. I have 4 later version to try.
!