Sign in with
Sign up | Sign in
Your question

P5B - PCI Express stuck at x1

Last response: in Motherboards
Share
March 15, 2007 6:58:45 PM

A few days ago after a reboot I observed serious 3d app performance drop. Cpu-Z has shown my Radeon 1950pro at x1 PCI-E.

I already tried the following:

- new BIOS (1102)
- various FSB frequencies
- different PCI-e freq. from 90 to 110 MHz
- reinserting graphics card
- force pci-e x1 enable->disable->enable
- shutting down computer for longer period of time
- different SB, NB, NBVcore, FSBterm voltages
- CMOS reset

No matter what I do, still x1.
I'd be eternally grateful if someone could help me resolve this.

My config :

Intel Core2 Duo E6300
Asus P5B Intel P965 (bios 1102)
Radeon X1950 Pro Gigabyte
PDP Patriot Dual 2x 1GB DDR2 667 MHz

More about : p5b pci express stuck

a b V Motherboard
March 16, 2007 3:01:02 PM

This is a well documented glitch on the P5B's (though I've never experienced it). It only happens when you overclock. Read this thread:

e6300 Overclocking Help...I just can't figure it out

to find a solution to the problem. There are several things to try including playing with the PCI-e bus speed, NB voltage, etc. but it sounds like you've tried most of that. You may need to lay off the OC until a BIOS fix.
March 16, 2007 3:18:27 PM

I wrote I did CMOS reset, default settings mean no OC, right ? Hovewer, that changed nothing, the damn board still cuts the speed.
Related resources
March 17, 2007 5:57:11 PM

In the BIOS, try these settings (see section 4.4 in manual):
PCI Express Frequency to 100 MHz (default is AUTO)
PCI Synchronization Mode to 33.33 MHz (default is AUTO)
March 18, 2007 6:41:04 PM

No change.
March 23, 2007 5:51:27 PM

Have u sorted it yet?

I had the same problem and I semi-sorted it by upping my PCI-e freq to 110Mhz, sometimes however I would have to reboot to get the correct x16 link width.

ASUS tech support told me to set PCI-e to 101Mhz and the NB voltage to the lowest selectable value 1.25 (or something like that). I was sceptical and this didn't quite work (no x16 at all), however raising the NB voltage to the next value up (1.4?) and leaving the PCI-e clock the same at 101 has done it - always boots into x16 and I have kept my over-clock at 3.2 Ghz.

This board was very twitchy for the first three weeks but after a lot of tinkering it seems *crosses fingers* stable at last.

Oh....and it flies ;) 
March 23, 2007 9:15:43 PM

Yeah, after a week of 'fun' I did it. BIOS 0509 (the oldest available on asus ftp) did the trick. Everything works like a charm. Every other BIOS did reset the PCI-E to x1 after reboot, with NO tinkering (fresh after flash!).
!