Sign in with
Sign up | Sign in
Your question

bad benchmark result with my x1950 pro

Last response: in Graphics & Displays
Share
March 18, 2007 8:41:09 PM

Hi!

i've just upgrader my computer with a new Powercolor x1950 Pro but i dont get the result i was expected... well, i think theres a problem with something.

the games that i tried to play are very slow for this kind of video card so i have decided to do a benchmark with 3dmark 2005 and my score is 5783 and a reviews on the net showed something like 14000 points.

so now, i dont know if theres something wrong with the video card or the other components. Heres my configuration:

P4 3.0GHz
Mobo P4P800-VM
1gig of memory
Power Supply: Antec Neo HE500
... and im running Vista

if you need more informations, please ask!!
and thanks for your help!
March 18, 2007 8:43:52 PM

It shouldn't get 14000. No way. You must of seen other X1950s, like the XT or XTX.

Based on your system, and the fact you're running Vista, it makes the score about right.

Try running it on XP, it should score little higher.
March 18, 2007 8:55:30 PM

With an X1950 Pro I wouldn't expect anything greater than 9k. I was benching 9500 with an X1950XT with an E6600 on a brand new built system running Windows XP.
Related resources
March 18, 2007 11:01:17 PM

Quote:
With an X1950 Pro I wouldn't expect anything greater than 9k. I was benching 9500 with an X1950XT with an E6600 on a brand new built system running Windows XP.


are you sure???? with my x1950pro I get 10,121.

any way, back to the question:

main reason is the fact that currently the vista drivers are really not up to scratch and every card performs worse than it would on windows xp.
March 18, 2007 11:09:07 PM

well... if you think thats normal, then im disapointed. I had a 9600 pro before and im not sure that i have a big difference. I tried Oblivion with the new card and i thought that i could push the graphic a little bit more but its seems not.

I will try to reinstall WinXP and see what will happen then.

Maybe someone can tell me the configuration he use with the x1950 pro for Oblivion, FEAR or HL2? It will help me to see if i can do the same here or if i really have a problem :) 
March 19, 2007 12:36:59 PM

well i normally play my games at 1024x768 or 1280x1024, iv uninstalled oblivion and HL2 for the time being cause i wasnt playing them for a while


Fear-
Almost everything at max, softshadow off ( switching it on knocks about 20-30 fps off the average and doesnt really give you that big a visual treat), 2xAA and 2xAF (though going 8x and 16X doesnt affect the game play by much, so you can try those aswell...in single player....for multi i preffer higher frames)

Oblivion-
everything at max in game, iv also edited the ini file so that i could see more trees and grass and the textures had been edited to make it look slightly better (without the patch like look if u look at the ground further away) :wink:

HL2:
yet again i set every in game setting on max (atleast i think i did...cant recall the exact settings)
a b U Graphics card
March 19, 2007 12:59:17 PM

You won't get 14,000, no way.
Around 9000-10,000 should be normal, IF THE CARD WAS PAIRED WITH A E6400 core duo that was overclocked to 3 ghz.
Your P4 is severly limiting your benchmark score.
March 19, 2007 1:04:04 PM

Quote:
I had a 9600 pro before and im not sure that i have a big difference. I tried Oblivion with the new card and i thought that i could push the graphic a little bit more but its seems not.


If you're not seeing a colossal difference in your ability to push higher resolutions with eye candy and more framerates compared to a 9600 PRO, something is terribly wrong.
March 19, 2007 1:05:50 PM

Quote:
Oblivion-
everything at max in game, iv also edited the ini file so that i could see more trees and grass and the textures had been edited to make it look slightly better (without the patch like look if u look at the ground further away) :wink:
Yeah right; do you enjoy playing at 5FPS? Or do you play at 800x600? :lol: 
March 19, 2007 1:16:48 PM

I'm getting about 6000 with my system

P4 3.2E @3.6
2x512 DDR400
1950pro 256mb
March 19, 2007 5:11:55 PM

Quote:
Oblivion-
everything at max in game, iv also edited the ini file so that i could see more trees and grass and the textures had been edited to make it look slightly better (without the patch like look if u look at the ground further away) :wink:
Yeah right; do you enjoy playing at 5FPS? Or do you play at 800x600? :lol: 

actually i was getting 30ish fps (first person) outside and around 100 indoors at 1024x768

some spots it would go down to 20ish but hey the game was playable through out. I never felt like it was unplayable.
March 19, 2007 5:48:55 PM

Quote:
Oblivion-
everything at max in game, iv also edited the ini file so that i could see more trees and grass and the textures had been edited to make it look slightly better (without the patch like look if u look at the ground further away) :wink:
Yeah right; do you enjoy playing at 5FPS? Or do you play at 800x600? :lol: 

actually i was getting 30ish fps (first person) outside and around 100 indoors at 1024x768

some spots it would go down to 20ish but hey the game was playable through out. I never felt like it was unplayable.While I'm a bit skeptical, perhaps at 1024x768 it's possible.
March 19, 2007 5:50:33 PM

Well, I'm getting about 6500 on 05 and 3700ish on 06 (give or take a couple hundred points) on XP with a stock 3800+ and an x1800xt 256, so on vista with a P4 that seems about right.

One BIG thing is to check the CCC (catalyst control center) and make sure all the visual options are set to application preference. My buddy reinstalled video drivers and he couldn't play COD2 b/c everything was set to 6xAA and 16xAF and all that good stuff.
March 19, 2007 5:54:07 PM

Sounds to me like your CPU is bottlenecking you for 3DMark.

I got a new x1950Pro yesterday, on an AMD single-core 3700+ @ 2.53GHz, and got 8500 in 3DMark05, 4100 in 3DMark06. Overclocking the card gave very little extra performance, so I reckon my darlin little cpu is not quite up to the job anymore...

Those are XP scores, and I would expect less on Vista anyways...
March 19, 2007 6:33:07 PM

I Get over 14K in 2005.. But thats with my 6300@3.2ghz, and my 1900XT 512mb overclocked as well.
March 19, 2007 9:53:58 PM

Quote:
Oblivion-
everything at max in game, iv also edited the ini file so that i could see more trees and grass and the textures had been edited to make it look slightly better (without the patch like look if u look at the ground further away) :wink:
Yeah right; do you enjoy playing at 5FPS? Or do you play at 800x600? :lol: 

actually i was getting 30ish fps (first person) outside and around 100 indoors at 1024x768

some spots it would go down to 20ish but hey the game was playable through out. I never felt like it was unplayable.While I'm a bit skeptical, perhaps at 1024x768 it's possible.

if you check the vga charts on this site it says that at 1024x768 out doors on max was around 25 fps, so i wasnt that far off :p 
March 20, 2007 8:52:06 PM

ok... i've reinstalled WinXP and did a 3DMark05 test.
The score is 6557 and the CPU score is 3602.

so if i compare with what a few people have here, i have a good score for that card.

thats answer my question :) 

thanks for everyone!
March 20, 2007 11:35:40 PM

the score is higher...but still on the lower side.

Im guessing its the rest of the system bottlenecking it cause you would really expect something around the 9000 range with a good cpu and memory.
March 21, 2007 4:05:29 PM

it must be something else!
if we take the MrSiko's post, he have a good score with a 2.53Ghz and i have a 3.0Ghz with 1gig memory.
March 21, 2007 4:57:32 PM

True, but my AMD 64 3700+ @ 2.53 is faster than your P4 3.0... It does more work per clock cycle, hence better results with same video card...

I still think that it is your cpu that is limiting the results. Time for your upgrade to a Core 2 Duo E6600 or something. Get that little baby up to 3.0 GHz and you will be laughing all the way to the 3DMark bank...
!