Sign in with
Sign up | Sign in
Your question

Large internet file downloading problems

Last response: in Networking
Share
January 7, 2007 9:15:50 AM

Hi all,

hopefully someone has come across this problem before. My Dad's PC doesn't like downloading files that are bigget than a few meg - for example, downloading the FarCry 1.4 patch and trying to run it, it bombs out half-way through the installation saying that the file is corrupt, trying to run the latest Company of Heroes patch it does the same.

Dad's PC is an E6600/Gigabyte 965P DS4 running Windows XP SP2, with Decembers dual-core patch, and it is connected to a Netgear Sky Broadband router using Cat5 cable plugged into the on-board GE port.

When he uses his laptop to download things from the web using wireless on the same router it works fine, so the problem is localised to his machine.

He has tried using both IE and Firefox, but niether one works. Even talked him through ftp last night to download the Farcry 1.4 patch, but still it bombs out half way through the installation saying that a cabinet file is corrupt.


WindowsUpdate doesn't work very well on this machine either; it will download updates, say "failed" when trying to install them, but won't let you download it again because it's already on the hard disk and keeps trying to use the same the same update! I've tried clearing out the internet cache, but this doesn't work and I don't know where else WindowsUpdate stores downloaded updates that have yet to be installed.


Dad has a wireless USB dongle somewhere in the house, so I advised him this morning to try that on the PC to see if the problem is only localised to the onboard GE port or if it's an XP problem. Not heard back from him yet though.


Any thoughts or suggestions?

Thanks in advance :) 
January 7, 2007 7:50:12 PM

Sounds like a hardware problem, maybe ram. Had a similar problem on one of my pc that I built 3 yrs ago.

Download and run prime95, expanding the settings to use most of the ram installed. You will want to monitor temps on startup. This is like a burnin test. It will highly stress the ram and cpu. I have never had any luck with memtest86.

If you have 2 sticks of ram, you may want to remove one and see if it gets worst or clears up.
!