Sign in with
Sign up | Sign in
Your question

Folders on desktop take a long time to open

Last response: in Windows XP
Share
December 15, 2005 11:26:47 PM

Folders like "My Computer" and any shortcuts to folders take a long time to open for some reason (up to 10 seconds). Once it's open browsing between folders is quick like it should be. Programs on my desktop take normal time to open. I've ran all sorts of anti spyware, adware and virus and found nothing. There's nothing that i can say i installed or uninstalled that made it happen, it took me a while to notice it happened everytime. There's also nothing unusual running in the background or in proccesses. Anyone have any ideas?
December 16, 2005 3:11:40 PM

How much memory are you running? any mapped drives or network drives? When opening 'MY Computer' it will check the links to all of these. I have some network drives that arent always available and the same thing happens to me. Nothing really wrong, just windows being a pain in the arse.
December 16, 2005 9:19:28 PM

I have 2 gigs of RAM. There is too other computer's hooked up time mine through a hub, but it's not just "My Computer" that does it. Any folder on the desktop takes a while to open. Even if i just created an empty folder on the desktop it still takes 10 seconds to open. The hour glass cursor pops up for a second or two but goes right back to a regular cursor. 10 seconds later the window pops up.
Related resources
December 17, 2005 5:58:27 AM

I may be wrong, but this feels like Registry glitches.

If this isn't an older system with a lot of "stuff" on it, wipe out your drive (format) and start over. If you have "stuff", throw in a second drive as "D" (Slaved to your existing one, which now becomes Master) and move as much as you can to it.

Then start over. You will be able to access your "stuff" when you complete the reinstallation of XP.
December 22, 2005 12:17:38 AM

Reformatting and reinstalling most of my games and programs is way to much work. Anyone know of an easier and less aggressive fix?
December 22, 2005 1:04:26 PM

try cleaning out your registry. I use Regseeker and have never had a problem with it.
Run it, select clean registry and check 'scan drives for old exe entries in registry'
When done just select all and delete. It will make a backup file for you if you have a problem.
December 25, 2005 11:24:12 PM

No go with the Reg cleaner. Folders still take about 10 seconds to open.
December 28, 2005 12:40:33 PM

Any mapped drives or CDs in the cd-rom?

Did you set up your own DNS or anything? You can get long time outs when you open select folders using DNS which reverts to netbeui over tcp if you're not using the fqdn. :) 

Defragment using a 3rd party application..
December 28, 2005 2:51:00 PM

No mapped drives, nothing in the cd drives. I never touched any DNS stuff, not really sure what you're talking about anyway. I'll try the defrag.

i started up in Safe Mode and everything worked fine. I rebooted in normal mode and tried closing all the proccesses i could but that didn't help. Any ideas?
December 28, 2005 4:12:41 PM

Sounds like something is timing out...

Run MSCONFIG to see everything that is starting up with your computer.. there's a startup tab that will show you. If you see anything you're not sure about or don't need, uncheck them. It will ask you to restart, go ahead.. when it comes up, it will tell you that you have disabled items. Not a big deal.

Check your folders.. if that fixes the problem, it's one of those programs trying to do something.

You can always go through and recheck the box to have the program start back up if you uncheck the wrong thing. You won't cause any harm to your computer doing this.
December 28, 2005 4:27:40 PM

I ran msconfig and unload all startup and system services. Restarted and it worked fine. Loaded just my startup programs, restarted, still fine. Loaded system services and everything is fine and dandy. I guess some service was disabled and caused the slow folder open. Thanks for the help everyone
April 8, 2009 9:18:07 AM

Even i have the same problerm. Can u pls tell me whad did u do to repair it? :bounce: 
September 10, 2009 12:40:31 PM

I have got the same problem. It is due to the change of path. I mean 1st of all let's open the command prompt and after that type "path" then it shows a long path instead of the default path. I found out the root of this problem but not the solution. Does anyone knows how to make that path short/default??
Anonymous
September 24, 2009 12:48:45 PM

The default path for XP is:

C:\Windows\System32\;C:\Windows\;C:\Windows\System32\Wbem

You can change your path by typing this into a command prompt:

PATH=C:\Windows\System32\;C:\Windows\;C:\Windows\System32\Wbem

Please reply if this fixes your problem.
October 9, 2009 1:54:45 AM

i did what you said but the path remains same..no change..i m using vista..

path=c:\windows\system32;c:\windows;c:\windows\system32\wbem;c:\windows\system32\WindowsPowershell\v1.0\;c:\Program Files\QuickTime\QTSystem\

How to change the above path..should we type directly in command prompt or is there any other way..

Thank you
Anonymous
February 28, 2010 4:44:10 PM

Be careful messing around with the path... applications us this to easily find short cuts to applications. For example if you use the command abc.exe, it will search for the file in each of the folders specificed in the path.

It's there for a reason, I wouldn't change it unless you know what you're doing.
Anonymous
June 3, 2010 7:21:21 PM

I had the same problem and just figured out the solution (well, it's a workaround, technically). It seems the slowdown is caused by the folder-based tasks. Once I turned these off, folders open quickly again. To turn these off, under Windows Explorer, click Tools -> Options, and click 'Use Windows Classic Folders'. If you like the folder tasks, it's a bit of an inconvenience, but I don't use them anyway.
March 30, 2012 10:40:39 AM

Move all contents of the folder to another location (even moving them to a new folder on desktop helps). When attempting to delete the old folder, you will most probably find that some program is using this folder, blocking your access. In that case, kill the process by applications such as Unlocker. The new folder will open promptly.
December 3, 2013 5:54:02 PM

Have you tried Long Path Tool? I'm sure this tool will be helpful to your problems.
!