Sign in with
Sign up | Sign in
Your question
Closed

Force Windows to use Ram instead of pagefile

Last response: in Windows XP
Share
December 20, 2005 9:03:36 AM

I recently upgraded my computer from 512mb of ram to 1024. I have used various programs like TweakXP and even Windows itself to try and force everything to load to system ram rather than the pagefile. I have two sata drives stripped in a raid 0. That is still just not fast enough. I will open up my task manager at any given time and my pagefile has got 400mb in use, while my system ram will have 600mb available. What is the deal, can anyone help me? I am running Windows XP Pro sp. 2 on a Pentium 4 2.8c @ 3.4 with a 971 Mhz FSB and 2 WD SATA 80gb with 8mb cache in a stripped raid array with a maxtor 300gb ata 133 with 16mb cache for storage. Xp is installed on the raid array.
December 20, 2005 5:55:37 PM

Set your pagefile down to two mb.
December 20, 2005 5:59:30 PM

Quote:
I recently upgraded my computer from 512mb of ram to 1024. I have used various programs like TweakXP and even Windows itself to try and force everything to load to system ram rather than the pagefile. I have two sata drives stripped in a raid 0. That is still just not fast enough. I will open up my task manager at any given time and my pagefile has got 400mb in use, while my system ram will have 600mb available. What is the deal, can anyone help me?


IF IT's XP
You should dissable paging executive:
regedit:
HKEY_LOCAL_MACHINESYSTEMControlSet001ControlSession ManagerMemory ManagementDisablePagingExecutive
Change DWord 0 to 1
Reboot

Leave your min/max pagefile set to 300mb
Related resources
December 20, 2005 7:24:56 PM

Thank you so much, I will try that. The only problem is that in the event I need more than 1gb of memeory, I would like Windows to use a pagefile, but only If I go over that 1gb not before then. do you know if this is also possible?
December 20, 2005 8:30:22 PM

That's great stuff Tuna!!! That's what I love about these forums; there's always something to learn from someone who knows more than you. I've been around awhile, and never picked up that piece.

I think my "blue collar" reply would have worked as well; but there's nothing like a solid Registry fix.

By the way Pimp, you should consider upgrading your RAM to two gig. Go to Kingston or Crucial and MAKE SURE it's designed for your mobo. It's cheap these days, and you could sell the existing. Then you'll never worry about needing that slow pagefile.
December 21, 2005 12:30:20 PM

My experience with WinXP is that you really don't need to screw with this anymore. For once M$ got it right. If WinXP uses virtual memory before physical memory, it's only to cache rarely-used memory (most often kernel) so that more of the physical memory is free for programs that would actually use it. I've never heard of a performance problem relating to this. In fact, it actually improves performance by making more real RAM available to the programs that need it. (Which is totally opposite of older versions of Windows like 98.)

So I have to ask, are you concerned because you're actually seeing a performance loss? Or is this just paranoia born of prior versions of Windows?
December 21, 2005 1:30:53 PM

I don't need to ditch my old ram, I have another pair of slots. My virtual memory is being used by frequently used programs, not rarely used ones that I could care a less about. I am not seeing a performance loss per say, I am just not seeing what I know to be possible. When I go into my start menu and scroll over to my programs, I have a folder with 64 gamehouse games. My harddrive is accessed and it takes 3-5 seconds for anything to appear. Once I do that once, If I don't do anything else memory intensive, even for days, the programs appear instantly. Also, when I am uncompressing files in the forground, high priority, my page file is in use while there is available system ram. I just want my 1 gb of ram to actually be used, until it is I see no real need for 2gb.

Also Tuna, I went and checked my registery, that value you mentioned was already set to 1, because I had already set it up in the Windows Virtual Memory Advanced area of the control panel. My pagefile is not set at 300mb though, it is set at non-existant. I will try to change it to 300, and I will get back to you.

Thank you all for you imput. I really like talking about this kind of stuff, and I just bore everyone I know to tears when I do. I think I will grow to really enjoy this fourm. :lol: 
December 21, 2005 1:38:37 PM

I'll echo my post. Go to two gig of RAM, and change your swap file to 2mb, NOT non-existant.
December 21, 2005 1:47:06 PM

I am uploading a picture to my webserver of my sysem with a @mb swapfile, and 350 mb being used. I'll have it for you in a minute
December 21, 2005 1:58:30 PM

December 21, 2005 2:11:05 PM

ok problem is that after restart, Windows keeps setting my pagefile to 1535mb even though I have custom checked and set at 2mb
December 21, 2005 3:48:54 PM

This is getting interesting. By the way, nice effort on the picture - but it is unreadable, even expanded. We all will believe you if you tell us stuff.

If you have more than one drive, make sure (other than "C"), that they are set for "no paging file".

If, after setting "C" at 2mb and rebooting, the system is still producing a pagefile, I yield to a higher authority.
December 21, 2005 4:21:26 PM

I scurried around a bit and tapped M$ MVP (and author) Alex Nichol's article on Virtual Memory for some help. The whole document can be found at aumha.org.

He intimates that XP "may" ignore ANY settings you may make, and set a 1535mb or so pagefile anyway.

He also suggests it may be impossible to force XP to live without one. There are "moments" when a cpu needs to address 4gig of memory which almost no one has in RAM.

He also suggests that you can try a low sized pagefile, but that you won't get away with 2mb - 2mb. Set the min @ 2mb and the max @ 50.
December 21, 2005 7:36:55 PM

I will check out that article. Thank you. Are you sure that you can;t read that picture. It is 1024x768 on my screen when I expand it. It is no on my computer, so I should be seeing the same thing as you.
December 21, 2005 8:56:29 PM

The text is barely readable when I expand. I do see the 376 pf.

No matter. You may not get around this. But try the 50 max on the pf setting to see if that helps.
December 22, 2005 12:58:36 PM

i click on the picture and opens in a new window clear as a normal page.
I wouldn't worry about not using a page file. Not haveing one could actually slow down the computer. I have done both and noticed no speed increase by not having one.
Most of the page file is going to be stuff that isnt used that often.
The reason the folder takes longer to load the first time, and it does this on mine, is becuase its not cached.
I wouldnt waste your time with this.
December 26, 2005 9:10:41 PM

Quote:
This is getting interesting. By the way, nice effort on the picture - but it is unreadable, even expanded. We all will believe you if you tell us stuff.


MS Explorer is probably auto-shrinking it. Save it to desktop. I can read it fine w/res at 1280x1024.
December 27, 2005 3:16:44 AM

Good tip. I did what you suggested, and it read just fine.
Anonymous
February 27, 2009 11:52:12 PM

really want to speed page loads, check this out
http://www.eboostr.com/download/

max ram is always good but cant do this much for speed in windows xp!
luck
April 26, 2009 2:00:57 PM

My harddrive is accessed and it takes 3-5 seconds for anything to appear.

- Pimp - I see it's a bit too late to answer - but - anyway.

- I understood your start menu is not working properly. - Now we all got Vista's and this is what you have to do: go to properties for taskbar under start menu->customize and remove the 'highlight newly installed programs' feature at once!

- 2009 !!!!

June 26, 2010 3:40:20 PM

I have a slightly different variation of this problem that I have not been able to solve - I am running a P4 2.8Ghz with XP SP3 1GB ram. The system is not using any physical ram, at least not according to task manager. For example, right now the PF Usage shows 644MB and the Commit Charge at the very bottom also shows the same 644MB (interestingly the Commit Charge in the lower left of the 4 boxes shows slightly higher, 660MB). These numbers always match and I can watch them grow as the pc boots and loads programs.

To me it appears the system is using only the page file and none of the physical ram, so everything takes forever to run.

Anyone have an idea? I have tried tweaking PF settings to no avail and also tried the registry tweak mentioned above.
June 26, 2010 3:49:37 PM

This topic has been closed by Mousemonkey
!