Sign in with
Sign up | Sign in
Your question

Memtest probs with ECC Memory

Last response: in Memory
Share
March 26, 2007 4:53:55 AM

I just put together one of my old rigs which would blue screen like crazy around 4-6 years ago. I placed the rig in my closet and got tired of the slowness of my p3 933 spare rig...So I decided to rebuild the amd 1800+ mp dual proc build. It's running flawlessly which has me mind boggled...but I came across a problem..

I ran my ram in memtest+ 1.70 and it came out with 3 passes so far..Still running right now. switched on ECC mode in my bios and turned on ECC check in memtest and it errored 2 times on the ECC check within 10 minutes...So I reset and disabled it...

Will this cause a problem in my computing environment?...I'm planning to use this rig as a overnight downloader with utorrent...But the last thing I want is bad data being outputted....I don't use ECC since it's erroring but would iut still effect the normal operating with ECC disabled?...Cause so far memtest has succeeded no probs with it disabled.
March 26, 2007 8:07:47 AM

well if u just got that ram send it back to where ever you got it and get a new pair.. otherwise just keep it disabled and keep going. It shouldn't error (I THINK) ive never owned ECC cause its slow and expensive.

I would keep it disabled ive had a pair of ocz gold series error 200 times in 1 min and it would cause xp to restart or "blue screen of death" on me so i had to rma them to newegg and 2nd pair worked flawless.
March 26, 2007 9:21:51 AM

I'd RMA if I could ^.^...But this rig dual amd mp rig is ancient...Around 6-7 years old. All the parts are the same as it was once built. I just removed everything and having it running off the bare essentials..(1 hard drive, 1 cd rom....It had 2 gigs of ram but it has 1.5 now since I gave one of the modules to a friend. They're all ECC but I guess they are busted.....But the fact they atleast work in normal mode makes me happy. Got memtest running next to me still...Been running for almost 10 hours...5 passes so far no errors...going to let it run overnight then I should be fine.

Thx for the info though ^_^...glad to know that just because they're busted in ECC doesn't mean I can't run the ram normally.
Related resources
March 26, 2007 4:41:05 PM

The ECC modules themselves just have extra bits to hold the ECC info - the actual processing gets done by the memory controller, so your problem may be there, or it may be in the ECC-storage part of a DIMM. I'd try testing one DIMM installed at a time to see if only one has the problem. Even if they're 7 years old, decent memory usually has a lifetime warranty, so you might be able to get one replaced.
March 26, 2007 5:37:36 PM

I am not sure if Memtest works well with ecc memory. Download the Microsoft memory tester and see if you get the same results. If memtest shows errors I always double check it with MS memory tester because memtest has been known to give false readings.
March 26, 2007 6:45:40 PM

really?...Interesting. Thanks for the info guys. I'll try the MS memory testers as well then. I just dislike the fact of letting windows boot with faulty memory...lol..But I have no choice ^.^. I'll post the results when it's done.
March 26, 2007 9:19:57 PM

Quote:
I am not sure if Memtest works well with ecc memory. ..... ....memtest has been known to give false readings.

There's no reason memtest86+ shouldn't work fine with ECC memory.
rcs: in what sort of situations has memtest86+ given false readings?
March 30, 2007 4:14:43 AM

memtest86+ seems to ignore ECC on my SuperMicro server board (5000P chipset). ECC is reported as *off* and the configuration menu has no impact. When I filed a bug report with Debian I discovered that someone else had filed a previous report about ECC not being supported for a number of chipsets.
March 30, 2007 5:56:44 AM

Interesting...It was working for me though. I enabled it in the bios (had it disabled) and it posted correctly inside of memtest. It was just not checking for it. I set up memtest to check it and it was ECC checking as well although it failed. Also my computer was acting REALLY weird with ECC enabled. The computer wouldn't post for like 25-30 seconds..Then finally it starts up. Restarted a few times and same result each time. I disabled it of course but I made sure to test it once with memtest which gave ECC errors on the checking. But yea...It performs rock solid without ECC...I ran two simultaneous first pass encodes via virtualdub with xvid...Then encoded both videos at the same time. Both of them came out flawlessly..Computer was at work for around 9 hours at 100% cpu usage and no flaws.
!