Sign in with
Sign up | Sign in
Your question

IWILL WON'T

Tags:
Last response: in Opinions and Experiences
Share
Anonymous
July 27, 2001 4:23:59 AM

I have had a horrific experience with IWILL and even a casual perusal of AMDMB.COM among others will indicate I am not alone.... I tried to work with these guys but NADA! Today I even got hung up on while on hold for TechSport (er support) naturally they haven't even bothered to respond to this...... (note: I am not a foamer.... Just a 56 year old consumer who has finally lost his temper)

Dear IWILL,
All Right Guys where do we go from here????? It, the replacement mobo, has the same problem as the Original Mobo!!!!

Several Comments... The replacement has the FSB set to 100mhz and I clearly stated in the request for RMA and my conversations with support that I have a "C" model CPU which runs a 266mhz FSB..... At the 100mhz setting it worked for about 15 mins and then locked up.... I let it sit for about 2 hours and tried again and got the same thing..... After letting it cool down I set the FSB jumper to 133 mHZ and it locked up with in a minute........I have been sitting there watching your PCHealth display and the CPU fan is indicating about 4400 RPM and the CPU temperature never got over 90 degrees Fahrenheit so that looks like it rules out CPU overheats .... If it had been tested at 133 mhz this would have shown up.... I believe you (IWILL) have a QC problem with your boards and for sure with the RMA replacements based on my experience and several threads being reported on AMDMB.COM forums...(btw I note that you even had problems with Jack Shubert News Editor cadjack@3dgpu.com http://www.3DGPU.com who had a very similar experience to mine) All the components have been tested in other machines and work fine (including the CPU).... BTW the test consisted of running at least 24 hours....... The replacement board has a 0515 BIOS so that problem is not here.... I am extremely upset... I have been trying to get this thing going for almost 2 months.... I am writing to you will all the components installed in a TYAN T-400 mobo with a PIII-650..... I have now spent over $50 shipping RMA parts around at your behest! AMD will not entertain the return of another CPU saying that the first one worked when they tested it (I spent the bucks for a Retail Box so I could get the warranty) and that they have heard of similar reports with IWILL mother boards and that I should note that the KK266 is not AMD approved and there must be a reason for that! At your behest - I have upgraded the power supply, an Enhance 300 watt unit, to a PCPower and Cooling 425 watt unit, Sent the CPU back to AMD, replaced the video card (a Creative TNT2u to a AOpen GeForce2/mx) replaced the memory, etc etc etc.... in the interim I am at the point where the Internet Pirate I bought the Mobo from won't take it back since I have had it too long....

I am an electrical engineer by training and a Systems Engineer for a very large OEM manufacturer for over 30 years and I literally do this hundreds of times a year so lets forget the stuff about "You must have screwed it up"!

IN MY PROFESSIONAL OPINION YOU HAVE A VERY SERIOUS QUALITY PROBLEM THAT SHIPPING "HAND PICKED BOARDS" TO REVIEWERS CAN NO LONGER CONCEAL! (I theorize that you might have a component heating up in the Northbridge due to the symptoms)

I HAVE SPENT OVER $400 OF MY OWN MONEY (NEW PARTS - SHIPPING - RMA) AND LITERALLY HOURS ON HOLD AND WAITING FOR CALL BACKS THAT DO NOT EVER OCCUR TRYING TO FIX YOUR-IWILL'S PROBLEM!

WHAT ARE YOU (IWILL) GOING TO DO TO FIX THIS PROBLEM???? I HAVE HAD IT!!!!!

IF I DO NOT RECEIVE SATISFACTION I INTEND TO PLASTER YOUR NAME AND REPUTATION ALL OVER THE INTERNET!

IF I DO NOT RECEIVE SATISFACTION I FULLY INTEND TO REPORT YOU TO THE FAIRFAX COUNTY VA CONSUMER PROTECTION AGENCY AND THE US BETTER BUSINESS BUREAU!

I AM WRITING AND COMPLAINING ABOUT THEIR DEFECTIVE TESTING METHODOLOGY TO THE REVIEW SITES WHO GAVE THIS PRODUCT FAVORABLE RATINGS! WITH ANY LUCK THEY WILL RESPOND IN AN OPEN FORUM!

In case you lost it here is my hardware configuration, AGAIN!

FONG KAI FK320 CASE, with optional 120mm inlet fan and 90mm CPU ducted fan
PC Power and Cooling 425 watt "turbo cool" ATX Power Supply
IWILL KK266 Mother Board, rev. 1.2 BIOS 0515
AMD Retail Box K-7 Thunderbird CPU @1.2Ghz with a 266Mhz FSB
512mb of ZEUS PC133 Memory ( 2ea 256mb sticks )
ADAPTEC AHA39160 SCSI Host Adapter (ver. 3.10.0 Bios)
3ea. Seagate Cheetah Disk drives (1ea 18 gig and 2ea 9 gig units)
Seagate 4mm Dat drive (tape)
YAMAHA 2100s SCSI 16x10x40 CD writer (BIOS rev. N)
AOpen PA256 Mx Video Card (GeForce 2/Mx)
3Com 3C905b Network Interface Card
I am using the onboard sound.....

More about : iwill

Anonymous
August 12, 2001 2:01:15 PM

HAPPY ENDING! I finally got a RMA replacement that works on Thursday and have been running it ever since. It installed and setup fine with absolutely no setup problems at all. Just like you would expect. I guess the 3rd time is a charm. It is a shame that I had to rant and rave (and wirte to Taiwan HQ) before someone took the time to actually test and configure a mobo for me. According to Joey at IWILL USA he actually hand picked and tested and burned in this board for me. It was still a 1.2 with the 0515 BIOS..... According to what I have been able to piece together from all my conversations with many IWILL USA employees here is what "may be happening" they "may have" sold a huge shipment to a West Coast Retailer (may be FRY's??) who has a no questions asked return policy and apparently a customer based "dumber than dirt" (install failed due to no heatsink or heatsink on backwards! my mother didn't like the color , I installed it in my wool underwear and now it doesn't work) They have returned a large number of boards, the percentage may be small but the actual volume isn't. Consequently IWILL's RMA department may be overwhelmed and a "large percentage" of these returns may be "failure denied".... So someone in the RMA or Quality department "may" have been putting an unknown quantity back into stock with inadequate testing"... Results we all may or may not be having problems!
LOL and Good Luck to you all!
!