Sign in with
Sign up | Sign in
Your question

network Issue

Last response: in Networking
Share
January 20, 2007 8:24:43 PM

I just purchased a seperate IP address for my apartment, reason being I wanted to run my home-network (router) on one IP and a seperate Computer on another IP so it can bypass having to use the router. My network setup is this...

Network Diagram:

{Cable Modem}
|
|
Switch
port 1:{from cable modem}
port 2:{to Seperate Computer} //Assigned seperate IP
...
UplinkPort: {To Router} //Assigned seperate IP
|
Router:
Internet Port: {From Switch}
Port 1-3: Other Computers
Port 4 (uplink I believe): empty

Roughly I have my internet connected to switch, with the router and computer on the switch...both of which should have there own IP address.

MY PROBLEM: For some reason, I can only get one of the two IP addresses to be assigned at one time. They both get the appropriate IP address but only ONE of them works at a time. When one is up and running the other will not get assigned anything EVEN if I put in the IP/subnet mask/gateway/DNS addresses manually. Any clue what I'm doing wrong? Obviously both router and seperate Computer are DHCP enabled...I've tried other configurations but I'm pretty sure this is the proper setup.

More about : network issue

January 20, 2007 10:04:31 PM

I don't see why you need 2 IP except for running a server and most all ISP's block port 80.

Your setup is correct, but your modem can only handle 1 connection (IP), So you will need to install a 2nd modem.

You could just use the router, then set up a DMZ with the second IP.
January 20, 2007 10:16:34 PM

well there are ways around the port 80 block but, I don't want this as a server, not for the most part. My problem is with my router and this computer, I've tried DMZ but it doesn't work the way I need it.

I'm not sure if my modem can handle more than two IP's or not, I wouldn't think they would give me another IP if it couldn't handle it but...they are not the smartest people I have dealt with.
Related resources
January 20, 2007 10:27:10 PM

Do you have a second router to connect in place of the Pc?

Switch to 2 routers.

Is your FW blocking Public IP's? Disable FW's...
January 20, 2007 10:49:09 PM

I tried disabling my firewall still nothing.

I tried using it with another router that I have, "switch to two router", still nothing :( ...and I called my ISP and they said the modem can handle two IP's so...I'm lost! My setup should be working!
January 20, 2007 10:55:22 PM

Connect 1 router and turn off DHCP and connect through the lan port, NOT the WAN or internt port. Then connect 2 pc's with DHCP enabled and see what happens.
January 20, 2007 11:00:44 PM

explain that a lil more...
January 20, 2007 11:10:38 PM

What I want you to do is turn your router into a switch.

To do this you need to turnoff DHCP in the router, then move the Cat5e cable from the WAN (internet) port over to a LAN port. You must then set your pc's to obtain IP automaticly.
January 20, 2007 11:18:00 PM

Actually, shouldn't the uplink port on the switch be plugged into the cable modem?

Also, bear in mind that USUALLY the port next to the uplink port is "shared" and will no work if you have an uplink cable in.
January 20, 2007 11:26:59 PM

NO, you need to bypass the WAN on the router.

Your switch has not worked so I want to use the router.

Not all switchs have deadicated uplink ports.
January 20, 2007 11:32:09 PM

Quote:
NO, you need to bypass the WAN on the router.

Your switch has not worked so I want to use the router.

Not all switchs have deadicated uplink ports.


Sorry, Blue, wasn't going through your posts, just was responding to the original post. Can't tell you how much money I've made with that little bit of unknown knowledge.

I definitely agree with you that router configuration is the way to go here.
January 20, 2007 11:49:31 PM

yes the uplink port and port 5 on the switch are "Linked"..........
and the uplink on this switch is used for other lan devices (hubs,switches,routers...)

Ok well I tried disabling the DHCP, and enabled it on my pc's and moved the internet cable to a lan port and couldn't connect to the dhcp on any computer.
January 21, 2007 12:35:21 AM

Did your ISP issue a Static IP, Or DHCP as you previously stated?

Did you look at your port IP info?

And did you disable the firewall on the pc's??

Then reboot and check again. Just to make something is not hungup.

It should have been issued at least 1 IP address.
January 21, 2007 1:12:11 AM

DHCP, ok I tried again and this time the "seperate" computer managed to connect to the DHCP, but I tried another computer and it wouldn't connect...it may take a little more time than I allowed for the ISP to recognise the new mac address of the other computers I was trying to get to connect...I don't know.

I was being rushed by a bitchy roommate :p 
January 21, 2007 1:34:04 AM

I've had ISP's reset MAC address and some times they tell me 24 hr others 1-2 hrs. If you did not give them and MAC address Info I havn't a clue. I wonder if they are needing that info for there systems. The reason the one computer only connects? Most of the ISP I have dealt with use some form of MAC filtering.

I just do not have firewall active when I am have problems they just complicate the problems.

Good luck, You have enough knowledge to continue. Your original setup should have worked. Some switch can be reset so they dump all of their mapping. My switch is managed, has a menu option.
January 21, 2007 2:15:44 AM

yeah, thanks I'll work on it alot mroe later tonight when I don't have someone down my throat about being on, and post if I need anymore help. Thanks for everything so far!
!