Sign in with
Sign up | Sign in
Your question

Video/Games stutter when moving mouse.

Last response: in Components
Share
March 27, 2007 2:05:06 AM

I use a Razer Copperhead Laser mouse and have just recently reloaded my machine. I have acquired an issue I have never had before.
When playing COH or using Media player 11 the video will stutter or lag when I move my mouse.

I am using XP pro (32 bit), Warcat 7.2 ATI drivers, Ati tray tool.
Video settings are:
1680x1050, 2AA, 4AF, Cat. A.I. Disabled, Mipmap- Performance, Enabled geometry instancing, Support DXT formats. On a Dell 2007WFP

Any help would be greatly appreciated!

OH Crap!! I'm sorry I think I put this in the wrong place!!!....LOL!! Sorry.
March 27, 2007 2:47:30 AM

Are you running the newest driver. Try back a rev or 2? maybe the mouse driver is "overclocking" the USB port. They seem to do this to get more communications per second to the PC, but it can cause issues.

If it was just COH i was gonna blame Issue 7(or are they up to 8?) :) 

I find my mouse is less smooth but i think its the cordless going, or my damn P5W's ps2 ports. Since they do not like my KVM or the other one i got to replace it. I assume they are underpowered.

Well...Post your results as you go so other can see the fix when it is found.
April 1, 2007 3:49:50 AM

I have this very same problem. My specs are as follows:

Asus P5WD2e-Premium
Pentium D 805 @ 3.6ghz
2x1024 OCZ DDR2-800 rev2
2x160 Seagate in Raid 0
ATI Radeon x1950pro
Sound Blaster Audigy
Windows XP SP2

Whenever I move my mouse, cpu-usage hits 50% in Windows. In game, it must be hitting 100% because the game completely stops until I stop moving the mouse. It's basically like hitting pause while moving the mouse. I've tried the following games:

Warcraft 3
Half life 2
Guild Wars
Call of Duty 2
Battlefield 2
FEAR

The only exception is Battlefield 2. It works pretty much fine. The menu's lag a bit (in between rounds, the "join game" button doesn't work if you're moving the mouse :p  and the menus are a little laggy but in-game, mouse-movements are tracked as normal). Also, in FEAR, while the mouse causes stuttered movement, I had my xbox360 controller set up and it worked fine (it was using joystick axis, not emulating mouse movements). This leads me to believe that this issue is not related to USB ports. However...

Since I've tried more than 1 mouse in more than 1 USB slot and I've even tried using an xbox360 controller to emulate mouse inputs and none worked, this is not an issue with the Copperhead. I tried updating the drivers/firmware of my Copperhead, however, and was unable to update the firmware; just the drivers. I got an error when trying to update the firmware. Did you try this?

I decided to boot up a few more games just to make sure. First up was Quake 4. It worked flawlessly. It's running openGL. So I got curious and booted up Prey. It worked flawlessly as well. I don't really know what this means but I've already re-installed directX and it didn't do anything for me. This more or less rules out hardware unless OpenGL doing something with mice beyond my comprehension (I'm thinking no).

So it could be a USB issue but it doesn't look like it to me. Someone with more experience and knowledge may have a better answer than I.

So the conclusion I have so far as that BF2 is doing something (or not doing something probably) that the other games are not because it works fine while in-game. And it doesn't seem USB related as the rest of my devices work as expected (nostromo n52 and xbox360 controller and this very keyboard I am using to type this, the Microsoft Ergonomic Keyboard 4000).

Any help or insight is greatly appreciated.
Related resources
April 1, 2007 6:10:07 AM

Quick Update: I tried deleting directx as per instruction on some random site. Of course, this didn't work and would not allow me to reinstall directx. I reinstalled Windows and while that fixed my directx issue, the stuttering issue still stands!

Startin' to think this is a virus...
April 1, 2007 3:52:30 PM

Another update:

This was being caused by a process being started up by Windows. Not sure which one but I shut off a few questionable ones in msconfig (Start -> Run -> "msconfig" -> Startup tab).

Here are the following that I shut off:

ALCMTR (realtek onboard sound)
CLIStart (ATI related)
CTHELPER (Creative soundcards related)
CTXFIHLP (Creative X-FI related, even thought I don't have an x-fi...)
DLM (fileplanet download manager)
ADGJDET (some audigy thing)
mppds (apparently some trojan that steals account information for certain online games. Super)
RTHDCPL (Realtek sound manager utility)

At least after disabling all this I was able to resolve the issue with directx-based games. I'm not sure if the trojan was to blame but I am now going to get rid of it and keep my fingers crossed that that was the issue.

Edit: I deleted the supposed trojan mppds.exe. It was in the Windows folder. You can find the .exe and the .dll easily by searching c:\windows. I'm not sure if this was the root of the problem but it looks to be as none of the other startup items I disabled looked to be an issue except the x-fi entry. I ran spybot and it didn't pick anything up. I will run trendmicro's housecall scan today (http://trendmicro.com) and see if that picks anything up.
April 1, 2007 11:25:39 PM

Well I got mine fixed. For whatever reason when I rolled my CPU back to 3.70GHz it stopped!?!

Any ideas?
April 2, 2007 12:08:18 AM

All you did was clock your cpu down and it fixed it? Because I didn't do that at all. I have a 50+% oc (from 2.66 to 3.6ghz). I resolved my issue by turning a few non-important things off in the startup. The items that I did turn off were related to my audigy and onboard sound (and we're not the processes using up the cpu. Task Manager was showing up as using the cpu when I moved my mouse, not System Idle Process.

Either way, we both resolved our issue but by different means. Hopefully if something runs into these severely annoying issue, they will be able to resolve it through one of our solutions.
April 2, 2007 2:07:34 AM

Yeah I looked at what you did and tried some on my machine but it did not help.
So figuring that the only thing different to my PC since the re-load was the fact that I had OC'ed the CPU further, I opted to check that and well the rest is history.
It is weird though having the exact same problem with the same mouse and two different fixes! :?
April 2, 2007 7:32:25 PM

Well, it wasn't the fault of the mouse at all. I tried several other mice with no results (including mouse pointer emulation with an xbox360 controller).

If it did happen to be the mouse, it would just be an excuse to buy a DeathAdder :) 
April 2, 2007 9:42:37 PM

:D  YUP :D 
!