Sign in with
Sign up | Sign in
Your question
Solved

Can't get application to run on startup.

Last response: in Windows 7
Share
July 23, 2011 7:58:11 PM

I am attempting to have an application run on startup. I put the application in the startup folder in the start menu, but that didn't work. It shows up under startup in msconfig, and the box is checked, but when I restart the application does not run. Any ideas?
a c 209 $ Windows 7
July 23, 2011 8:11:43 PM

What kind of program is it, and how sure are you that it doesn't actually run and then perhaps exit immediately due to some unexpected condition?
July 23, 2011 8:27:29 PM

The application is called CPUID HWMonitor, and I am not sure that it doesn't initially run and then exit, I just assumed it doesn't because when I run it manually it has not exhibited that behavior as of yet.
Related resources
a c 209 $ Windows 7
July 24, 2011 1:59:45 AM

When you run it manually, does it give you a UAC prompt? If so, that might prevent it from running at startup.
July 24, 2011 4:11:11 AM

Yes, there is always a UAC prompt. So UAC = no startup? Seems odd. Anyway around this?

Best solution

a c 209 $ Windows 7
July 24, 2011 3:55:26 PM
Share

I don't have any personal experience doing this myself, but you might try using Task Manager as suggested by the last post in this thread: http://www.techspot.com/vb/topic139324.html
July 24, 2011 6:36:47 PM

Using the Task Scheduler works perfectly. Thank you very much for your help sminlal, I really appreciate it.

Just in case the link dies, here is what it says (and it worked for me, at least the first time):

- Start Task Scheduler
- Create basic task, give it a name
- Set trigger as When I log on
- Set Action as Start a program
- Point Program to afterburner executable file
- Set Add Arguments to: -T
- check "Open the Properties dialog for this task when I click Finish", click finish
- Select "Run with highest privileges", OK

July 24, 2011 6:36:59 PM

Best answer selected by jsanthara.
!