Sign-in / Sign-up
Your question
Closed

USB Flash Memory stick recognition problem

Tags:
  • Drivers
  • USB
  • Windows XP
Last response: in Windows XP
February 19, 2006 7:38:43 PM

Hi all,

I have a question relating my DEll USB Key 64Mb

Recently I had problems doing a repair on my computer (concerning cable select on DVD-rom drive and DVD RW-drive) At that time they asked me to change physically the two drives to be able to reboot from the windows XP CD.
This worked fine (thanks for the help :-)) Anyway after repairing Windows XP home edition, and after reinstalling all the updates (SP1 and SP2) i encountered a strange thing.

When I plug in my USB key, it will be recognized by the computer (mentioning "new hardware found", but the drive doesn't show up in the "my computer folder". If I then go to the Device Manager under Computer Management, I see the USB Key, but it isn't assigned to a Drive. When I then map it to a drive, let say F or G (used the two) and close the menu it will still not show up under windows explorer.

other apparatus working with an USB cable, such as my printer do not cause any problem, I also tried to put it in different USB ports, no change.
I don't have a network drive mapped to the F or G drive, so this could not be the problem, as mentioned in other forums.

I can access the drive via the Device manager, put copying files is such a pain in the **s, since it doesn't allow long names or something.

Please help me out, Because I have no Idea what could be the problem...


greetz Genehunter

More about : usb flash memory stick recognition problem

February 22, 2006 2:06:42 PM

Have you tried to reformat the drive?
Its possible that the computer is trying to assign a drive letter that is already in use. Ran into this problem at my work with drives that are mapped automatically at login.
What are the drive letters for all drives?
You might try changing the optical drives to n and m.
March 8, 2006 8:58:44 AM

Hello friends i have the same problem with my usb stick too

suddenly the windows cannot recornize it and in the divice manager
windows found it "unknow divice"


i have too xp home + sp2


the other usb stick i have works fine in this computer

and the usb stick with the problem works fine in other 3 computer i test it

with win 2000 and xp pro+sp2

it must be a windows problem
but i cant find a solution

Friendy Dimsot
Related resources
March 16, 2006 3:04:15 AM

Hey, I've ran into this problem with a few customers of mine, it seems that Windows has a common issue with network mapped drives, and jumpdrives not recognizing if certain letters are mapped. If you have not made any particular changes to your system, and this has just all of the sudden happened, I have ran into this is a few times as well. The first obvious thing it looks like you have already tried; make your ROM's ec.t. different letters as the previous poster stated, then retry. If this doesn't work, you may wish to edit your registry and remove all of your previous USB/USB STORAGE registry key entires, clearing previous entries. This part of the registry holds all previous information about hardware, and by flushing the USB / USB STORAGE portion, it normally has fixed this issue when I have ran into it before. I caution, editing the registry incorrectly WILL CAUSE PERMANENT DAMAGE TO YOUR COMPUTER!!!! If you are not comfortable editing the registry DO NOT DO IT, get a qualified computer technician to look at the issue for you. Myself, as well as Toms Hardware cannot be held responsible if you do not know what you are doing. I personally have performed the following registry changes to many Windows XP/Windows 2000 machines, and have never had any issues with USB devices afterwards, but this MAY NOT be the answer.
The registry keys reside in the registry (click start, run, regedit) under the following keys:

HKEY_LOCAL_MACHINESYSTEMCurrentControlSetEnum
edit: (Slashes may not appear in this forum for some stupid reason...)
It is: HKEY_LOCAL_MACHINE, SYSTEM, CurrentControlSet, Enum

Under the headings USB, and USBSTOR. What you have to do is right click "USB", click "permissions" click the "Allow Full Control" checkbox, and OK. Once you have completed this, right click the "USB" key, and click delete. Do the same for the "USBSTOR" key, deleting them both.

Restart the PC, wait a few minutes on startup, as it will re-find any USB devices attached to the system, it shouldn't but may ask for drivers disks, but almost all USB drivers are previously stored/saved on the PC, so it will recall them. After this has completed, plug your USB Jumpdrive back in, and it should recognize.

If this does not work, not sure what else ot tell you, your probably into a Windows XP Repair load, or a backup/reformat/reinstall. Please post back even if this works, or for any questions pertaining to these instructions.
March 16, 2006 7:08:26 AM

Hey friends

I tried everything that dg6464 said and ever more
(delete file "infcache.1" )

2 solve this problem
but nothing happens


Finally the problem solved by luck

i put i Kingstone usb stick and after that

EVERYTHING WORKS FINE
May 10, 2006 12:44:56 AM

I had similar problems, but noticed that the USB Key Drive appeared correctly within the "Disk Management" panel of "Computer Management". (To access, right-click My Computer, select "Manage", then click "Disk Management" under the Storage heading.)

The USB Key Drive appeared here, with the correct drive letter.

I could also RIGHT-CLICK THE DRIVE AND SELECT "OPEN", which would successfully show the contents of the drive. Alas, it still did not appear in Windows Explorer.

Then, I did the following:
* In Disk Management, I removed the mapped drive letter
* I "safely removed" the USB Key Drive
* I quit and restarted Disk Management
* I remounted the USB Key Drive
* The USB Key Drive then appeared in Windows Explorer again!
* I then re-mapped the drive letter

So, it definitely appears to be related to a mapped drive letter. Removing it may help your mount. At worst, you might be able to at least view the contents via Disk Management.

By the way, reformatting the USB Key Drive did not assist.

Good luck!
July 4, 2006 12:18:53 PM

Hi Guys,

I discovered something very interesting with my machine today which in turn has to do with this. I'm running Windows XP 64bit recently upgraded from 32bit. I had thought that there was a problem with XP64 as my usb-stick and usb external hard-drive ceased to work properly. I couldn't see them in Windows Explorer but could see them with an assigned drive mapping in computer management.

It took me a little while but I knew that I had previously used the external drive on my system before in xp64 and had to be something else that I did. What I managed to track it down to was that I had mapped a drive to my brother's computer that was now inaccessible.

As soon as I deleted the drive mapping, bang, it appeared straight into windows explorer.

If anyone else is having this same problem this could be a fix for it.
July 25, 2006 12:32:16 AM

I have the same problem except the device shows up under device manager under drives, but not under disk management and it will not show up in explorer either. I have tried pluggin the jumpdrive into every port on the computer and I have the same problem, but when i plug it into another computer it works fine. Every other usb device i plug in works fine. I haven't been able to try a different jumpdrive yet. I also noticed under the properties in device manager i am not able to change the settings for quick removal (2nd tab i think). Also this problem came out of nowhere it had worked in the computer for about 6 months and then all of the suddent this happened.

My system stats are:
-Windows Xp Pro
-AMD 64 3700+
-512 mb ddr

Here is what i tried so far.

-Everything that has been posted in this forum
-Reformatting the jumpdrive via a different computer
-Installed the beta version of vista onto the computer and had the same problem
-reformatted the entire harddrive and installed xp x64; still nothing

Any suggestions would be greatly appreciated.
a b \ Driver
September 9, 2012 8:52:04 AM

This topic has been closed by Mousemonkey