Sign in with
Sign up | Sign in
Your question

How can I get RoboCopy to copy *ALL* NTFS permissions?

Last response: in Windows 2000/NT
Share
April 27, 2006 4:27:00 PM

I am trying (hard!) to run RoboCopy with these options:
[code:1:bc642a9dec]C:robocopy.exe "G:/Finance" "G:/TestDatabases/Finance" "*.mdb" /SEC /S /FP /NP /r:1 /w:1 /LOG:"C:Logfiles/Finance.txt" /V[/code:1:bc642a9dec]
It copied all of the folders, subfolders and files properly - with their correct NTFS permissions with one crucial exception: the folders which contained no files did not receive their appropriate permissions. In otherwords, folder "X" would only get the appropriate NTFS permissions if folder "X" contained at least one file in folder "X" itself. Any folder that contained subfolders (even infinite levels deeps) would receive their appropriate permissions only if they contained at least one file...

Please let me know if that is not clear. This is crucial I get this working - and it seems like this is 99.9% of the solution!

PLEASE HELP...

Thanks!
Eliezer
October 17, 2006 1:52:21 PM

Not sure about RoboCopy. I know that SecureCopy tool has some options for this. Some weeks ago we have used it for migrate data from our server to new one.
http://www.scriptlogic.com/securecopy
March 27, 2010 3:06:49 PM

I have used SecureCopy in the past but today I am convinced that CopyRight2 is the better solution. It has way more features, is less buggy and it costs a fraction of what SecureCopy costs. You may wanna give it try: http://www.Sys-Manage.com

Ed
!