Sign in with
Sign up | Sign in
Your question

Web, FTP Hosting and Port Forwarding

Last response: in Networking
Share
February 7, 2007 5:41:35 AM

Hello, I have a rather simple problem. I cannot forward any ports through my modem/router to any computer on my lan. I have been able to do this in that passed. But I changed to a static IP through my ISP and my wireless router dumped. So I got a grand spanking new linksys wrt54g. My old one was a dlink 524. I am kinda glad it died because it always would freeze. Continuing on...

First off my modem is an Actiontec GT701R. I have done some digging and found that this is not just a modem, but a a 'gateway device.' So it has some properties that a router would, it uses a NAT. My isp is Qwest.

When I had the portforwarding working with my Dlink and with a dynamic public ip, I had my set the dlink to connect using PPPoE and put my user name and password in the router. I used the dlink router to forward ports and what not. It worked great. Since I was doing a lot of remote access i decided to pay a little more for the static IP. Coincidentally my dlink router decided to die.

When setting up the linksys router there was no way i could connect through PPPoE. I had to set it to DHCP and everything worked great except the portforwarding. I have tried just about everything.

At the moment I have the router acting as a WAP/switch. The modem is not plugged into the WAN port on the linksys, but in a lan. So the gateway for my machines is my modem.

When I hit my public IP form my own lan I get the login from to enter the configuration on my modem.

I am not willing to call Actiontec and pat $30 for them to help me. My ISP wont help me either. They refer me to actiontec. Does any on have any suggestions for my on this problem? I am pretty sure that it is not user error on the UI on the devices. I think it is the way I have my network setup. If you need any more info from me please just ask. Thank you!

EDIT: ew. should have posted this in General Gateways, Routers and Firewalls. =/
Anonymous
February 7, 2007 10:35:12 PM

You shoudl be able to setup PPPOE on the Linksys otherwise you're doing double NAT.

Grumpy
February 8, 2007 7:15:29 PM

Double NAT doesn't hurt anything as long as LAN A (between Actiontec and router) is different than LAN B (between your router and your computers). Actiontec can have port forwarding, but I don't remember the menus at the moment. You could either look up the same settings with the Actiontec, or forward all traffic to the Linksys and setup the same stuff you had before. As I don't know what you had before, I don't know how to help you set it up, but the Actiontec, Linksys and DLink all have relatively the same feature sets, despite the Actiontec being a DSL router, not an Ethernet router.

I'm curious, who is your ISP and what's your metro area? i used to work for a DSL ISP
March 15, 2007 10:35:48 AM

I have the self-same problem with similar configuration, different hardware.
I have a Binatone adsl2000 modem/router/gateway. I have setup port forwarding - ports 20 and 21 to forward to 192.168.1.12 my local tcp address on LAN.

YET, when I FTP://"my public ip address" I get connected to the adsl2000 admin login at 192.168.1.2

I have tried all reasonable configuration changes, fixed and dhcp assigned addrresses even accessing my ftp server using a setup domain name...NO JOY!
I can access the ftp server fine using the LAN address whether fixed or dhcp assigned

Norrie
!