Sign in with
Sign up | Sign in
Your question

Gameing/File sharing problem on network

Last response: in Networking
Share
December 28, 2003 7:47:07 PM

I currently have 3 computers connected to a Di-604 router. Two run XP and one runs windows 98.

All three computers can easily connect to the internet through comcast high speed internet at the same time, but file sharing doesnt work between the two xp computers and I havnt tried it on the 98 computer as its rarely used. Xp computer 2 can see the computer in the workgroup, but cannot acces computer #1 because it says he needs to contact system administrator even though computer 1 is sharing. Also, if I make a LAN game, the person on the other computer cannot see it and we cant join the same internet game.

XP #1
ip as whatismyip.com says 24.118.121.197
ip assigned by DHCP 192.168.0.101
subnet mask 255.255.255.0
Default gateway 192.168.0.1

XP #2
ip as whatismyip.com says 24.118.121.197
ip assigned by DHCP 192.168.0.101
subnet mask 255.255.255.0
Default gateway 192.168.0.1

Please, we really need to be able to play games together online, any help would be greatly appreciated.
December 29, 2003 1:17:30 PM

Have you noticed that the local IP's of both machines are the same? This will stop them talking to each other! If your router is a DHCP server and it is providing these addresses, then it is set up incorrectly!! If your router isn't doing the DHCP, what is exactly ??

But since doing the network bit manually is easier for me than trying to help you fix a DHCP server, then here's what you should try:

(I assume that the Router's IP address is 192.168.0.1, as you say you can connect to the net on both PC's and this is the default gateway.)

1. Set XP#1's IP manually to 192.168.0.2

2. Set XP#2's IP to manually 192.168.0.3

Subnet mask the same on both, 255.255.255.0

Leave the gateway as it is.

This is likely to solve your problem.


PS Also make sure both PC's have the same workgroup name (and different computer names!) to be able to see each other in the Network Neighbourhood.

Fatal Error #449: Unable to process the "Go to Hell" command specified.
December 31, 2003 1:51:39 PM

Ill second that comment.

You can set the router to be the dhcp server by setting it in the options. You will need to set each computer to obtain ip numbers automatically. You can do this under internet options. Or do what was mentioned before.
Related resources
December 31, 2003 7:56:10 PM

I'm having this same problem. How do you manually set IP addresses for each computer? How can you check to see if they're the same?

-----

In a world... where nothing is interesting...

<A HREF="http:// www.nosmarts.com " target="_new">http:// www.nosmarts.com </A>
January 4, 2004 9:50:28 PM

Start>Control Panel>Network Connections
Right-click your LAN connection>Properties
Internet Protocol(TCP/IP)>Properties

[Edit: missed a step]


<P ID="edit"><FONT SIZE=-1><EM>Edited by arkus on 01/04/04 06:51 PM.</EM></FONT></P>
!