Sign in with
Sign up | Sign in
Your question

very unique problem (lenghty post)

Last response: in Windows XP
Share
June 26, 2006 7:46:09 AM

Hello all, I'm currently having some issues with Clean Installing windows XP on a beat up old Dell Latitude. I just wrote an email to Dell tech support, but I thought I'd copy paste it here in case any of you gurus out there can toss me some suggestions before the Dell folks!!! I warn you this is a very long post, so don't bother reading it unless you have a bit of spare time, or are REALLY keen to help me out, which of course I really hope you are :) 

Apologies in advance if I've placed this in the wrong section, or if posts of this length/content are not welcome here.

cheers!!!


-----------------------------------------

Greetings. I am currently having a bit of trouble with my Dell Latitude D505 and I was wondering if you might be able to help me sort things out.

My situation is quite unique, and I believe it warrants a bit of prior explanation.

The laptop was given to my father’s research assistant as part of a medical study that was conducted several years ago. During the course of the study, the laptop was unfortunately stolen from my father's office. There was almost no question that it was lost forever, however, lo and behold, almost three years later the police approached my father with news that they had recovered the laptop! The company who gave it to the research assistant had assumed it was lost, and therefore said they did not need to have it back. It was for this reason that my father decided to give me the task of caring for the laptop. There was a catch however, the laptop did not start. After some quick tinkering I noticed that all of the RAM had been removed from the laptop, along with the CD/DVD drive. Everything else was intact, so when I went to future shop to purchase some replacement memory, the computer booted fine! My next challenge was cracking the windows XP user account password (easy enough with the help of some google searching).

Generally I like to keep my computers very clean, and when I finally got it booted up this laptop was far from it. There was adult content, and other offensive material saved on the hard drive. Definitely not the type of environment you want to expose your younger sisters to, if they happened to need the laptop for a school project or something similar. My first thought was to re-install a fresh copy of windows XP. As I do not have any of the Dell recovery CDs, or documentation, I decided I would use an extra copy of winXP Home Edition SP2 that I had lying around.

Now here comes the tricky part. Without a working CD-ROM drive, I knew it was going to be very difficult to install the fresh copy of winXP. After various attempts such installing over a network and installing over the original OS I found that I was having trouble formatting the original system partition, apparently due to the fact that the vital setup files were stored on that drive.

I did some further thinking, and came up with what I thought at the time was a viable solution to my problem. I would use the third party program, Partition Magic” to create a new partition from the existing free space on the old C: then proceed to install windows to this new partition (by copying all of the files from the CD to a folder on this newly created drive).

This step worked as well as I had expected, I managed to get a working fresh install of WinXP on this new drive and booted up with no problems at all. I even managed to install some drivers and get the computer running far better than it had previously.

Now came the issue of the old install of WinXP, back on the C: drive. My next action (which I now realize was a bit hasty seeing as I am not the most experienced user of partition magic) was to simply format the old C: drive partition using Partition Magic. The format went well, but at the end of it all I soon realized my pitfall, as the computer would no longer boot!

I did some research on the internet, and discovered a very useful website which informed me that all I needed to do was override some of the boot.ini settings, and tell the computer that I was actually booting my OS from a non-default partition. They even provided a boot-disk that miraculously enabled me to once again boot my new install of winXP!

Figuring that I had solved the problem, I quickly checked out the free space on the C: and discovered that in fact it had been formatted successfully (strangely enough, even though there were no visible files, something was taking up ~500 mb of the partition). I wasn’t too concerned with this loss of HD space, so I carried on to the next step of my setup plan.

With a fresh copy of WinXP now installed on a ~3 GB partition, and 15GB of free space on my original C: partition I now desired to merge these two partitions in hopes that I could cure the boot problems I was having and consolidate the hard-drive allocation.

Once again, I utilized Partition Magic to complete this task, and again everything was executed as I had instructed. However, I was still having serious boot problems. In fact they were now turning into something a bit more drastic. Instead of getting the “NTLDR is missing” message (as I had received before the merging) I was now getting a “no bootable devices” message. With my old windows boot.ini disk no longer working for me, I was at a loss for what to do. More searching on the net led me to creating 2 boot-disks (using the partition magic rescue disk creator) and giving them a shot.

Success! (well sort of). I was able to boot into the low-fi version of partition magic and was able to gather some valuable information about my problem. Apparently my current drive setup was as follows:

one unlabelled drive of type “Unallocated” and size 47.0mb with none being used, this drive was Primary.

one drive labelled “Windows XP”, type “NTFS” with 3.3 GB of used space, and 15.6GB of free space. This drive was set to “Logical” and the status set to “None”.

Being that I had previously read some information about these settings, on the internet and in partition magic, I decided that I had better change some things around on my WinXP drive.

Currently, the drive is setup as follows:
Label still = Windows XP and type is still NTFS. The space remaining/taken is still the same, however I chose to change the drive to “Primary” and set its status to “Active” as my reading instructed were the appropriate settings for a partition with an OS installed.

Now when I try to boot the computer, I get a flashing underscore right after the opening screen, and no more booting seems to occur. My Partition Magic rescue discs still manage to get the computer to boot, however, I receive an error saying that “partition magic is unable to read the batch file. Verify that the System32 directory is not compressed or corrupt” I am able to get past this error message and it appears that Windows XP is loading, however the load hangs indefinitely in the screen right before the user login (the screen with a 2 toned blue background, and a little windows logo saying Welcome).

More searching on the internet, and running a scan of the drive in Partition Magic informed me that I had error 1516 “Partition improperly dismounted”. I found that this problem is usually related to the switching of drive letters (which I unfortunately executed during the merging of the partitions; I changed the drive letter of the system partition, E: to C:; I believe this is the cause of a lot of the trouble I’ve been having).
The web resources also informed me that there is generally a quick fix to this problem, and that was to run CHKDSK /f from the Windows Setup recovery console (accessible via the WinXP boot CD-ROM/floppy).

As was previously stated, the CD-ROM option was right out, so I tried the old-fashioned way and made up a set of 6 boot floppies using Microsoft’s utility.

I managed to get to the Windows Setup Startup screen without a problem, although it took a while to load the temporary drivers, especially with having to change disks all the time. But to my great horror and dismay, on inserting the sixth and final floppy disk, I was presented with a great big “blue screen of death”. It was complaining about some System32 folder being corrupt. Frustrated as I had ever been with computer technology, I forgave any further internet searching and went to blow off some steam at the gym.

Now, with that out of the way, I am back trying to solve my problem. Right now I have narrowed it down to one step. All I really want to do at this time is run the CHKDSK /f utility, but as you can see I am having a heck of a time executing that command when I have no working CD-ROM drive and any windowsXP boot floppies I try result in a blue screen of death. I briefly looked into booting from a USB flash device, and over a network, but did not have much luck in either of these departments. Right now all I need is some alternative way to tell this blasted machine to run CHKDSK /f, and I’ve run out of ideas on how I can accomplish this.

With this email now approaching the size of a mid-school English essay, I will not bog you down with any further details. Hopefully I have been clear in conveying my problem; I have tried to be as thorough as possible in explaining it, as I realize it can be quite heard to grasp, especially through an email. If you need any further information, or have suggestions of where else I could find support for this type of issue please just let me know and I will be happy to send a quick response.

Thank you so much for your time, and I hope to hear from you soon!!!

-Paul Holland
June 26, 2006 2:50:57 PM

Well, I can imagine what Dell is going to tell you...

Purchase a CD-ROM (or CD-RW or whatever) drive and order a replacement restore CD. Those will be your simplest options. Might be a little more cash than you want to spend, but the time it will save and the ease at which you'll be able to accomplish this task will make it worth it.

To me, that is your best option.
June 27, 2006 4:20:26 AM

I saw numerous CD-ROM Latitude drives on eBay for about $10-$20, and CD-RW/DVD drives for $40-$50. Just pick up one of those and save yourself future headaches and hassle.
Related resources
September 6, 2008 8:40:24 PM

What useless answers. I just hit the exact same problem, but you folks really don't solve anything. I'd be interested to find out how the original poster finally resolved the issue. Wish there was a way to point PM to the right batch file...
September 7, 2008 3:13:50 AM

Useless? Whatever. Buy a CD-ROM drive, install it, and there you go. I really don't understand what you find so "useless" about it. If you can't find an internal drive to fit your laptop, buy an external. Then you are able to use the XP CD to format and reinstall. I'm sorry you find such as simple solution useless.
September 7, 2008 12:02:57 PM

"Now when I try to boot the computer, I get a flashing underscore right after the opening screen, and no more booting seems to occur. My Partition Magic rescue discs still manage to get the computer to boot, however, I receive an error saying that “partition magic is unable to read the batch file. Verify that the System32 directory is not compressed or corrupt” I am able to get past this error message and it appears that Windows XP is loading, however the load hangs indefinitely in the screen right before the user login (the screen with a 2 toned blue background, and a little windows logo saying Welcome)."

does partition magic give you any options after it lets you boot?
iT sounds like you need to change the primary back to where it was as that was the partition that had the NTLDR setting on it

Another possibility is that when using the floppies and got to the welcome screen did it give you a option to repair the install or F8 to get to a command prompt?

Don't click Install when prompted! Instead, click Repair Your Computer in the lower-left corner.
In the command-prompt window, type the following commands and press Enter after each one:
(Please note that these are vista commands but I think they will still work. If not it should be bootcfg see below)

bootrec.exe /fixMBR
bootrec.exe /fixBoot
Close the command prompt and click Restart.

If all else fails get the floppies sorted out to get to the point where you can F8 to get a command prompt with networking and copy the files over and start over

ps another thing to try from a command prompt
type bootcfg /?
This explains the switches . Please note that you can type bootcfg (switch) /? and get better details on that particular switch.

!