Sign in with
Sign up | Sign in
Your question

USB Boot not supported. Now What??

Last response: in Motherboards
Share
April 6, 2007 4:08:30 PM

Hey everyone, got another problem.

My Dad's office had a few extra computers, and I managed to snag a couple. They are Dell Dimension L1000R. 1GHz P3, 128mb of RAM, 20GB HDD, CD-Rom, Floppy. Pretty Basic.

Anyways, I wanted to make a file server. I got FreeNas, and an extra 160GB HDD. I wanted to install FreeNas on a Flash Drive and boot from there. However, after installing to the flash drive, I realized the BIOS does not support booting from the USB! What can I do now?

Ive heard that it is possible to boot from a CD that tells the computer to boot from the USB, but could not find any info on it. Just to say, I installed FreeNas on the 20GB HDD, and everything worked. I've checked Dell's site, and I have the most recent Bios update.

Thanks for any help!

More about : usb boot supported

April 8, 2007 2:06:50 PM

Oh com'on!! Somebody has to know! Easy question:

Bios does not support booting from the USB port. What can I do to force a USB boot??

Thanks
April 13, 2007 6:47:49 AM

Here's a workaround that worked for me. Well, got it to the boot loader and it to recognize the USB memory stick to boot off of. The boot itself failed, probably because I copied Knoppix to my USB stick incorrectly-some permission error after Xserver starts. Anyways, different problem different day...

Here's what I suggest you try:
Create a Linux boot floppy with USB modules so it can recognize the USB drive in the boot loader (my terminology may be a bit off, but you should get the idea). I did some research on this and came across this article: http://linuxgazette.net/116/okopnik1.html . Adopting the techniques in that article and using my Knoppix 3.6 or 3.7 CD, it was able to create the boot floppy that recognizes a boot partition on the USB key.

Hope this helps...
Related resources
April 13, 2007 12:33:27 PM

Thanks alot for the response! I was getting desperate!

I know exactly what you mean. Something like Grub (from Ubuntu) Thanks for the idea! I will try this this weekend and report back next week.
April 16, 2007 10:04:25 PM

:(  :( 

I'm confused. When I download Grub, I get this tar.gz file. NP. I just use 7-Zip to open it. After opening it, all I get are these files and folders. None of them are recognized with Windows. I have no idea what to do. On the same note, I tried Grub (Legacy)'s documentation of how to make a Bootable CD-Rom. However, the tar.gz file does not contain a "stage2_eltorito". It's not there. I have no idea what to do.

I've also tried a couple of others. I tried GAG. It didn't recognize my usb drive. I got a "stage2_eltorito" file from SuperGrubDisk, but it turned out to be a command line program, and I have no idea how to make it boot, or recognize it for that matter.

I want a boot loader that can boot FreeNAS from a USB drive.
FreeNAS is based on FreeBSD and is already installed on the USB drive. Thanks a bunch!!
April 16, 2007 10:29:42 PM

get a different USB stick?
April 16, 2007 10:55:20 PM

You sure you don't have USB Emulation support in the BIOS? That stinks.

As for the tar.gz file, did you read any info on it? You probably need rawrite.exe to write it out. Or, how about burning the install for FreeNAS to CD? There's plenty of options besides booting to USB.
April 17, 2007 1:45:08 AM

I don't see how a different USB stick will help. Bios still won't boot into it. And I've checked a couple of times, and in the boot devices list, USB drive/ USB HDD isn't there.

Quote:
Or, how about burning the install for FreeNAS to CD? There's plenty of options besides booting to USB.

Wait you don't understand, I've already made the CD-ROM, and then installed FreeNAS to the USB drive. All I need to do is to boot from the USB drive to run FreeNAS.

Thanks for all the responses! Keep them up! (plz)
April 17, 2007 3:20:02 AM

FreeNAS must be ran from a USB drive I take it.

Sucks for you.
April 17, 2007 3:30:18 AM

Quote:
FreeNAS must be ran from a USB drive I take it.

Actually no. But to simplify things (nvm now), I wanted to just make the whole 160GB drive for storage, and the OS (FreeNAS) off the flash drive. Mostly so FreeNAS's operating files arn't tampered with. In other words, I didn't want my family screwing up FreeNas by mistake. (no part of the flash drive would be shared)

And plus I had other plans for the original 20GB drive and using 32megs of a 20GB drive is kinda a waste. (less than a fifth of a percent used)
April 17, 2007 3:32:24 AM

If your motherboard does not support USB emulation, and does not boot from USB, then there is not much you can do.


You could buy an lockable 5 1/2 drive bay hard drive enclosure and when you dont want them mess'n with it, turn off the drive and lock it.
April 17, 2007 4:25:16 AM

If the PC is an old P3 and doesn't support booting from USB, it probably won't support 160gig drives either.
FreeNAS only requires 32meg of space, install it on the HD and test the thing first before spending time & money on something that might have other problems.
April 17, 2007 4:34:06 AM

another solutions that that uses flash memory would be to use Compact Flash insted of usb drive. you use a ide to CF or buy a ide CF drive. then the computer just see the CF as a normal ide hard drive no speacial bios required.

i am all so looking into this for my own home network but not for a month

this the one i was looking at
Addonics IDE CF adapter


Have fun and good luck
August 28, 2009 5:44:24 PM

PROBLEM SOLVED!!!!!!!! I notice this has been inactive for quite some time now...thought I still would respond. I just got this same problem when creating a "demo" freenas for my family yesterday. Threw it on an old celeron 700mhz that doesn't support usb boot. After a couple of hours of fiddling around I managed to get a floppy disk to boot and <a href="http://sourceforge.net/forum/message.php?msg_id=5777790">with this guys help</a> perfected it enough to work like a charm. Wish I would've found that site first! lol I now leave the floppy in the drive and if I restart freenas (or if power goes out and back on) it automatically reboots on the floppy and then the floppy sends it straight to the usb drive and the usb automatically finishes booting. It takes about an extra 30-60 seconds to boot since it has to read the floppy first but very much worth the wait. Here's EXACTLY how mich this method "costs": 30 seconds worth of downloading, about 15-20 seconds worth of un-zipping, about 60 seconds to "burn" floppy and like I said 30-seconds added to each reboot. Since it's a "headless" unit I don't think a few extra seconds on a reboot matter to many. Anywho, in these steps he does tell how to load freenas onto the usb too but I wouldn't follow that rout, just do that the old-fashioned way buy cd booting (if possible) and selecting "create hd/usb/cf" from menu. What the heck else is a celeron 700mhz gonna do???? lol Perfect for a small family household (2 people) of "non-techies." Anyway, hope this helps somebody eventually! Cheers!
October 1, 2010 5:25:21 AM

hi IJ, I am looking for the resolution of booting from USB while my BIOS is not supporting the function.
Glad you found one so I might like to borrow your method. But the link of the forum does not available any more. If you still get this message please share what the steps to fix your problem. Thanks. -OJ
Anonymous
a b V Motherboard
October 3, 2010 12:54:13 PM

It seems this thread has got sporadic posts over the months and years so I will add one.
I recently wanted to get my old 128MB Compaq going again.

It will run a minimal XP SP3 and but only one app at a time (once settled down Firefox is fine on it.) Antivirus/MS Updates, almost every thing has to be off.

So I thought I would try a Linux USB boot. No BIOS Support.


But Google turns up many bootloaders now.

I tried PLoP which worked fine. (Install it from CD). Don't have any USB drives flash or ext hdd hanging off when you install, cos it messes up on booting to Windows on hda1 when you don't want Linux then.

I can't run Ubuntu/Mint etc 128MB is too much. But Puppy works fine.
However, I want to do it again and I want to try another bootloader so I am hunting again and came across this.

Many seem trialware (PLoP is Freeware). I am working my way through this Google search.

PLoP here:- http://blog.brothersoft.com/2008/12/09/boot-computer-fr...

My Search is:- http://www.google.co.uk/search?q=bios+not+support+usb+b...


Happy Booting all
!