Sign in with
Sign up | Sign in
Your question

HELP !!! onboard LAN not working !!!

Tags:
  • NICs
  • Components
Last response: in Components
Share
April 7, 2007 9:45:39 AM

My configuration is: Asrock 4CoreDual-VSTA LGA 775 Motherboard, Intel D 915, 2x512 DDR 400, ATI Radeon 9550 256 mb 128 bit AGP, PCI tv-tunner ASUS MyCinema P7131 DUAL, 200gb SEAGATE SATA 150.
I am running Windows XP and I am able to install the 10/100 onboard LAN (VIA Rhine II), but the local area connection alway prompts "network cable is unplgged". I have tried the enable/disable bios setup command several times but no luck. I have tried several bios setups and the default settings also but still no luck. I am absolutely sure the cable is working for when i plugg it in another PC it's working. I have tried setting IP's and DNS's but won't work (obviously since I get "network cable is unplgged" wouldn't expect it to work this way ). I have used my waranty and exchanged the motherboard for another one (same model). Still the same problem. HELP !!!!

More about : onboard lan working

April 11, 2007 11:52:20 PM

A "network cable unplugged" message is usually an indication that you have a hardware problem.

Do you get a link light?
- Try another cable. Look to see if you get a link light as soon as you plug in the cable (you should see a light in a second or less)

- Look at the other end of the cable, the link partner. Check for a link light there too.

- Make sure you have PXE (pre-boot or sometimes called LAN boot) disabled

Is the driver loading?

What happens when you run driver diagnostics (what error messages does it display).
April 12, 2007 5:57:09 PM

It's really weird.There's a problem with the cable. However the cable works only when i use the 10 Mbps setting of the LAN card. if i leave it auto or 100 Mbps the DNS settings simply won't work but the IP's are ok....it's strange...i guess the cheap onboard lan simply cannot work with this weak signal. Well the cable is 120 meters long i forgot to mention :)  =)))))). My previous motherboard had a Marvell Gigabit lan...obviously better than a VIA 10/100.
Thanks.
Related resources
April 12, 2007 7:00:50 PM

Um, you do know there's a max cable length of 100m for cat5 and cat5e cables, right? You're probably experiencing just a weak signal due to the length. You'll probably either need a repeater or something similar.
April 13, 2007 6:26:55 PM

Sounds like you have 120 meters of CAT3. Get a shorter, i.e. less than 100M, and make sure its CAT5 not CAT3.

Rob Murphy
April 19, 2007 5:57:16 PM

IEEE spec says that Ethernet must work to 100 meters. So not working at 100M at 100Mb/s or higher is not entirely a surprise, but it's pretty normal to get 120 meters or more.

It makes some sense that the 10Mb/s is working since a 100Mb PHY usually can attain greater distances at 10 .

Best guess, try another cable. It coule be that the insertion loss (attenuation) for that cable and the connectors are not that good. The suggestion that it's a CAT3 cable (or a CAT3 mislabled as CAT5) is possible. If you're sure the cable is good, replace the connectors and make sure it's not been severely kinked (or other knots) or entagled with wires other cables that tend to affect attenuation.

Try two shorter cables with a switch in-between (I know, this idea sucks... but it will help isolate the problem)

By an add-in NIC from Intel or Marvell. VIA and Real-Tek "tend" to make inexpensive products (which is why you tend to see them in MB all the time) but not great products.

Good luck!
!