Sign in with
Sign up | Sign in
Your question

Windows hangs on start/classpnp.sys/possible SSD issue?

Tags:
Last response: in Windows 7
Share
July 25, 2011 9:39:12 PM


I’ve been searching this and other forums all day, and haven’t found a solution that has worked to this problem. Hopefully someone can give me a hand.

My computer had a video driver crash yesterday (happens once a month maybe). As I normally do, I restarted the machine, but for the first time ever the Windows Startup Repair tool started. It threw an error saying it could not fix the problem, and then windows continued to load—only to hang on the startup screen (immediately before the logon screen).

I tried starting in safe mode, and the system hung at classpnp.sys (either on it or on the file immediately after it, I’m not sure by slasspnp.sys was the last one to display).
Roughly at the same time as the hang occurring, the status light on my OCZ Agility II SSD (on which the OS is loaded) changed from green to red.

In addition to trying to start in safe mode, I’ve tried various windows diagnostics (system restore, startup repair, etc.) using the Install Disc, and reset the BIOS. All non-essential external peripherals were removed. No change in anything.

With the exception of a faulty mobo (which was replaced in the P67 recall anyway) when I first built the system and the occasional graphics driver crash, the system has been running problem free since it was built.
So, the big questions: is this a system issues (I’ve seen several complaints regarding Windows 7 hanging and/or classpnp.sys) and if so, how do I fix it? Or is it a hardware issue (in which case the fix is pretty obvious)?

Windows 7 Home Premium x64
CORSAIR XMS3 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600
Gigabyte GA-P67A-UD3-B3 Motherboard
Intel Core i7-2600K
GIGABYTE GV-R687OC-1GD Radeon HD 6870
OCZ Agility 2 SSD (Primary HD)
HITACHI Deskstar 7K2000 (Data Drive)
EDIMAX EW-7128G Wireless Card
Hauppauge WinTV-HVR 1850
LG DVD-RW
600W Rosewill PSP

Any thoughts/assistance is greatly appreciated.
a b $ Windows 7
July 25, 2011 10:48:46 PM

Most likely the SSD is corrupted. What I would do is trot over to OCZ and tdowload the toolbox for the Agility II/ Vertex II. Use the toolbox to do a secure erase. and then reinstall the OS.

Minor problem is that the SSD must have all partitions deleted. Easiest way is to use your Win 7 installation disk. Select custom install and on page that ask where to install, Delete ALL partitions (should be two). then exit installation.

Next problem - need to boot to an operating system with the OCZ SSD on a Intel controller. I think you can use Linix as a boot CD, but you need to check OCZ on that. I did a secure erase of My agility III by connecting it as a 2nd drive on my back-up I5-750, Had no problem.

Once that is squared a way - USE win 7 Back up to crease an image of your C drive so that in the event you need to reinsall operating system And Programs juse use this image file. Takes about 5 min to create the image on to an HDD. But sure cuts down on installation time plus do NOT have to reinstall all them pesky programs.

Then try to resolve the rare System crashs.

Added: If above fixes the SSD, recommend starting a new thread regarding the crashs
!