Sign in with
Sign up | Sign in
Your question

Should be a quickie: Video Driver

Last response: in Linux/Free BSD
Share
July 23, 2006 7:18:52 AM

I'm using FC5 Linux on a Pentium D 805 system with a GeForce 7900GT video card and I just went to nVidia's website to download a driver. There are two choices I have, one is "Linux IA32" and the other "Linux IA64" (there are actually several more choices that I don't think are for me). And I honestly don't know which one to get. :^(

FC5 is a 64-bit operating system, right? So I think I need to get the IA64 driver, but I really don't know... can anybody help?

More about : quickie video driver

a b 5 Linux
July 23, 2006 9:25:38 AM

Quote:
I'm using FC5 Linux on a Pentium D 805 system with a GeForce 7900GT video card and I just went to nVidia's website to download a driver. There are two choices I have, one is "Linux IA32" and the other "Linux IA64" (there are actually several more choices that I don't think are for me). And I honestly don't know which one to get. :^(

FC5 is a 64-bit operating system, right? So I think I need to get the IA64 driver, but I really don't know... can anybody help?




You can only use the IA64 driver if you have an Itanium.

The P4 D 805 does not support IA64.

It does support x86_64 or EM64T however it runs slower in 64bit mode than it does in 32bit mode.



If you installed FC5 i386 you need this IA32 driver:

http://www.nvidia.com/object/linux_display_ia32_1.0-876...

If you installed FC5 x86_64 you need the x86_64 driver:

http://www.nvidia.com/object/linux_display_amd64_1.0-87...


They are not interchangable so you need to verify what version you installed.

[code:1:26207b357b]
uname -a
[/code:1:26207b357b]


The output will be something like this:

Linux localhost.localdomain 2.6.17-1.2157_FC5smp #1 SMP Tue Jul 11 23:24:16 EDT 2006 i686 i686 i386 GNU/Linux


or this:

Linux localhost.localdomain 2.6.17-1.2157_FC5 Tue Jul 11 23:24:16 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux


http://download.nvidia.com/XFree86/Linux-x86_64/1.0-876...

To install:

[code:1:26207b357b]
ALT+CTRL+F1

# login as root

init s

wget http://download.nvidia.com/XFree86/Linux-x86/1.0-8762/N...

#or

wget http://download.nvidia.com/XFree86/Linux-x86_64/1.0-876...


sh NV*.run --check

sh NV*.run

# follow the prompts

[/code:1:26207b357b]


good luck :-D
a b 5 Linux
July 23, 2006 2:10:03 PM

:trophy:

That should just abaout do it, the only thing I'd add is, after completing those steps
[code:1:7503b3f533]//still in "single user mode" , i.e. the mode you've entered after typing "init s"
lsmod|grep -i nv
//make sure there's an "nvidia" module, if not type "modprobe nvidia" to put it in

init 5
//This will get you back to the graphical mode (runlevel 5).
//After logging back in, verify that you have openGL acceleration
//open a terminal, "Applications->Accessories->Terminal"

glxi[tab] // this shows tab-completion, a really nice thing for getting around in terminal-land
(now on the command line)glxinfo (add this)| grep -i opengl[enter]
//Make sure NVidia is listed here and your card is properly recognized.[/code:1:7503b3f533]
Related resources
a b 5 Linux
July 23, 2006 5:46:12 PM

Again I forgot that wget is not going to work due to lack of internet access :cry: 

The wget will have to be executed on a system with INET access, then the file must be copied to the Linux box.
July 23, 2006 6:34:24 PM

Thanks guys for your help.

But I am having the same problem I always have when I try to run any file in a terminal... it says the file doesn't exist. I have absolutely no idea how to point the terminal in the right direction to locate a file.

I simply typed in everything exactly the way that you told me, but on the "sh ..." command it says the "NV*.run" file does not exist. Is there a directory I'm supposed to put files in so the terminal can find them? How do I get the terminal to realize that the file actually DOES exist and I need to run it?

Thanks again for your help.
a b 5 Linux
July 23, 2006 6:47:25 PM

Quote:
Thanks guys for your help.

But I am having the same problem I always have when I try to run any file in a terminal... it says the file doesn't exist. I have absolutely no idea how to point the terminal in the right direction to locate a file.

I simply typed in everything exactly the way that you told me, but on the "sh ..." command it says the "NV*.run" file does not exist. Is there a directory I'm supposed to put files in so the terminal can find them? How do I get the terminal to realize that the file actually DOES exist and I need to run it?

Thanks again for your help.



# become root

su -

# or login as root in the GUI

# copy the .run from the nVidia website into /root

cp /media/cdrecorder/NV*.run /root

# assuming you put in on a CD then

sh NV*.run --check

sh NV*.run
July 23, 2006 6:58:23 PM

It is on a CD, but it said the file didn't exist when I tried to copy it. Heh.

I'll just copy it in GUI mode then try the sh command line again.

And can you please tell me what I was doing wrong earlier? I copied the file onto my desktop, then Ctrl+Alt+F1 into Text mode, then entered the command "cd /home/tyler/desktop," then "sh NV*.run --check". Why did it say the file didn't exist?

[EDIT]
When I try to install it, now it says that I "appear to be running an X server, please close X before continuing." Since I have not yet set up a server, I don't know why I would have any server software running and I definitely don't know how to close this mystery software.

Ya know what? I really don't think Linux is right for me, Vista is sounding better by the minute...
a b 5 Linux
July 23, 2006 7:21:32 PM

Quote:
It is on a CD, but it said the file didn't exist when I tried to copy it. Heh.

I'll just copy it in GUI mode then try the sh command line again.

And can you please tell me what I was doing wrong earlier? I copied the file onto my desktop, then Ctrl+Alt+F1 into Text mode, then entered the command "cd /home/tyler/desktop," then "sh NV*.run --check". Why did it say the file didn't exist?

[EDIT]
When I try to install it, now it says that I "appear to be running an X server, please close X before continuing." Since I have not yet set up a server, I don't know why I would have any server software running and I definitely don't know how to close this mystery software.

Ya know what? I really don't think Linux is right for me, Vista is sounding better by the minute...





My instructions included a key command:

init s # this will kill the GUI so you can install the nVidia driver




ALT+CTRL+F1

# login as root

init s

# ignore the wget's

#### wget http://download.nvidia.com/XFree86/Linux-x86/1.0-8762/N...

#or

#### wget http://download.nvidia.com/XFree86/Linux-x86_64/1.0-876...


sh NV*.run --check

sh NV*.run

# follow the prompts


# ignore the wget's
July 23, 2006 8:46:00 PM

It actually wanted me to install it in runlevel 3 (telinit 3 was the command line, I think). I just tried again and now it says that no precompiled kernel interface matched my kernel. Then it failed to compile one because it couldn't find the kernel source tree... and it said something about a command line to point to the kernel source tree. To tell the truth, I didn't understand a word of any of this.

On the bright side, I am finally getting the hang of using the terminal. I've just been practising changing directories and running programs and I think I'm getting it. :^)
a b 5 Linux
July 23, 2006 9:02:47 PM

Quote:
It actually wanted me to install it in runlevel 3 (telinit 3 was the command line, I think). I just tried again and now it says that no precompiled kernel interface matched my kernel. Then it failed to compile one because it couldn't find the kernel source tree... and it said something about a command line to point to the kernel source tree. To tell the truth, I didn't understand a word of any of this.

On the bright side, I am finally getting the hang of using the terminal. I've just been practising changing directories and running programs and I think I'm getting it. :^)




Log into the GUI as root

Copy the kernel-devel RPM from the install CDs to your HDD into /root

then

cd /root

yum localinstall kernel-devel*.rpm

# or

rpm -Uvh kernel-devel*.rpm
a b 5 Linux
July 23, 2006 9:26:50 PM

Just a little hint that makes navigating in the terminal much easier: tab-completion.
Example: You have the file "NV-something-or-other.sh" in the cd-rom directory "/media/cdrom/"
[code:1:8741e223d2]cd /me[tab] (this should place "/media/" on the command line)
cd [tab][tab] (should show all of the contents of the /media directory)cdr[tab]
cp NV[tab] /r[tab][/code:1:8741e223d2]

In regards to it asking for kernel headers, simply install the kernel source headers to get it to work properly.


Select "Applications->Add/Remove Software". Enter the root password.

Search for "kernel headers", many should show up

Open a terminal ("Applications->Accessories->Terminal"), become root ("su[enter]ROOT_PASSWORD[enter]") and find out the kernel you have ("uname -a")

Find the kernel headers in the "Add/Remove Software" area that match yours (see picture, note checkmark). Select it and hit "Apply"

Let this complete

*Make sure to put a symbolic link in place so that the headers are where the installer is expecting them, i.e. note that in the terminal in the pic, "/usr/src/linux" points to "/usr/src/kernels/2.6.15..." This can be achieved with the command "ln -s /usr/src/kernels/YOUR_KERNEL /usr/src/linux". Make sure that the link exists with "ls -l /usr/src/". When typing in the paths here, be sure to try to use tab-completion.

Try the installer again.

*Why do you need a symbolic link and what is it, exactly? A symbolic link is a way to redirect a file or directory request from one area to another, i.e. when go to visit someone's office and they have a noteboard that tells you they are in the lab. Why do you need such a thing? It is an unfortunate truth that different Linux distributions tend to do some things a little differently. Fedora, for example, does not put the kernel headers in the place that most other distributions do. As such, you have to make it appear like they are or move them so that they are. Moving them can break some Fedora-specific things, so it is just easier to tell the installer where the kernel headers can be found.
July 23, 2006 10:17:03 PM

When I select "Add/Remove Software" it tells me that the software information could not be found.

I give up, I'm reformatting my hard-drive and installing Ubuntu. I'll see what I can do after that.
a b 5 Linux
July 23, 2006 10:49:41 PM

Ah, right, that message is because of no network connection. There are ways around that, but give ubuntu a try.
July 23, 2006 11:31:22 PM

I'm burning Ubuntu to a disc as I write this.

Anyway, I wanted to ask you all if you could find a suitable Linux driver for my sound card. It's a Sound Blaster Audigy2 ZS Platinum. Unfortunately, Creative doesn't supply Linux drivers for their hardware (well, none that I could find anyway), and a search of Driver Guide didn't seem to turn up much.

Any help would be greatly appreciated!
a b 5 Linux
July 24, 2006 12:38:22 AM

Basically, any of the newer "user-friendly" distros will support it via ALSA. You can verify this by looking at the boot messages ("dmesg|less" then looking for the ALSA stuff). My main desktop machine has a Audigy2 ZS in it, and it's supported by ALSA and the EMU10k kernel driver (a module in every user-friendly distro)
July 24, 2006 4:30:50 AM

It's good to know I don't have to find a driver for it. But I'm having problems with my sound. I'm sure you can help me, since you have a very similar sound card...

I have Dolby 5.1 speakers with three line outs (rear, front, center), but only one of the line outs on my sound card makes any noise... I'll explain. I *have* to plug the speakers into the SB's line out (front) to get any sound out of them. Neither of the other two line outs on the SB make any noise at all when speakers are plugged into them.

Any idea what the problem could be?

Oh by the way, I didn't get Ubuntu. I brought the disc home and analyzed it, it failed the checksum test. :^(
a b 5 Linux
July 24, 2006 1:53:30 PM

Be sure to check the mixer settings. Not sure exactly where they are in the menus (away from my computer) but I know you can check them with the "alsamixer" utility.

Open a command prompt and type "alsam[tab]" to open it. It's very DOS-esque (actually called "ncurses" type of display, named after the library used to make the "graphics"). Any listed with a "<MM>" instead of "<##>", e.g. "<50>", are muted.

There should be some for balance and fade to "center" the sound.
a b 5 Linux
July 25, 2006 2:14:19 AM

Quote:
Be sure to check the mixer settings. Not sure exactly where they are in the menus (away from my computer) but I know you can check them with the "alsamixer" utility.

Open a command prompt and type "alsam[tab]" to open it. It's very DOS-esque (actually called "ncurses" type of display, named after the library used to make the "graphics"). Any listed with a "<MM>" instead of "<##>", e.g. "<50>", are muted.

There should be some for balance and fade to "center" the sound.



Great advice :-D

alsamixer is great!

For those more GUI inclined there's gnome-volume-control

GL!
!