Sign in with
Sign up | Sign in
Your question

Sata Raid1, ICH8 Sata and Optical disc errors

Last response: in Motherboards
Share
April 9, 2007 1:38:18 PM

Good day all,
I have searched and come up empty handed.
I read every-ones post prior to doing my install of Vista and had downloaded the 1.17xx JMicron SataRaid drivers, the latest ICH8 Intel drivers, HDAudio 1.64 etc.

My config seems enough different than most folks that I am not able to find a similar issue but:

1. SATA AHCI mode disabled
2. SATA Port 0-3 Native mode disabled
3. Onboard sata/ide device enabled
4. Onboard sata/ide control mode Raid

Two Seagate 320gb drives on purple JMicron Controller configured for Raid1 with Vista installed.
1 Seagate 320gb PATA drive attached to the PATA port.
2 Samsung SATA DVD-RWs attached to the orange ICH8 Intel Sata ports.

I was able to read from the Vista install CD and play pre-recorded DVDs and music just fine, but when I insert a blank DVD I get the following error:
An error was detected on device \Device\CdRom0 during a paging operation.
This is an Event ID of 51
It happens on both optical drives on any of the orange sata ports.
I have uninstalled and reinstalled all controllers and devices. Made sure I had the latest firmware for the drives. Running F10 bios.

I am not able to burn a successful DVD-Rom on this new machine. Sometimes some of the chapters will play, others wont play at all.

Does anyone have any suggestions at this point?
I am tempted to just get a separate PCI Sata controller for the optical drives to see if this resolves the issue.
May 2, 2007 3:06:31 AM

It sounds like I am having the same issue and I am not having any luck with support from Gigabyte. I have two 40gig satas in a RAID config on sata0&1, I have a 500 Gig WDC on Sata2 and on 4 and 5 I have two optical drives one an Asus and the other is a Samsung. I just built the machine so I haven't installed any burning software, but I tried to install games such as BF2 and they install fine, but when I go to play them I get an error telling me to make sure the correct disc is in the drive and try again. Though when I connect my pata DVD rom in the system and try running the game, it works.

I hear there is a problem with the ICH8 and sata optical drives, but I haven't read enough on that to prove that it is indeed the case.
May 2, 2007 1:33:26 PM

Sort of...

The telltale way to test is that anytime you insert blank media and cancel out of auto-play it records 4 event ID 51 in the Windows, System Logs in the Event viewer.

I finally narrowed it down to anytime there is flash media attached to any USB device on the PC (regardless if its a card reader or a thumb drive plugged into a USB port.

Boot with no flash memory and the drives work just fine. Insert flash memory and you get the errors. Errors will continue until you re-boot.

Not sure if this is what you are experiencing but I have it all documented here on what we found to be the case:
http://windowshelp.microsoft.com/communities/newsgroups...

if this is the same for you please add to my post that you are having a similar issue.
Related resources
May 2, 2007 4:04:15 PM

Ah, my problem looks like either the ICH8 chipset or a driver for it. I cant run any games that are connected to the orange sata ports, but works when I put it on the purple jmicron ports. <sigh> Have you noticed anyone else having a similar isue to this? Sorry, thought it was close to the issue you were having.
May 2, 2007 4:27:51 PM

Have not seen anything directly related.
Do you have any flash memory attached?
If so, try disconnecting any thumb drives or media readers, reboot and see if the issue goes away.
As for the ICH8 drivers, go to the Intel site and download the latest here:
http://downloadfinder.intel.com/scripts-df-external/Pro...
Select your operating system and download.
May 2, 2007 5:05:21 PM

Quote:
1. SATA AHCI mode disabled
2. SATA Port 0-3 Native mode disabled
3. Onboard sata/ide device enabled
4. Onboard sata/ide control mode Raid

just suggestion, because i dont have SATA DVD RW
okay, enable SATA Port 0-3 Native mode, if it still doesn't work, then enable SATA AHCI mode aswell...
hope that helps...
May 2, 2007 8:27:33 PM

Tried both AHCI and Native mode enabled separately and in combination.
No change in my instance.
Seems to be a ICH8 / Southbridge driver issue as both the SATA ports and USB ports are controlled by that one chipset.
I will have a separate PCI USB Add-In card (NEC Chipset based) here tomorrow to see if that solves the issue.
Using a PCIe SATA Controller (SiI 3132) did not make a difference.
I think this is a MS or Intel driver issue.
May 2, 2007 11:08:25 PM

Can you post what version of drivers your ICH8 chipset is using? I just updated from 6.0 to 8.0, but I heard something about 8.3 being the latest release. Even after updating I still have the same issues I mentioned earlier.
May 3, 2007 12:07:07 AM

I am running 8.0.0.1008 from Intel dated 9/15/06 for the 965P/ICH8 chipset.
That I am aware of there is not a later driver.

On Intel's site there is a 8.2.0.1012 dated 12/28/06 but that is for the 965M

You would also want to make sure to differentiate between the ICH8 and ICH8R chipsets (R supports raid)
May 4, 2007 1:42:54 AM

Today we secured the Rosewill RC-100 PCI USB card with a Via VT6212L Chipset.
This invokes a OS install of MS driver 6.0.6000.16386 dated 6/21/06

Attached Two different Kingston USB thumb drives, a Verbatim and a PNY unit as well, all with same results of introducing an IO error on the optical drives.
Also attached an internal USB Card Reader and any flash memory (CF, SD or SM) introduces the same error.

Since we have now tried two different Motherboards, Two different USB Chip-sets, Three different SATA Controllers and Two different brands (4 total / 2 of each brand) of Optical Disc Drives we are going to presume this is a MS OS or supplied driver issue and will simply have to wait for a Hotfix to address this.
May 11, 2007 12:36:46 PM

We have now installed Intel driver 8.3.0.1011 dated 2/6/07 for the P965 IO controller.
No Change.
We then decided to try a USB ODD.
and...
Same issue.
As soon as you insert any flash memory you get the IO errors and an event ID 51 is the system log.

A point of note:
As soon as you insert the flash memory your get an informational message in the system log of:
"Name caching for File System Filters has been disabled on volume '\Device\HarddiskVolume7'." with an event ID of 2
!