Sign in with
Sign up | Sign in
Your question

onboard audio=unknown pci device

Last response: in Systems
Share
April 9, 2007 4:06:08 PM

is there anyway to get my computer to recognize, and install drivers if necessary for, my onboard 680i sound/audio? i was getting a yellow question mark in the device manager under 'other devices- pci device'. i disabled onboard sound (i have an xfi soundcard) and sure enough, this ? dissapeared. now that i've reenabled the onboard sound (mainly b/c i am trying to get the mic on my headset to be recognized, and i have it plugged into the usb/headphone/mic/1394 port on the front of my lian li case, which is in turn plugged into the mobo) the question mark has returned, along with the 'unknown pci device' notice in the lower right toolbar upon startup.

thanks.
April 9, 2007 4:21:00 PM

You need to install the drivers. They are on the disk that came with your motherboard, or at their website.
April 9, 2007 9:41:44 PM

ok thanks

installed the new drivers for the realtek on board audio and that went ok. there are two options for the realtek- HD audio input and digital input.

here are my settings from within 'sound and audio devices properties" -- audio-- default device-- sb xfi, sound recording-- realtek hd audio input, midi- sb xfi synth
voice-- voice playback default-- realtek hd audio output, voice recording-- realtek hd audio input,
mic is checked and boosted
Related resources
April 9, 2007 9:54:55 PM

ahh, I didn't catch that you has an X-Fi installed. Actually, you should uninstall the Realtek software and drivers, and then disable the onboard sound in your BIOS. Unless you want to use both. You may be able to set it up so only the front audio ports use the Realtek device, maybe not.

I have an example. For some reason my speakers aren't working properly on my X-Fi, but my headphones work fine. So I have my speakers plugged into the onboard audio. If I want to play a game or listen to music with the headphones I change the default device to the X-Fi. On Vista however, there was an option to specify the device for the front panel audio only which is attached to the onboard anyway so I don't use it.
April 9, 2007 11:25:08 PM

right--what i am wanting to do is haVE THE xfi handle the sound output, ie through the speakers i have and through the headphones, and then have the realtek onboard audio handle the microphone input. the reason/need for this is that i have my sennheiser headphones/microphone plugged into the the 2 appropriate spots on the front of my lian li case's slot, which plugs into the mobo. i don't have my headphones/mic plugged into the xfi card on back of the comp b/c annoyingly enough, the card would apparently force me to unplug one of my speaker cables in order to plug my headphone cable in. i don't wanna hassle with the switching back forth btwn these things.

so, in a nutshell-- onboard realtek for mic input only, and xfi for all sound output. how to do this?
April 10, 2007 1:25:44 AM

Look in 'Sounds and Audio Devices' in your control panel, click the audio tab, select the X-fi as the sound playback default device, set the realtek device as the sound recording default device. That should work.
!