Sign in with
Sign up | Sign in
Your question

What's with my MTU??

Tags:
  • Routers
  • Internet Service Providers
  • Modem
  • Networking
Last response: in Networking
Share
February 21, 2007 8:31:59 AM

Hi. Suppose to have a 24mbit dsl line but this only reports up to eg. 6-8mbit average.(yes, it s**)Have a Thompson Speedtouch 585 v6 wireless modem (with latest FW) which also acts as a router. Now, my ISP. use a ppoe protocol so i had to configure my NIC to MTU1492, this by using Both DrTcp And manually correctly adding a string to the WinXP registry. The modem is suppose to be set at 1492 but the technic staff can't verify that it really is(though they claim it's set to 1492 def.) since there's no documentation inside the modem, or at Thompson's website. The most strange thing is when i'm doing a ping with the -f -l parameters, the conn reports an MTU at 1452(??!) The same thing at the tweaktest here and at www.dslreports.com. Here's the string from the tweaktest at this site:
----------------------------------------------
MTU = 1452
"MTU is not fully optimized for broadband. Consider increasing your MTU to 1500(1492 in my case) for better throughput. If you are using a router, it could be limiting your MTU regardless of Registry settings."
-------------------------------------------------------
What's Going ON??

More about : mtu

February 23, 2007 5:45:43 PM

If you use VPN it will drop the MTU down to 1452 range.

Try using DrTCP to check/change you settings.
February 23, 2007 6:02:42 PM

LOL. Thx for your reply but haven't you read my post? Where i mention i already tested drTCP. It doesn't work out, at least not visible And VPN? The only VPN is in that case, PPoE..the protocol my ISP is using. Or please define VPN?

Thx
Related resources
Can't find your answer ? Ask !
February 24, 2007 1:20:14 PM

An MTU of 1452 shouldn't affect your connection. Did you verify with your DSL provider that they have you set for the speeds your paying for? Or they can send a tech out to verify this?

Also here is a link to Thompson's website and if you scroll towards the bottom and find your model gateway (585) there is a user guide you can download.

Thompsons support page

Also that gateway might not support that high of throughput on its WAN port.
February 24, 2007 1:38:11 PM

The most weird thing is that the distortion that causes this problem is not to be found. I've already consulted a tech and he tested my line from the station to my house -no problem, cables inside my house -no problem, cable of the modem plugged into his own measure device -he measured 17/10 mbits(!!)
NO other sources for distortion either, eg. telephones, microwave ovens, etc.
I observated this though: at this command: (to my modem) "ping 192.xxx.xxx.xxx -f -l 1464"(+28=1492) had no packetfragmentation, eg. worked out as it should. However, when running the same command but to a WAN-address it defaults to MTU 1452(??!) Conclusion: when running behind Internet -the proper default MTU according to my ISP 1452. When surfing, it drops to 1452. This is weird...or?
February 24, 2007 3:26:56 PM

That might be where your problem is. Internally your PC/LAN side of the gateway is trying to push data out the ADSL port at 1492...but the WAN is set to 1452 by default and therefore might affect your throughput outside. Try using dr.tcp again and setting your PC to transmit data with mtu of say 1400.


The only other thing I can think of is the throughput from the LAN to WAN of your Speedtouch 585 gateway...it might not support speeds over 10mbps.
February 24, 2007 4:02:49 PM

Ok, great. But how can the Wan be set to 1452 and why??
February 25, 2007 5:57:17 PM

Try this, open your web browser and go to http://192.168.1.254.

From there click the Broadband Connections link.

Then click the DSL Connection link. View the information provided. See what it says for your Bandwidth.
February 25, 2007 7:36:36 PM

Right now it says 961/13.320
February 27, 2007 5:59:53 PM

Did you try using Dr. TCP to set your PC to mtu of 1400 and then run a speed test?
December 7, 2010 6:40:42 PM

Hi,
I know this thread is really old...
But couldn't resist responding as it still shows up in Google's results and hasn't really been answered.

The reason you see 1452 (-l) as the max size that will sucessfully ping without fragmenting the packets (-f), when you're doing a
Quote:
ping with the -f -l parameters
...
is because the MTU (Maximum Transmission Unit) is for the actual encapsulated data.

When doing a ping, the machine sends ICMP echo requests and receives ICMP echo replies.
In your case, when doing a ping with -l 1452 ... you're actually saying you want an ICMP payload of 1452bytes.
The ICMP Header adds 20 bytes to each ICMP packet.
And quite obviously you're pinging an IP address... and... the IP Header (Source IP Address, Destination IP Address, etc.) is.. 20 bytes !

So... here's the math:
1452 bytes payload
+
20 bytes ICMP Header
+
20 bytes IP Header
=
1492 bytes (which is the MTU of a typical PPPoE connection)

PS: The Header for PPPoE is... 8 bytes ;) 
PS2: If you tried pinging over a 1500bytes MTU link, the maximum ICMP payload with the Do Not Fragment bit set(-f) would be 1460 bytes (1460+20+20=1500..)

Cheers,
Pete
!