Sign in with
Sign up | Sign in
Your question

argh! ubuntu dapper partitioning!

Last response: in Linux/Free BSD
Share
August 19, 2006 7:06:24 AM

im having a lot of trouble installing dapper on my conroe system. it crashes whenever it tries to partition my hard drive. is this a normal problem?
August 19, 2006 6:22:04 PM

I would suggest setting up the disk(s) before letting any distro get it's mits into partitioning. What is your current setup, in terms of what disks you have and what are on the disks.

Also, have you completed burn-in testing? If not, it would be advisable to do so no matter what OS you wish to use. I suggest a few hours of Memtest 86(+) and a few hours of a prime-cruncher (mprime, prime95, etc.) or a test suite (like lucifer). All of these tools and more can be found on the ultimate boot cd

If you have nothing on the disk currently, Iwould say something is wrong here and you need to jump into troubleshoot mode (try the reinstall in text-only mode to try tonarrow down the issue).

If you have Windows already installed and wish to install linux on the same disk, I would suggest the following actions:

1) Boot into Windows, do a disk error check and a defrag to prep the NTFS filesystem for resizing.

2) Boot a livecd with a parted tool. I suggest the GParted LiveCD. Use the tool to shrink the NTFS partition. You may either carve out partitions here or leave it to the installation. I suggest letting the installation try first and if that doesn't work come back and do it manually here.

2.5) [optional] Create a FAT32 partition between the Windows partition and the space to beused for the linux paritions. This will allow for moving data back and forth between the two OS's as Windows cannot see Linux paritions and Linux cannot (safely) write to NTFS partitions.

3) Install your distro of choice
August 19, 2006 10:16:10 PM

ok, so i tried the gparte live cd, but when it is booting up, it says that there were no screens found. i think its because of my graphics card. i have a evga nvidia geforce 7600 gt ko. i tried the vesa drivers adn the nvidia ones but they both don't work
Related resources
August 20, 2006 4:40:39 AM

Well I can get the thing to work on my system with a 7800GT, plus the VESA driver should be able to work with two sticks hot-glued into a PCI slot, so I don't know what's going on there.

A "no screens" error usually indicates a bad X config file, but since you didn't make/modify the thing, I am at a loss as to what happened here. Try an older version and see if some of the updates they've made to the boot sequence is to blame (look for something around the 0.2.5-2/3 area).

Reading the release notes, in 0.2.5-5 (the latest) they recently made changes to the graphics system which might be the root of you problems, so give an older version a try (or give the "manual video card" thing a try, as stated in the same notes).
August 20, 2006 8:35:39 AM

the older version worked great! thank you so much. i finally have ubuntu up and running. but on to a new problem...i cant boot windows xp anymore. i guess in the moving of the partition, some data was lost. its missing some dll and it cant boot. yet another ARGH.
August 20, 2006 3:45:17 PM

Unfortunately all of the methods to recover from the situation you describe would mess up the boot situation by overwriting what GRUB did.

My suggestion would be to backup any important data (not likely to be much since you just built this thing), boot the gparted cd, delete all of the partitions and set it up exactly how you want it partition-wise, install Windows first, the install Ubuntu next.

Setting up the partitions first before getting started makes things a lot easier. Also note that the NTFS partition can be much smaller than you normally might allocate if you put all of your media and documents on the FAT32 "D:\" drive, if you choose that route (highly suggested).
August 20, 2006 6:29:56 PM

its ok, it turns out all i had to do was rebuild teh boot.ini. its all working now. thanks for your help
!