Sign in with
Sign up | Sign in
Your question
Closed

Is there a way to assign more memory to an application?

Last response: in Applications
Share
September 6, 2006 2:06:12 AM

Im running adobe premiere pro 2 on an dual Opteron 270 based system with 2GBs of memory and I am getting an message from Adobe premiere that says : "Permiere is low on system memory -proceed with caution."

The project im working on is very complex - over 2 hours long. up to 10 layers. But i am wondering if I can make sure the system is giving all its got to allocated to premiere. How can I check this?
September 6, 2006 4:19:41 AM

Ctrl Alt Del

Processes

Look for the process that's consuming all the cpu power, that's probably the process that is (supposedly) running low on memory. See how much memory the process is using (furthest right hand column). Next, go into the Performance tab. Check the Page file usage amount. You do have page file enabled, right? If your page file size is manually controlled, make sure the page file usage is not at the max of the total page file size allotment.
September 23, 2006 10:08:54 PM

!.Right-click MY COMPUTER
2.Properties>Advanced>Performance>Settings>Advanced
3.Under, Virtual Memory check Paging File size,(if memory serves, the rule of thumb is 1/2 of total V. Memory may be used. If you use more, the paging file fights between the app. and the OS.
Hope this help's
Related resources
Anonymous
a b } Memory
January 26, 2009 12:03:57 AM

You could go into task manager and give it the hgih priority ( or realtime if your pc can handle it ) minimize all other programs. if you REALLY want a speed bonus of RAM and to get adobe to never run out, go to control panel>system>advanced and go to the performance area give yourself a 10Gb paging file, it will go faster than hell ( all minimized programs will run on that paging file not RAM) hell, i gave myself a 70Gb page file and now i can do whatever i want on my computer, everything is on the page file so it all runs smoothly.
January 26, 2009 12:58:41 PM

Honestly, you are better off just getting some more memory for your machine. Find out the max your motherboard can support and add more if you can. If you are using a 32 windows, you will only be able to use 3070 gb of ram (assuming you bump up your ram to 4gb). 64 bit doesn't have that limitation.

Modifing the page file won't help all that much as far as speed goes. The hard drive (where the page file resides) is much slower that RAM will be. If you are going to modify the page file, whatever size you want to set it for, make the minimum and maximum the same amount. Doing that will give the processor one less thing to worry about. Normally having different values for the min and max makes the processor work harder by resizing it on the fly. Having the same values takes that away. Microsofts rule of thumb for setting up virtual memory is 1.5 times the actual ram in the system.

Be careful with using real time in task manager. You can lock up your PC. Use caution. Setting high priority is a safer alternative. Ending processes, while freeing up some memory, is better served as a tool for freeing up CPU time. All those processes fight for CPU time and it takes away from what you are wanting done. I personally go into the Services MMC snap-in and disable (or set to manual) all the processes that I don't need for my daily use. Once windows starts up and loads everything, I have 24 process in XP that run. In my Vista, I have 34 (vista has more stuff that I haven't decipherd yet).
January 28, 2009 7:21:12 AM

i dont know what the guys above have been smoking tbh, but this should fix your problem....

open adobe premier and goto Preferences>General change the amount of memory that premier can use to about 1.5 (that should be enough)

This problem can also be caused by low HDD space, make sure you have enough space for your project.

EDIT

what Operating system are you running? - if its vista try running the program in xp compatibility mode.
July 21, 2009 2:30:37 AM

Flakes said:
i dont know what the guys above have been smoking tbh, but this should fix your problem....

open adobe premier and goto Preferences>General change the amount of memory that premier can use to about 1.5 (that should be enough)

This problem can also be caused by low HDD space, make sure you have enough space for your project.

EDIT

what Operating system are you running? - if its vista try running the program in xp compatibility mode.



thanks man you save mi life ill will be grated all my life thank you very much flakes
September 25, 2009 8:17:05 PM

Flakes said:
i dont know what the guys above have been smoking tbh, but this should fix your problem....

open adobe premier and goto Preferences>General change the amount of memory that premier can use to about 1.5 (that should be enough)

This problem can also be caused by low HDD space, make sure you have enough space for your project.

EDIT

what Operating system are you running? - if its vista try running the program in xp compatibility mode.


In premiere pro 2.0 when going to Preferences>General there are no options to change the amount of memory that premier can use. Is that hidden somewhere else in Premiere 2 or are we missing something? Thx!
September 26, 2009 1:33:28 AM

This topic has been closed by Randomizer
!