Sign in with
Sign up | Sign in
Your question
Closed

AT&T DSL modem won't link to my Linksys router

Last response: in Components
Share
April 12, 2007 7:17:40 PM

Hey all,

First off, thanks for reading and any help you might be able to offer! I probably should have posted in the Network forum, but there's not many people there. :) 

Here's the problem:
I just moved and got AT&T DSL hooked up. They sent me a Siemens Speedstream 4100 modem. I have a Linksys BEFSR41 router (wired only, 4 port ethernet).

Now I can't get the router to recognize the modem. On the front of the router are LEDs for each ethernet port and the WAN port. The LINK LED just won't light up no matter what I try - which signals that the router won't recognize the modem. The modem recognizes that the other end is plugged in (via the Ethernet LED).

The thing is that the 4100 modem has the PPPoE authentication on it, which works fine. I can hook the modem directly to my computer and everything works fine. So it must be the router-modem connection.

I've tried:
Having the router get an IP automatically from the modem.
Changing the router's IP address.
Having the modem pass PPPoE authentication to the router.
Bridging the modem.
Power cycling the guts out of everything.
No matter what I do, it never lights up the LINK LED. Its driving me nuts! I'm hoping someone's experienced a similar issue and can help me out?
May 17, 2007 12:51:42 PM

Plug the modem ethernet cable into the WAN port on the router. Go into the router and configure PPoE with username and password. Set up a LAN connection to the router on your computer. Make sure that your firewall is not blocking the router internet connection.
If the port is not lighting up, it may be a dead port.
May 17, 2007 8:44:32 PM

Thanks, I did try that, but to no avail.
I don't think its dead, it just may be that the router is too old for the PPPoE on the modem configuration. :-(

That's the only thing I can figure that went wrong. Course, it could be dead, but i'm too lazy to find out. I ended up just getting another wireless router since i'll need it for my wii anyways.

Thanks for the help!
Related resources
May 17, 2007 9:17:34 PM

with the modem handling the PPPoE authentication, set the router up for standard cable modem. (basically a hardware reset on router will set that up). then change anything regarding firewall and such on the router.
May 17, 2007 9:44:56 PM

yeah I tried setting up the router to accept an automatic IP address from the modem (which should happen w/ PPPoE on the modem), but it still didn't work. Maybe evongugg is right w/ the dead port/router idea. :? Its all good now since I got a new router.
June 9, 2007 1:21:04 AM

Had the same problem with my D-Link 624 Rev C. Here is what I've done so far:

1) disconnect router and plug directly into the DSL modem
2) get into the DSL modem webpage (same as wireless router)
3) switch to "always on"
4) copy tech info (primary DNS and secondary DNS)
4) reconnect wireless router
5) make the connection to Cable Model
6) input the two DNS addresses

This should do it.

Let me know how you make out.
July 2, 2007 4:36:56 PM

I have the same issue with my WRT54GS. Recently I got DSL and I'm trying to hook up my Siemens 4100B modem to my Linksys WRT54GS, but so far I'm having zero luck. Running directly off the modem works fine, but the minute I bring the router into the equation everything goes south. I have configured the mode/router as follow:

1. configured the modem to bridged.
2. plug in model to WAN port on router.
3. configured router to run in PPOE mode.

No luck, I know the router is port is good because It works with Cable modem.
July 2, 2007 4:49:43 PM

Try changing the IP address of the router. Linksys defaults this to 192.128.0.1. I'd change it to something different, like 10.0.0.1. The modem (as far as I can tell) is hardcoded to take 192.128.0.1. This causes a bad conflict.

Leave the authentication (PPPoE) on the modem, and set the router to get an IP address automatically.

On my old router, I couldn't change the entire IP address, just the last number.

My solution was to get a new router. :p 
July 2, 2007 5:05:51 PM

Have you tried a crossover cable? If you're not getting a link light, messing with the IP settings will get you nowhere.

EDIT: Replying to the OP. Goofy "Post Reply" button is randomly replying my posts to various folks.
July 3, 2007 3:35:29 AM

With DSL in my area and every router hookup, I've gone in (192.168.x.x) and set them to cable modem (like a straight pass thru). Seems PPOE on the router messes with the DSL. Then set the router to DHCP & automatically assign addresses.
And don't forget to rename the login and password to the router, and wireless SSID and WPA password asap! 3 idiots in my area have linksyses wide open with default factory passwords.
July 3, 2007 3:08:03 PM

I did try the crossover at the begining. Thanks.
July 3, 2007 3:14:46 PM

Actually the modem's default IP is 192.168.0.1 and the router is 192.168.1.1
July 3, 2007 3:18:18 PM

Also, the version of the firmware I'm using is 4.71. Is anyone using this version with the PPOE configuration?
July 3, 2007 3:32:22 PM

Connect your PC to the router and clone its MAC address onto the router. I'm not sure that matters with no link LED showing, but it might if the modem has been set to only allow a specific MAC to connect to it.
Then plug the router into the modem and see if it flies.
July 3, 2007 5:41:16 PM

Quote:
Actually the modem's default IP is 192.168.0.1 and the router is 192.168.1.1

Oh yeah sorry about that, but my suggestion still stands. I think it could be related to the subnet mask on the modem as well.

I highly doubt that the modem is configured to allow only 1 MAC address. That would be a nightmare for consumers and ATT.

Also, remember when you do a IP change, do a ipconfig /release and a ipconfig /renew to get your new IP address from the router.

How my netgear is set up is I have PPPoE on the modem and the modem is set to always provide the connection to the router with a specific address (192.168.64.1? - from my months old memory).
The netgear is 10.0.0.1 and to automatically get the IP address from the router (akin to how a cable router is set up). Then DHCP is handled by the router to my computers.

Another note, you can try to disable as much as security as you can on the router until you get it to work. After I make it work and I've got the correct settings up and going, then I reenable my security.
July 4, 2007 5:17:50 AM

I hope this helps. I have a linksys befsr81 with the 4100b modem with AT&T and I was having problems.
I found this page
http://www.dslreports.com/forum/remark,15694046
with detailed instructions on how to setup the modem and router. I performed the steps exactly and they worked for me.
If it still doesn't work, then plug directly into your modem and try to connect that way. If you can connect through the modem directly and the instructions don't work for configuring it, then it could be the router.

Good Luck
July 6, 2007 5:37:28 PM

Just out of curiosity since you moved, and now have I assume a different modem, did you reset the router to its default settings, using the reset switch?
July 6, 2007 6:34:03 PM

Quote:
I've tried:
1. Having the router get an IP automatically from the modem.
2. Changing the router's IP address.
3. Having the modem pass PPPoE authentication to the router.
4. Bridging the modem.
5. Power cycling the guts out of everything.
6. No matter what I do, it never lights up the LINK LED. Its driving me nuts! I'm hoping someone's experienced a similar issue and can help me out?

1. IP address is completely irrelevant to an ethernet connection
2. IP address is completely irrelevant to an ethernet connection
3. PPPoE is completely irrelevant to the ethernet connection
4. ...all of the higher level protocols are irrelevant to the ethernet connection, all of the DSL negotiation is irrelevant to the ethernet connection between the router and the DSL modem
5. ok, we'll rule that out
6. Is there anything that *does* cause the link LED to light up?

I *think* I have the same router (it's at home and I don't recall the model number exactly) so I'll try to give some model-specific instructions below. If they aren't quite right just try to adapt them.

My best guess: crossover. There should be a button for it on the router for the "WAN" port but you have an older router and it doesn't do auto crossover detection. Try a different ethernet cable. Try different ports on the router. Try both settings for the manual uplink crossover button (little square black button on the back). If your WAN port is broken just get a crossover cable and use one of the regular ports.

The ethernet connection has to be established first before any other levels of communication can happen so don't even worry about anything else until that link light turns on. When you hook your computer to the router does the link status light turn on? Does the computer get an IP address?

That link status LED is a physical layer ethernet link up indicator. None of that other stuff matters until the ethernet link is up. I assume that you at least tried to use the connection even though the LED didn't light up (the LED could be broken)?

To all the people who suggested tweaking firewall, authentication, and IP settings when he clearly stated that the physical layer ethernet link up status indicator wasn't turning on: don't give out advice if you don't know what you're talking about.

Nobly, if you ever do manage to figure out what was wrong with it we would all appreciate some feedback. Did the hardware goblins really break your router during your move or did you just need to push the crossover button? Inquiring minds want to know.
July 7, 2007 12:24:43 AM

Quote:
Just out of curiosity since you moved, and now have I assume a different modem, did you reset the router to its default settings, using the reset switch?

Oh yeah. :p  Multiple times. And then another one for the heck of it.

Flasher, you have revived my technical curiosity in it. I had solved the issue by just getting a new router because I realized I would need wireless anyways. But I will contemplate some extra investigation this weekend and see what happens.

I know the modem works fine because the modem's ethernet LED would light up is if I bypassed the old router and went straight to my computer. I'm relatively sure that the router is ok - it was when I decommissioned it. I know the switch part works, it was just the WAN LINK port that would not recognize the modem.
The router does have auto-detect crossover or straight (at least according to the data sheet). That was one of the first things I thought of and double checked. I've tried different cables. Did not think about trying a port on the switch though - i'll have to give that a shot to see if the physical layers will recognize each other.

Router to computer is fine. I have an IP from the router's DHCP and can ping, etc. Its seriuosly just the path between the router and modem. And since I've verified the modem works, its down to the router.

So pretty much I figured the WAN port was either fried or dead and just got a new router since I had to to go wireless anywho.

Oh another thing I just remembered - the modem's Ethernet LED would light up when I plugged it into the router, but the router's would NOT. That was what confused me - it seemed like the modem knew the router was physically there, but the router was refusing the acknowledgment or something. That's why I pursued the upper layer protocol methods.

I like the goblin theory... :)  Thanks for the ideas, I'll post back next week. If you have more ideas, love to hear them.
July 7, 2007 1:17:27 AM

Quote:
Quote:
J

Oh another thing I just remembered - the modem's Ethernet LED would light up when I plugged it into the router, but the router's would NOT. That was what confused me - it seemed like the modem knew the router was physically there, but the router was refusing the acknowledgment or something.

that is indeed very strange and if any sense can be made of this I'd love to hear it. The WAN port is auto crossover though? No manual button to switch it? Well there goes my best theory :/ 

Quote:

I like the goblin theory... :)  Thanks for the ideas, I'll post back next week. If you have more ideas, love to hear them.

also do not rule out techno gnomes ;) 

You could try plugging the WAN port into your computer. That would rule out obscure incompatibility issues and give you a little more troubleshooting power than plugging it into the modem. If it's auto crossover it should just work.

very very strange though... I'm glad it was your problem and not mine xD
July 9, 2007 11:30:32 PM

Quote:
that is indeed very strange and if any sense can be made of this I'd love to hear it. The WAN port is auto crossover though? No manual button to switch it? Well there goes my best theory :/ 

You could try plugging the WAN port into your computer. That would rule out obscure incompatibility issues and give you a little more troubleshooting power than plugging it into the modem. If it's auto crossover it should just work.

very very strange though... I'm glad it was your problem and not mine xD

Hey Flasher, I would have posted back last night but the forumz were down for this overhaul. Kinda hate how the quotes are working right now, but that's a different issue.
Yep, it is indeed a wacky problem. One that drove me bonkers and caused about a week of troubleshooting. I tried plugging the WAN port of the problem-router to my good router's LAN port. As before, good signal on the good router showing a connect, but the WAN LED's on the problem-router were blank. I reconfirmed by going LAN to LAN and both routers were happy there. I will try the problem-router to my computer sometime. It is Auto-crossover, so unless that broke, I think I'm safe to put that theory down.

Currently my line of thought is that the WAN port on the problem-router has been fried/heat damaged, but still allows the physical layer to connect on the other side. Or that there is some obscure Linksys compatibility issue at hand. I have seen some similar reports online to the same effect. I'm not sure in what cases the Link LED will light up on the problem-router (some Linksys specification of some sort that only allows it to light up when its being an actual router??). As you can tell, I'm just pulling theories out of no where to explain it.
September 7, 2007 1:48:48 PM

I had exactly the same problem with the Siemens Speedstream modem which includes the PPoE authentication. I tried everything listed in this forum, finally I got the AT&T 2 wire wireless router, had it working in 1 hour. Most Best Buys carry them if you are in a hurry like I was.
October 1, 2007 3:07:25 PM

does you dsl link light go off or flash when you hook this to the router?
May 4, 2008 11:10:47 PM

I have enjoyed the many ways that folks have tried to get the ATT DSL to work with a router.
I just signed up with ATT, and have used Verizon and Comcast Cable for several years.
My two routers, Airlink and Belkin will initially link with the ATT Broadxtent DSL Modem, but
then "time out" or something. I have contacted Airlink and Belkin, and followed their suggestions.

As I said, I have used them for several years without problem.

ATT responds that they DO NOT SUPPORT routers. Boadxtend (A Creative company)
does not respond at all.

I plan to wait out the time with ATT and then go back to either Verizon or Comcast.

Joe
June 12, 2008 3:17:49 AM

ATT likes to set their modems up to use the 192.168.1.x subnet, which is also what the Linksys (and many others) router uses by default. Hook everything up as normal and leave the router set for DHCP from the modem. Now change the IP of router to 192.168.2.1. The router will reboot, you'll also need to renew the IP on your computer (make sure it gets a 192.168.2.x address) and now you should be good to go. :) 


aa
July 13, 2008 8:16:46 AM

Hi there,

Let me help you out here. Considering an average Linksys router, the signal strength is perfect for a range of 25 meters, no matter what anyone else says. I am a system administrator and I work on routers on a dialy basis. The router signal is emitted in a spherical ball shaped fashion. Think of it as a spherical ball on the top of your router. First, a few basics need to be taken care of. Firstly EMI devices like fa machines, cordless phones, halogen lamps, speakers or anything which runs on electricity needs to be atleast 2 feet away from your router. Make sure that there is a distance of 2 feet or more between your modem and your router.

Now lets go the router setup. Considering that you are using dynamic IPs instead of static IPs. Dynamic IPs change every 8 hours or so, as per your ISP's policies or capabilities. An IP Address is a unique number assigned to your computer which identifies your computer over the internet. Now, as you have a router, that means you need to identify your network on the internet.

Lets say you have 4 computers in your home. So you would ost likely have a single user modem, a Linksys router and your computers which you want to hook either wired or wirelessly. Your ISP provides one dynamic IP address to your modem. This IP Address is then captured by the router which uses a time slicing technique or an IP Subdivision technique (DHCP) to generate 4 different IP Addresses to allow each of your computers to go online. These IP Addresses should be captured by the computer in order to connect to the internet.

Hence it is necessary to boot up your system correctly. Firstly, the modem should be turned on. Wait until the sync/DSL/broadband light turns solid, indicating that you have a connection to the server and an IP Address is assigned to your modem. We need to ensure that it reaches your computer. Now connect the power cord for your router and check the internet light on the Linksys. If its green, that means that the router is ready to send out the IP Address to your computers.

Finally, turn on your hardwired computer first. This ensures that your router would be in a position to deliver the IP Addresses. To check if your computer is getting an IP Address, type ncpa.cpl on the Run box and check within LAN icon by going to the Support tab. If you are using Vista, then double click on LAN and goto details. You need to look at (IPV4) IP Address and (IPV4) Default gateway. You should get the following IP Addresses

IP Address: 192.168.1.100
Subnet Mask: 255.255.0.0
Default Gateway: 192.168.1.1

These are the router's default IP Address and gateway, provided you have not changed them. Its a class C IP Address. By default class A, B and C are the only types of IP Addresses. class D and E is reserved for military and internal research purposes.

Back to the topic, once you get this IP Address, then turn on your other computers in order to go online. If you are the type of person who would shutdown your computer at night, then make sure that you do not touch the router or your modem. Leave it on but it is recommended that you turn it off atleast once a month.

If you are not able to go online, decide where the DHCP is located which is pretty easy. If you store your ISP username and password on the modem, the DHCP is on the router, else vice versa. Lets consider the connection part:

DHCP on the router.
The nest thing is you dont have to isolate the router in order to accessthe modem. Firstly access the router GUI using 192.168.1.1 and then goto WAN connection type or Internet Connection Type. Use the dropdown arrow and select DHCP. Now close this window and open IE/Mozilla and type in your modem's default gateway. It should be something like 192.168.1.254 or 192.168.0.1. If you are confused about your modem's default gateway, then take a look at the bottom of the modem and you would find it written below.
Update the username and password and click on connect, in order to go online

DHCP on the modem (bridge mode)
This means that the router would be making all the connections while the modem is bridged (partially disabled). As for 2wire modems, you do not need to bridge them, becuaseits already a combination of modem and a router barring 2wire1070b which is a singleConsidering a Motorola2210 or a speedstream modem, isolate the router and access mdoem GUI using 192.168.0.1 or 192.168.1.254, goto Advanced>PPP Location>
You would get three options

(a) PPP is on the modem (default)
(b) PPP is on the computer
(c) Bridged mode

Select PPP is on the computer and click on Save settings>Restart. From this point onwards, your Ethernet light would never turn solid which is perfectly normal.
Then access router GUI using 192.168.1.1, select WAN/Internet Connection type as PPPoE, enter your ISP's complete email address and password and click on Save Settings. Then on upper left hand corner, click on Satus and click Connect in order to connect the router to the internet. If the connection still does not work, then turn off all the devices and turn on in the sequence discussed earlier. i.e., modem (wait for DSL to turn solid), router (wait for internet to turn solid), your hardwired PC and then your wireless computers in order to go online.

I know this would resolve the problem. If you have any comments, then mail me on

cyberthunder9000@yahoo.com
Lets help each other...
July 22, 2008 1:50:45 AM

I'm trying to migrate from Comcast cable to AT&T DSL. I've run into all the stated issues. Except one. I noticed in Network Connection Details (in Windows Vista Home Premium) this setting:

Connection-specific DNS Suffix: hsd1.ca.comcast.net

I can't figure out how to undo it. I even reset my Linksys WRT54GS router to factory defaults. If this suffix is being added, though I'm not very technical, could it cause cause connectivity to fail between the router and DSL modem?
September 20, 2008 4:17:24 PM

I just set up my Linksys WRT54G router to connect to ATT/Yahoo DSL with help from this forum.

1) Keep the ATT modem configured as default (mine is Motorola 2210 and its default is to run PPOE on the modem itself). This is the way the Windows DSL account installation utiliity leaves it.
2) Set the router to "Automatic Configuration - DHCP"
3) Set the "Local IP Address" to anything but 192.168.1.*. You can use 192.168.2.1 and it works fine.
4) Save your router configuration changes.
5) Turn off modem, router and PC (unless you know your way around the ipconfig /release command.
6) Restart the modem and wait for the green light to go solid.
7) Restart the router and wait for it to come up.
8) Restart your PC. You should be good to go.
October 12, 2008 8:30:31 AM

Thanks! it worked for me after following mtasker's suggestions.
Before that I was strggling with both zyXel and Linksys routers with Motorola modem. by default all of these three use 192.168.1.* IP range.
After changing IP address range of Linksys router from 192.168.1.* to 192.168.2.* it started working.
October 29, 2008 6:46:52 PM

Here's how I got it working for me:

1. AT&T DSL modem using PPPoE
2. Router using DHCP to get an IP address from the modem
3. Router configured with DHCP Client ID set to "computer"

It started working immediately after setting the DHCP Client ID. Hope this helps.
December 13, 2008 3:11:52 PM

Let me provide a little insight, from the perspective of a phone company technician who fixes phone lines and DSL service (including on-premise issues). I'll start by saying that we are not allowed to touch customer networking equipment that is not provided by AT&T. Computer networking is a much more complex set of issues than merely getting the DSL to work. That said, I have a network at home, and I have built networks using both MS Server software and Novell. My home network is Linux (OpenSuSE). So, I'll occasionally assist a customer in getting their DSL working through a 3rd party router, but only if they have some idea what they're doing. If a child set up the network and the parent is the only one home and has no clue, I'll generally prove the DSL working to my laptop and let the customer's child re-setup the network.

Here are the troubleshooting steps which we perform in order to get the DSL working.

  • First & foremost is to get a signal to the DSL modem (it can be any of the modems we've provided in the past, the 2-Wire home portals, or the Cayman/Netopia routers - we don't provide the Cayman/Netopia routers as a self-install option, only as a full-tech-install option).
  • Troubleshooting the DSL signal to the modem means confirming that there's dialtone to the modem (or continuity, on a dry loop [DSL w/o phone service]).
  • Then we check to make sure everything is properly filtered. Note that any device (other than the DSL modem) that is connected to the phone number MUST be filtered. This list of devices includes anything connected ANYWHERE that the phone number exists, and such devices as telephones, answering machines, caller-id boxes, fax machines, sattelite dish boxes, and, yes, especially burglar alarms (burglar alarms won't necessarily kill the DSL signal, but 99% of them eventually do - they may not "malfunction" immediately, but it can [& will] happen within 2 seconds, 2 minutes, 2 hours, 2 days, 2 weeks, 2 months, 2 years, etc., from the time of initial installation - so we suggest that we either do a full-tech installation or that the customer have their alarm company come install a filter on the alarm).
  • Assuming that there is a signal to the house (as measured at the phone company box, usually outside the house and located somewhere near the electric meter), then there should be a good signal to the end of the phone cord that will plug in to the modem. If there's not a signal there, but is outside, then there's something wrong with the house wiring ("IW" - Inside Wiring), which must be fixed before the signal will reach it's destination. We'll presume that the signal is now at the modem and is evidenced by a green DSL led on the modem. We use a test device to confirm the signal is present, and if it is present on our test device but not on the modem, then we simply replace the modem. From this point forward, we'll assume that the modem has a green DSL LED. There is one 2-Wire Home Portal that has a 3 state LED: Red for no signal, Orange for a signal but customer isn't registered, and Green for signal AND registered. For this device, an Orange broadband LED is ok.
  • Next, we'll connect the computer DIRECTLY to the modem, via ethernet cable. We'll use the customer's computer, assuming it is operating correctly, or we'll use our own technician's laptop. Either one is fine, but our laptop is almost always functioning properly. It is now time to get the customer registered and enter the registered username and password into the PPPoE client that exists on the modem. There are a few modems out there that do not have PPPoE built in, and those require either a router with PPPoE or a "broadband" connection on the computer. We no longer support those modems as they are out of date. However, if a customer has one & it will work, I will usually attempt to get them going with it.
  • To confirm that the (customer's) computer is working properly, we'll surf into the IP of the modem/home-portal/router (I say "router" here, but am specifically referring to the AT&T provided Cayman/Netopia series routers, not 3rd party routers such as D-Link, LinkSys, E-Home, Belkin, - & the list is as long as everything I'll type into this post). If we can surf INTO the device using the IP address, then it would appear that everything is ok (with the possible exception of DNS settings, but that's a different issue than this one here).
  • If we do get the device setup screen, then we confirm that the PPPoE shows the "default" username and password. I can't tell you what these are, because it's supposed to be proprietary and not public knowledge, tho we do show it to our customers if they're watching us.
  • Then, we go to the registration website and get the customer registered. If everything works correctly, the customer pick out an email address (that can never be changed after it's registered to that phone/account #), and a password. The registration process goes a little further and then it SHOULD automatically reprogram the username and password into the device. But, to make sure, I always go back to the IP of the device and confirm it's there, or put it in manually. I usually put it in manually because I do not fully complete the entire process - because some of it is downloading software and I don't want/need the software on my company provided laptop (especially after the 100th time I've done this) - it takes too long and we don't use it, so I bypass that.
  • Once the username (email address) & password are programmed into the device, we surf. We usually go somewhere like cnn.com or weather.com - because they are always changing and we can tell that we're live & online. If it's a 2-Wire, and the customer has 1 computer to be connected wirelessly, I'll usually assist in that, or do it for them. I may not do 2 or more, but might, depending on my workload and where I are in the day & how long it's taken us to get that far, and if the customer has been respectful or abusive. If it's a router (AT&T provided Caymen/Netopia) and the ticket has the code to install jacks & cables & computers, I'll do whatever the ticket requires - up to connecting and surfing on 4 computers - We WILL NOT EVER configure printers for sharing and especially not configures file sharing -> That is up to the customer's "certified networking professional" because we will not be liable for potential security breaches among computer users.

    Providing that we've been successful to that point, we attempt to get the customer's computer connected & have him/her surfing to prove that it's working. If we can do this, then our responsibilities have been fulfilled - we've proven that our circuit and our AT&T provided equipment is working properly - even if we can't surf from the customer's computer, we'll prove it from our own. If we can't surf from the customer's computer, but can from our own, we'll do some cursory troubleshooting on the customer's computer. We'll make sure the network card is properly configured and that the IP & DNS settings are properly configured. This is all dependent upon it being a computer running either Windows XP or Vista. If it's a Mac computer, I am probably less knowledgeable than the customer and will explain the concepts and watch as the customer does the configuration themselves.

    Now, if the customer also has a 3rd party router to be inserted between the modem & his/her computer, we are not allowed to touch that. However, because of my networking background, I MIGHT (see conditions above) attempt to get it working - if it can be done quickly.
  • There are two ways, generally, to configure the two devices so that the customer can surf from 1+ computers.
  • Leave the modem configured with the PPPoE in it, and set the router to grab an IP address from the modem. Replacing the modem in this condition requires that we have the customer's username (available on the phone bill) ans password (not available anywhere and must be reset online if the customer has forgotten/lost it). This is the default, but it can be a pain to replace the modem like this. Or, one can ...
  • Set the modem to "bridged" mode, where it is nothing but a dumb modem with no IP configuration or anything, and configure the router to handle the PPPoE. Remember, this is done AFTER all the above configuration has been done & proven it works. Once the modem is configured to bridged mode ("bridging the modem"), it becomes 100% transparent to the entire process from either end with the exception that it changes the DSL signal riding on dialtone to an ethernet signal transported on 10T/100T to your router. To do any further configuration of the modem, after it's set in bridged mode, the modem must be reset to factory specs using the itty-bitty-tiny-whiney little button that performs this function - you can't even get into the modem from the computer, even directly connected, without doing a full reset. When it's done this way, it's easiest for us to replace the modem because we don't even need to know the customer's username or password.
  • In either event, generally, the default settings will work correctly so that the customer can surf from multiple connected computers. Specific applications, such as remote monitoring of a security system with cameras, gaming, etc., are all up to the customer to configure the router for such specific tweaks.

    Finally, a quick recap.
  • If the DSL LED on the modem is not green (with the aforementioned exception), stop there & make sure everything is properly filtered or that you connect the modem outside at the phone company box with the jack inside. Do not pass go, and definitely do not collect $200. If the DSL light is red, you're dead.
  • Connect the computer directly to the modem and get registered and surfing before connecting anything else. If you can't surf with just the modem between the computer & the phone line, you definitely won't be able to do it with a router also inserted.
  • Any other networking devices connected other than AT&T provided equipment are the sole responsibility of the customer - I (or your friendly technican, if capable) MAY do it when we're out there on a service ticket, there may or may not be a charge for it, but we are not certified networking professionals and you definitely don't want us (not even me) connecting and configuring anything more complex than the most simple configuration on the router.

    Hope this helps!
    January 27, 2009 12:56:52 AM

    Heyyaaa!!

    You have moved somewhere else,so you should change your modems configurations,you should change the phone number on the modems setting,because your modem is storing your ex-place phone number
    February 9, 2009 1:47:55 AM

    alirezap said:
    Heyyaaa!!

    You have moved somewhere else,so you should change your modems configurations,you should change the phone number on the modems setting,because your modem is storing your ex-place phone number


    The modem doesn't have any info regarding phone number in it. It only has username & password for the AT&T DSL account. I've setup hundreds of these. If the modem isn't bridged, then it's actively using it's PPPoE client to login to the Internet. It will work any place there is a DSL signal on the phone line, and it's completely independent of the phone number. Now, you HAVE to register your username and password with the phone#, or else you'll just be using someone else's, and they can lock you out with a password change. But, there is no memory for the phone # in the modem. The modem doesn't care what the phone# is, as long as there's a DSL carrier signal on the copper.
    March 3, 2009 2:20:00 AM

    I also thank y'all for saying to change my Linksys NR041 LAN IP to 192.168.2.1
    After doing that, the router finally saw my DSL modem and connected to the internet! Thanks a bundle! I lost a couple days troubleshooting my "upgrade" to AT&T DSL, but the $20 / month savings over Comcast cable will feel great in a little while. Thanks again!
    March 4, 2009 2:33:38 PM

    Yes, the IP address change fixed my problem as well. Even though ATT's instructions said to bridge the modem, I knew that wasn't necessary because it was working fine before (set up by somebody else) without being bridged. I needed to reset my router to reset the passwords. Nothing was working after that until I saw cecil14's comment about how ATT's modems use the same subnet as the default for Linksys. As soon as I changed the router IP address and repowered everything (power up the modem first, then the router), I had Internet on the LAN using automatic configuration (the cable modem option). I did clone the MAC address from the PC which was previously hooked up directly to the modem and had working Internet, but I'm not sure if that was necessary. Thanks for the tip!
    March 4, 2009 2:36:27 PM

    I should note that just changing the last part of the router's IP address (i.e. 192.168.1.xxx instead of the default 192.168.1.1) didn't seem to be sufficient. It only worked after I switched it to 192.168.2.xxx.
    March 6, 2009 10:40:30 PM

    cecil14 said:
    ATT likes to set their modems up to use the 192.168.1.x subnet, which is also what the Linksys (and many others) router uses by default. Hook everything up as normal and leave the router set for DHCP from the modem. Now change the IP of router to 192.168.2.1. The router will reboot, you'll also need to renew the IP on your computer (make sure it gets a 192.168.2.x address) and now you should be good to go. :) 


    aa

    Hi Cecil14
    This worked for me.....
    Saved me $99 from AT&T plus .....

    Regards,
    Lebon
    Anonymous
    April 7, 2009 8:55:45 PM

    mtasker said:
    I just set up my Linksys WRT54G router to connect to ATT/Yahoo DSL with help from this forum.

    1) Keep the ATT modem configured as default (mine is Motorola 2210 and its default is to run PPOE on the modem itself). This is the way the Windows DSL account installation utiliity leaves it.
    2) Set the router to "Automatic Configuration - DHCP"
    3) Set the "Local IP Address" to anything but 192.168.1.*. You can use 192.168.2.1 and it works fine.
    4) Save your router configuration changes.
    5) Turn off modem, router and PC (unless you know your way around the ipconfig /release command.
    6) Restart the modem and wait for the green light to go solid.
    7) Restart the router and wait for it to come up.
    8) Restart your PC. You should be good to go.




    Thank you so much, that worked also for a Linksys BEFSR41 router and AT&T Motorola 2210-02-1006 after two hours of trying to fix the issue. Thanks again!!!!!!!!!!!!!!!!!!!!
    June 2, 2009 3:53:08 AM

    Nice to see it wasn't only me having problems with ATT DSL. Have a linksys providing a Wireless N network and ATT came with a 2wire dsl modem/router combo.

    In the end changing the IP address scope of the 2wire to the 10.0.0.1 range and enabling DHCP to assign the 192.168 range on the linksys did the trick.

    I'm now trying to help my fiancee set up a belkin wireless G with a legacy SBC yahoo modem. Unfortunately I can't see the Belkin interface in front of me so it's an arduous process. Will check back with the proper solution for an old school sbc yahoo dsl modem and Belkin wireless router.
    June 13, 2009 4:43:59 AM

    I have the speedstream 4100 also, which I got when it was SBC here in San Diego. I had the same problem getting the router to work with the modem. SBC customer service had me set the modem in "bridge" mode, and then everything worked out ok. If you are interested I think I have the text of the customer service session where he walked me through it.
    July 6, 2009 2:37:32 AM

    BReed said:
    I have the speedstream 4100 also, which I got when it was SBC here in San Diego. I had the same problem getting the router to work with the modem. SBC customer service had me set the modem in "bridge" mode, and then everything worked out ok. If you are interested I think I have the text of the customer service session where he walked me through it.



    Yes!! I practically have the same problem. Speedstream 4100 B and a Linksys BEFSR41 v.3. Now, ATT claims to only support the Speedstream . Linksys tried but after a while it was back to sq1........

    Thanks for the offer and the info in advance........!
    July 14, 2009 1:02:15 PM

    Quote:
    Thank you so much, that worked also for a Linksys BEFSR41 router and AT&T Motorola 2210-02-1006 after two hours of trying to fix the issue. Thanks again!!!!!!!!!!!!!!!!!!!!


    Good information and seems to be matching what I'm searching today...

    I have been running my WRT54G into a cable modem and it's been great. Making the switch to DSL was a PAIN. I too got the Motorola 2210 and when I tried to set it up, it just killed EVERYTHING.

    Hooked one machine to the DSL and configured IT with the utilities. It works.

    Had to reset my WRT54G and totally rebuild it with my cable settings (we haven't deactivated it yet).

    It is using the 192.168.1.1 default, serving IP addresses (DHCP), and also has several static devices (for DMZ and port forwarding).

    Am I correct in understanding that if I change my router's IP to ...2.1, set it to receive IP automatically - DHCP, which it is currently IS set at, everything else will be fine?

    Will I need to change the host and domain information as well? Currently they have my cable userid and cable provider names in there. Will I need to list any DNS servers? Or can I leave them blank and let the modem do all that?

    I don't want to miss anything setting this up again. I REALLY don't want to have to reset my modem and reconfigure the mac address filters and static IP addresses.

    BTW, I'm running the Tomato firmware, not the standard Linksys firmware (easier to use, faster, and more flexible).

    -Paul
    July 14, 2009 1:08:22 PM

    Also, with my static IP's, should I reconfigure them to be 2.xxx instead of the 1.xxx I'm currently using?

    -Paul
    July 18, 2009 4:09:04 AM

    This is a transcript of when the SBC guy helped me with my SpeedStream. I see a lot of other posts out there that I didn't bother to read because, to be honest, mine works and I don't have enough tech savvy to decipher a lot of what is being said. If this helps anyone, good.

    I am trying to connect Airlink wireless. When I config the Airlink modem to PPPoE, I cannot connect to the i/net. If I leave the modem to Auto Config DHCP I connect, but the wireless doesn't work. I've been told I need to disable the router function of the DSL modem supplied by you. Do I need to do that? How do I do that? DSL modem is Siemens SpeedStream 4100.

    steven 7:27 PM Dec 31 2006

    I apologize for any inconvenience this has caused you.
    steven 7:27 PM Dec 31 2006

    I’m providing you an overview on how you should approach for establishing Internet connection using your Router through SBC Yahoo! DSL Connection; I’ll provide detailed instruction afterwards.
    steven 7:27 PM Dec 31 2006

    This is what you have to do: -
    a) Put your DSL Modem into bridge mode. We put DSL Modem into bridge mode when we wish to use other networking equipments like Router with it. Please note that your DSL Modem should be connected to computer directly while putting DSL Modem into bridge mode.
    b) Insert your Router within your DSL Modem and Computer. The yellow Ethernet cable from DSL Modem should go to the WAN/ Internet port of Router and Ethernet cable from one of the Ethernet port from Router should go into the Computer’s Ethernet port.
    c) Pull up the GUI of you Router and insert the ISP Settings.
    d) Restart your DSL Modem and your Router subsequently and you should be now online.
    carpenterbob@sbcglobal.net 7:28 PM Dec 31 2006


    Let me provide you detailed instructions now on how to proceed with each step that I just mentioned. You can copy-paste these steps in a notepad or MS Word document so that you can follow them easily later as you’ll lose session with me as soon as you put your DSL Modem into bridge mode. Are you ready?
    carpenterbob@sbcglobal.net 7:29 PM Dec 31 2006


    When you use router, you need to use the PPPoE connection software of your router to connect to Internet, and that is why we need to put the DSL modem in bridge mode. So, that the PPPoE connection software of your DSL Modem does not conflict with your router PPPoE.
    steven 7:30 PM Dec 31 2006

    Here is the detailed instruction for 1st steps that’s putting your DSL Modem into bridge mode.
    1. In your web browser browse to http://192.168.0.1 This address will be located on a yellow sticker on the bottom of your modem.
    2. The first screen will ask you for your Modem Access Code. This also will be located on the same yellow sticker.
    3. Select Advanced from the blue buttons on the left.
    4. Click the PPP locations button.
    5. The modem may ask you for the Modem Access Code again. If so type it in again and click continue.
    6. Select the radio button labeled, "Bridged Mode (PPPoE is not used)"
    7. Click Save Changes.
    8. A "PPP Location Warning" page will come up. Click "Change PPP Location."
    9. A "Restart Needed" page will come up. Click "Restart"
    -
    All right, 2nd step is straightforward wherein you have to just insert your Router between your DSL Modem and Computer.

    In the 3rd step, you have to pull up the GUI (Web Console) of your Router and insert some simple settings. The settings are: -
    1) In the Internet Connection Type, you have to select PPPoE.
    2) Username: Please enter your complete SBC Yahoo! Account e-mail address including the domain name '@sbcglobal.net'.
    3) Password: Enter your correct SBC Yahoo! Account password.
    4) Router Name / Host Name / Domain Name / Service Name: You can enter any name of your choice.
    5) Primary DNS / Secondary DNS: 68.94.156.1 / 68.94.157.1


    Then restart your DSL Modem and your Router subsequently and you should be now online.`
    carpenterbob@sbcglobal.net 7:38 PM Dec 31 2006


    If you ever wish to disconnect your Router and connect directly with your DSL Modem then you need to click on the reset button at the back of your modem under the yellow sticker. This button is there to reset the modem back to factory settings, if the modem is not properly configured.
    Using a Ballpoint pen, press the reset button thru / under the paper label for 2 seconds, and release. Then, wait 60 seconds for modem to complete the reset cycle.
    You need to follow the steps to connect to the Internet using your modem after you reset it:
    1. In your web browser browse to http://192.168.0.1 This address will be located on a yellow sticker on the bottom of your modem.
    2. The first screen will ask you for your “Modem Access Code”. This also will be located on the same yellow sticker.
    3. At the login screen type in your SBC Internet Services member ID and password.
    4. Click on “Connect”.
    5. If everything is successful you will get a screen that says, "You Are Connected." and your Internet light will go solid green. If you username or password is invalid you will get a screen stating such. If there are other problems you will get a screen stating, "The DSL connection is down."


    If you need further assistance with configuring your router using these settings, I suggest that you contact either your router vendor or Support+. SBC Support + is a fee based technical support service. You can contact Support+ at 1-866-294-3464. I assure you that they will assist you in resolving your issue. They are available from 9 AM to 11 PM.
    July 20, 2009 8:17:23 AM

    mtasker said:
    I just set up my Linksys WRT54G router to connect to ATT/Yahoo DSL with help from this forum.

    1) Keep the ATT modem configured as default (mine is Motorola 2210 and its default is to run PPOE on the modem itself). This is the way the Windows DSL account installation utiliity leaves it.
    2) Set the router to "Automatic Configuration - DHCP"
    3) Set the "Local IP Address" to anything but 192.168.1.*. You can use 192.168.2.1 and it works fine.
    4) Save your router configuration changes.
    5) Turn off modem, router and PC (unless you know your way around the ipconfig /release command.
    6) Restart the modem and wait for the green light to go solid.
    7) Restart the router and wait for it to come up.
    8) Restart your PC. You should be good to go.


    Thanks so much mtasker, so simple, just changed router to 192.168.2.1, restarted everything, and it worked fine.

    ATT customer service is HORRIBLE.
    Graham
    Anonymous
    August 11, 2009 12:32:38 PM

    I have had the same modem (ATT) and router (Cisco/Linksys) issues. I can get online w/out problems if I disconnect the router, but the router messes up the connection. I have spend over 10 hours on the telephone with ATT tech support and an hour with Linksys support. Still the same issues.

    I did find it interesting that one ATT tech reassured me that if I purchased an ATT 2-wire modem their tech support peeps could help me with router and modem issues.

    While not a conspiracy nut, I am getting the feeling that the ATT modems might be intentionally set to not work consistently with other routers in an ATT attempt to collect even more of our $$.

    I will most likely give in an purchase the 2-wire from ATT OR switch to a provider that does not require a modem.

    Any thoughts on how to get out of the ATT web of tech issues and telephone calls?
    August 15, 2009 2:21:44 AM

    I have a Linksys WRT54G wireless router which is notorious for losing the signal from the modem on a fairly regular (3-5 time weekly) basis. The only solution is to unplug the router, wait aboyt 15 seconds, plug it back in, and it will work MOST of the time until next time. I went online and read 12 costomer reviews of this router, of which TEN were between bad and horrible. I wouldn't hit a pig in the behind with a Linksys router. By the way, I DO NOT have ATT internet.
    August 15, 2009 10:40:07 PM

    mtasker said:
    I just set up my Linksys WRT54G router to connect to ATT/Yahoo DSL with help from this forum.

    1) Keep the ATT modem configured as default (mine is Motorola 2210 and its default is to run PPOE on the modem itself). This is the way the Windows DSL account installation utiliity leaves it.
    2) Set the router to "Automatic Configuration - DHCP"
    3) Set the "Local IP Address" to anything but 192.168.1.*. You can use 192.168.2.1 and it works fine.
    4) Save your router configuration changes.
    5) Turn off modem, router and PC (unless you know your way around the ipconfig /release command.
    6) Restart the modem and wait for the green light to go solid.
    7) Restart the router and wait for it to come up.
    8) Restart your PC. You should be good to go.

    Anonymous
    August 17, 2009 10:42:48 PM

    I found this forum before I signed up for AT&T DSL, did not want to use thier gateway, since I already had Draft N. Set my Airlink router to 198.168.2.1, instant connect. This forum saved me alot of grief. Thanks a million.
    Anonymous
    August 20, 2009 7:34:57 PM

    For use with a motorola modem and linksys router

    Log into the modem
    Make sure that use private IP address is selected under Connection configuration > LAN

    Log into the Linksys router
    Under setup change the ip address (router IP) to 192.168.2.1
    !