Sign in with
Sign up | Sign in
Your question
Closed

Slow file transfer speeds across 2 pc's on home network!!!

Last response: in Components
Share
April 13, 2007 3:19:10 PM

Basically, I bought a Netgear Rangemax WPN824 cable router (108 Mbps) a while back. I've hooked it up in my house downstairs in the lounge. I've got a computer downstairs wired up using a direct cable to it and also a computer upstairs which accesses it wirelessly using a Netgear WPN111 USB adapter (108 Mbps). Everything is fine when surfing the web on both machines and we receive good speeds. The wireless connection to the machine upstairs is also pretty good, usually sitting at about 8/10 signal strength. When I ping between the two machines (the wireless one and the directly connected one) it does so without any lost packets and at a speed of <1ms.

Now the problem comes when we try to transfer files between machines. For some reason the transfer speeds are pretty rubbish, usually around 100kb/s. Surely we should get more than this across out network right?

Can anyone help me out?

Thanks.
April 13, 2007 6:19:14 PM

I have a netgear wrt624 108 mbps router, and a netgear 108 mbps laptop pcmia card, but I never get the 108 mbps connection, even with the laptop and the router in the same room.

Most people's connection rate for 802.11G would be 20mbps or so, not the 54 promised by 802.11G. I would expect maybe 1.5 to 2.0 Mbytes per sec on a good day, but sometimes my wireless connection slowed right down. I think this is due to the many other wireless networks near to me.

Check what other wireless networks the upstairs machine can see. If there are many then that may be the reason for the slow speeds. You should also check that the router is set to support 802.11G. If its set to 802.11B then it will only get 1 to 11 mbps. It may make sense to set the router to only support 802.11G, I think having it support both B and G slows down the clients with a 802.11G connection.

You should also ensure that the USB adapter is connected straight into the machine upstairs (i.e. not through a USB hub). Check that the USB port used is a USB 2.0 port, and not 1.1. If you are still having problems I would try disconnecting any unneeded USB devices on the machine.

My area got so "crowded" (about 10 - 15 other home wireless networks)and the wireless conections so bad that I've disabled the wireless on the wrt624 and just connect via a network lead.

Rob Murphy
April 17, 2007 8:07:33 PM

With a Netgear DG834PN (108MB/s)and a Netgear WPN111 (108MB/s), I usually get 54mbps (this is due to the way the router is configured) and during large file transfers across the WiFi, get the full 108. This is probably because there is only a stud wall between me and my router.
Related resources
May 13, 2007 5:43:54 PM

Your never gonna get the advertised 54 or 108mb/s, even if your computer is showing a 54 or 108 connection your not really getting that speed. Your lucky if you get half those speeds in real world situations, 20mb/s is common with 54g Another thing to consider is that differant brands dont always work well together, if you want the full speed your wireless router is capable of make sure you use the wireless card thats made for yourrouter, mixing and matching almost always results in less performance. Also if you have a computer with a 54g card and one with a 108g card on the same network you will onlyconnect at the speed of the slowest client. And finally just like other computer hardware there are both good and bad performing routers out there. If you want good performance go for one of the good performing routers such as the Dlink dir655, Netgear Rangemax240...etc chec out Toms Router charts for performance comaprisons.
February 5, 2009 1:29:45 AM

R you guys going to anwser the question or talk about stuff everyone knows. How do I fix a slow network. I can download files from the internet at 1MB/s but can only transfer from pc to pc at 100-200 KB/s. I realize even 20mb/s, (2.5MB/s) connection would be nice from pc to pc.
February 5, 2009 11:09:00 AM

What is the OS you are you using?

Vista sucks for file transfer from PC to PC through wireless.

Also with out looking at your router config we cant really help unless somebody had that router infront of them.


February 5, 2009 11:59:00 AM

Guys, this thread is from 2007.
February 19, 2009 2:56:52 PM

Well, i have the same problem between 1 desktop and 1 laptop, both with vista home premium 64 bit. File transfert between the 2 is very slow. My router is a dlink 614+. My wireless card on the desktop is a xtreme n pci-e. The laptop is a toshiba with a biult in wireless card. Both have good performance on internet. The router is 802.11b

Is there to speed up file transfert ?

This thread is 2009 ;) 
February 19, 2009 10:41:13 PM

necroed...

Ummm my advice would be to buy a Cat5e cable... everytime ive tried to use wireless its slow it drops out its insecure latency is through the roof...

Cable is cheap, fast, secure everything wireless isnt.
April 3, 2009 7:32:40 AM

Even though this is an old post, it was one of the first results google gave me when I searched. I was basically having the same problems as the original poster when trying to transfer speeds from one PC to another on a simple Windows XP network: I was only getting speeds up to 70 KB/s, when I know it can do more. You may ask how I know, well there are actually three PCs on this network. Let's say PC-A has the data, which are video files since it's an HTPC. PC-B and PC-A had no problems transferring this data at full speed, in the MB/s. When I connected PC-C to the network, I was not able to see those transfer speeds.

Here's how I resolved the issue: I changed the speed/duplex settings for the network adapter on PC-C. Apparently it was in a "Force 100 Full Duplex" mode. I simply changed the value to "Full autonegotiate".

If you are wondering how to access these settings, you have a couple of ways. First, open the Device Manager and find your network adapter. Right click on it and go to Properties. Then go to the Advanced tab. Finally select the "speed/duplex settings", change it's value to the right, and hit ok.

Another way to get there is to go to the Control Panel and open up Network Connections. Right click on the network adapter in question and go to properties. Under the first tab, click on the Configure button, and the rest is the same as before.

Hope this works for others and saves some time.
July 22, 2009 8:05:49 PM

Thanks Cusideabelinc for pointing me in the right direction. My fix was a bit different though even though I was having the same issue. I'm on a Vista laptop transfering data to a XP desktop. Here are my steps:

1. First, open the Device Manager and find your wireless network adapter.
2. Right click on it and go to Properties.
3. Then go to the Advanced tab.
4. Select Wireless Mode under Property
5. Change the Value to 3.802.11g

My connection was originally set up as 6.802.11/b/g which was causing the slowup. Hope this helps.
September 1, 2009 1:09:28 AM

I have, of course, a similar problem. I have a Linksys WRT54GX2 router that is connected to the WAN port of a Thecus NAS and also connected by cat5e cable to my PC. Internet download is great but anytime I need to send data upstream it's capped at about 1.3 mbps...so moving files onto or off of the NAS takes way too long. My guess is that the bottleneck seems to be anytime data is sent upstream to the router.

The only thing that has made a difference was switching from auto negotiate to 100 mbps half duplex...that increased the speed from .9 mbps to the current 1.3 mbps.
September 4, 2009 4:42:33 PM

Guys, this thread is from 2007.
September 4, 2009 4:48:55 PM

thumbchi3 said:
Guys, this thread is from 2007.


So yes, I suppose the first 2009 post could have started a new thread...but nevertheless, it appears some people have the same problem here in 2009 regardless of if the original poster was in 2007 ;) 
November 25, 2009 10:59:43 PM

hey guys this may or maynot help everyone but i was tinkering with the duplex modes for my network cards because i was unsatisfied with 2 mb/s i have had my vista and xp pro machine transfer much higher than my outcome is but after setting the duplex modes to auto negotiate on both it went from 2 up to 11 mbs this may help some anyways if i can get my transfers back to 1 gb/s like i used to have them i will reply again (side note it was with a netgear no idea what the model was sorry )good luck
Anonymous
June 3, 2010 3:40:03 AM

Hello,
Landed here from Google due to only getting 100Kbps on my brand new wireless-n router (TrendNet). Turns out that the theme of restricting operations to the highest speed mode works a charm. I changed to "green field" mode and restricted to "Wireless N Only" which immediately (in the middle of a file transfer) boosted my speed from 100 KBps to 12 MBps (and yes, that's a capital B).
April 27, 2011 2:24:47 PM

Hello there again, folks! Gotta nearly the same problem. Transfer between Desktop and Laptop is 1MB/s. My router is Siemens SL2-141. Desktop is connected with a Ralink 802.11 Wireless 54Mbps Adapter. Laptop's adapter is Intel WiFi Link 1000 BGN.
Changing channel on a router didn't help any.
August 13, 2011 10:45:25 PM

Me too, Vista to transfer to a Windows 7 new computer. Surprisingly it only took an hour to connect the computer but now transfer times are capped at 1.3mbps. So yeah, its an old thread, but this is an old issue with NO solutions.

The fact that there is the same bottleneck speed and all have Vista involved is the reason I say they are all linked - regardless of the routers. The solution is not "vista sucks!", we get that, but its being used. And "this thread is from 2007" is only a part of the problem. :non: 

I hope someone has the intelligence to help us here, those with (so it seams) less than stellar intelligence in this area. :)  ;) 
October 21, 2011 1:27:56 AM

I had the 100 KBPS problem.

Thanks to one of the posts above, I was able to resolve this. I'll simplify this, since this appears to be the #1 hit for "home network speed slow" on Google.

I have Vista.

Go to Control Panel, choose System and Open it.

Click on Device Manger under Tasks on the left panel. It requires admin privs, so click continue if it asks.

Under Network Adapters, you should see your network card. (Mine is Intel(R) 82566DC Gigabit Network Connection). Right click on it and choose Properties.

Click on the Advanced tab.

Under Property, choose Link Speed & Duplex. My value was set to 1000 Mbps Full Duplex. I changed it to Auto Negotiation. Click Okay.

Now you should have amazingly faster transfer speeds.
October 21, 2011 1:30:44 AM

Old thread is old and dead, let it stay that way.
!