Sign in with
Sign up | Sign in
Your question

Access Denied when installing drivers - HELP PLEASE

Last response: in Graphics & Displays
Share
April 13, 2007 3:25:25 PM

Okay guys, I have an HP XW4200 with an nvidia quadro. Well a driver update was installed and when it rebooted it came up in VGA mode and won't work correctly. No problem, right? Uninstall the drivers and install the correct one. Well everytime I try and uninstall it says it can't because the PC may need this device to boot. It will also not let me install another driver saying that Access is denied. Tried the setup program, updating in Device Manager, rolling back, safe mode... everything. I am logged in as an Administrator.

Please help me. Formatting is the LAST option which I would like to avoid.

Thanks!
April 22, 2007 5:52:14 AM

I have the exact same problem, I am adminstrator. First I tried updating my network card drivers for both my wireless and network card. It uninstalled the first and tried installing but failed because "Access is Denied." So then my internet wouldn't work. I tried safemode, tried editing my registry for that specific driver, etc all failed. I ran a system restore and it fixed it, but I still couldn't update my driver. So today my SVChost screwed up and was taking up 130,000mb and lagging everything, so I end tasked and restarted, and my screen was now 800 by 600. I tried to install an ATI x1300 graphics driver and it failed because "Access is Denied". Windows tried installing a generic VGA one also but it failed because "Access is Denied." (edit) I also rolled back this time, but the driver wasn't fixed.

I can't find anything on this, I was thinking maybe it was some recent windows update maybe?
April 22, 2007 6:18:00 AM

I uninstalled all april 11th updates to see if that was what was preventing me from installing them and it failed again.

I also tried on Safe Mode.
Related resources
April 22, 2007 7:36:22 AM

there is an error in one of the registry keys under HK_local_machine\System\CurrentControlSet\Enum\PCI\VEN_big long number

the device description is the VGA driver

the folder with the error is Device Parameters when i right click it to change permissions it says Permissions not in order, this may cause conflicts. I uninstall the VEN folder dissapears, i reinstall it (Plug n Play install standard VGA), right click the folder save error is given...
April 22, 2007 8:58:45 AM

He's the end of the setupapi.log I bolded the error. I have spent hours searching the web. It is some permissions problem, I'm not sure why doing it. I tried to set all of the permissions and subpermissions and it didn't work. Going to try in Safe Mode.


.....
@ 03:22:40.406 #V132 File "C:\WINDOWS\system32\ATIDEMGR.dll" (key "ATIDEMGR.dll") is signed in catalog "C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem0.CAT".
@ 03:22:40.406 #V191 File "C:\WINDOWS\system32\ATIDEMGR.dll" pruned from copy.
@ 03:22:40.421 #V132 File "C:\WINDOWS\system32\atifglpf.xml" (key "atifglpf.xml") is signed in catalog "C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem0.CAT".
@ 03:22:40.421 #V191 File "C:\WINDOWS\system32\atifglpf.xml" pruned from copy.
@ 03:22:40.453 #V132 File "C:\WINDOWS\system32\atioglxx.dll" (key "atioglxx.dll") is signed in catalog "C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem0.CAT".
@ 03:22:40.468 #V191 File "C:\WINDOWS\system32\atioglxx.dll" pruned from copy.
@ 03:22:40.515 #V132 File "C:\WINDOWS\system32\atioglx1.dll" (key "atioglx1.dll") is signed in catalog "C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem0.CAT".
@ 03:22:40.515 #V191 File "C:\WINDOWS\system32\atioglx1.dll" pruned from copy.
@ 03:22:40.531 #V132 File "C:\WINDOWS\system32\atiiiexx.dll" (key "atiiiexx.dll") is signed in catalog "C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem0.CAT".
@ 03:22:40.531 #V191 File "C:\WINDOWS\system32\atiiiexx.dll" pruned from copy.
@ 03:22:40.531 #T183 Install Files (nothing in queue): Verifying catalogs/INFs.
@ 03:22:40.531 #T184 Install Files (nothing in queue): Verifying catalogs/INFs completed.
@ 03:22:40.546 #V166 Device install function: DIF_REGISTER_COINSTALLERS.
@ 03:22:40.546 #T152 Executing class installer.
@ 03:22:40.546 #V153 Completed class installer.
@ 03:22:40.562 #V155 Executing default installer.
@ 03:22:40.562 #V005 Opened the PNF file of "c:\windows\inf\oem0.inf" (Language = 0409).
@ 03:22:40.562 #I056 Coinstallers registered.
@ 03:22:40.578 #V156 Completed default installer.
@ 03:22:40.578 #V166 Device install function: DIF_INSTALLINTERFACES.
@ 03:22:40.578 #T152 Executing class installer.
@ 03:22:40.593 #V153 Completed class installer.
@ 03:22:40.593 #V155 Executing default installer.
@ 03:22:40.593 #V005 Opened the PNF file of "c:\windows\inf\oem0.inf" (Language = 0409).
@ 03:22:40.609 #V011 Installing section [ati2mtag_M52.Interfaces] from "c:\windows\inf\oem0.inf".
@ 03:22:40.609 #I054 Interfaces installed.
@ 03:22:40.609 #V156 Completed default installer.
@ 03:22:40.609 #V166 Device install function: DIF_INSTALLDEVICE.
@ 03:22:40.625 #T152 Executing class installer.
@ 03:22:40.734 #V005 Opened the PNF file of "c:\windows\inf\oem0.inf" (Language = 0409).
#-035 Processing service Add/Delete section [ati2mtag_M52.Services].
@ 03:22:40.953 #V282 Add Service: Modified existing service "ati2mtag".
@ 03:22:40.953 #E033 Error 5: Access is denied.
@ 03:22:40.953 #E275 Error while installing services. Error 5: Access is denied.
@ 03:22:40.968 #E154 Class installer failed. Error 5: Access is denied.

@ 03:22:44.578 #V166 Device install function: DIF_DESTROYPRIVATEDATA.
@ 03:22:44.593 #T152 Executing class installer.
@ 03:22:44.609 #V153 Completed class installer.
@ 03:22:44.625 #V155 Executing default installer.
@ 03:22:44.625 #V156 Completed default installer.
April 22, 2007 9:12:20 AM

No Luck in Safe Mode...
April 22, 2007 9:38:25 AM

Not an expert in this and you may know more about this than me so apologies if not helping but are both these problems related to file attributes?

You need to know all the driver files and then check their file attributes. If they 'think' they are being used by the system then you get the message 'access denied' while trying to delete.
April 22, 2007 9:56:12 AM

Nope, It wouldn't be a problem, because I have tried 3 different drivers. Original that came preinstalled, windows generica VGA, and updated ATI. Plus it did the same thing with the two network card drivers. This is a Dell Laptop. Sorry I sort of hijacked the thread...
April 22, 2007 3:16:43 PM

XP Pro
April 22, 2007 7:00:38 PM

I think I have XP Media center on this, not sure which it is...
April 22, 2007 8:11:30 PM

In the absence of anybody else helping all I can suggest is:

Roll back to time when everything works then set the graphics to VGA/disable network card and uninstall/remove old video/network drivers then try fresh install.

You may be in a loop: The file attributes may be set to not allow removal because of the corrupt registry. You may not then be able to roll back because you can't remove the new files. If you disable the card/network there is a chance to get out of the loop by deleting the drivers. You may be able to delete in safe mode if not in normal boot.

Only other thing is to try cleaning the registry either with regedit or with registry tool that removes corrupt entries.
April 22, 2007 8:19:08 PM

I've tried all of those things :( .
April 22, 2007 8:30:40 PM

Think you may be F***ed

One of the truly great things about Windows is that it always knows better and once it has made up its mind it requires really detailed knowledge to circumvent its actions. You are either going to have reinstall or try re-posting to interest a real registry expert.

Sorry can't help more
April 22, 2007 8:45:46 PM

I found out why System Restore didn't work :(  It failed... Twice... My computer hates me, I'm going to try and replace SVCHost

Thanks a lot for your help muddle.
April 22, 2007 8:56:22 PM

In that case you may have missed the point I was making i.e.:

You won't be able to do a system restore if Windows can't delete the video driver files to replace the old files. You can't delete the video driver files because the registry is corrupt and this precludes removing the driver using normal means.

Have to boot in safe mode and delete the offending files if necessary changing their attributes. At the same time set video card to standard VGA.

Reboot normally hopefully now using standard VGA driver and uninstall/remove any reference to old and new video drivers including registry.

Now try roll-back
April 22, 2007 10:26:57 PM

The reason I didn't do that was because the roll back worked for the same problem with the NIC card drivers. I will try that, thanks. Any idea how I find out which files are the drivers files? I moved all the ATI**** files in system32\drivers to a backup folder and tried and it didn't work, the files were all replaced like new.
April 22, 2007 11:34:35 PM

They are either in the inf file or in a similar text file that comes with the install

Good luck this may not work but it's worth a try
April 23, 2007 12:05:41 AM

I'd consider trying to use a different vid card alltogether(borrow one or something) to boot with then clean out the drivers with drive cleaner pro then reintall the quatro from scratch.
April 23, 2007 12:37:45 AM

It sounds like your system registry is corrupted. It is possible that the file permissions on your registry have been reset (malware?). I've seen it happen.
Go into regedit and set the permissions for all the registry keys to all allow the administator account to have full control. Make sure the changes propagate to all child keys. If any keys refuse to reset permissions, you've found the bad ones. You will have to take ownership of the keys with the administrator account before you can change them.
Be careful when fooling around in the system registry. If you accidentally delete the wrong keys, poof! No more windows for you!

You also may have to turn off windows system file protection when you uninstall the driver files.

Good luck!
a b U Graphics card
April 23, 2007 1:09:44 AM

Here's something to try if all this has failed. If you are having trouble with your video drivers download Driver Cleaner (Gizoogle it) Guru3D has it I think. Install it and run all the scripts that pertain to your card (I think that you mentioned ATI). I would just run all the ATI scripts, it can't hurt anything if the registry entry and files that it is trying to remove don't exist, it just moves on to the next. It might be better to run this from Safe Mode (I think that's what the instructions that come with it say to do). Then try rebooting into windows and installing your driver. Hope that helps.
April 23, 2007 1:17:28 AM

I have tried reseting the permissions in the registry actually, and i am kicked back with the error "Some of the children etc etc can not be changed" only the local machine set. I guess i need to narrow it down and find which ones... I'm going to try that video thing first and try the registry second since it takes longer. Thanks for the help :) 

It's a laptop, and it's not a problem with the hardware, it's software, so there really isn't any way to replace the card easily. Thanks though.
April 23, 2007 2:08:32 AM

We re-imaged the PC already. lol, thanks for all the help though guys. Hopefully mankind can get it figured out.
April 23, 2007 2:51:33 AM

I am having major non-video problems now... Things taking forever to open, browsing for drivers freezing every time i try to point to the drivers etc. I think that one or several of the major system files is corrupt some how. Is there an easy way to replace a bunch of them? i386 folder or something in command prompt safe mode?... If I can't replace these then I am going to reformat...

It can't find the driver files after I point to them.

Access is Denied again.
April 23, 2007 3:45:39 AM

it's not the bios. gah my computer hates meee.
April 23, 2007 5:57:36 AM

I gave up and restored it to the original installation. I hate Microsoft....
Anonymous
a b U Graphics card
a b \ Driver
a b α HP
August 21, 2009 8:07:56 AM

THEN DIE! WHAHAAHAH

RE INSTALL YOUR OS ^^
a b U Graphics card
a b \ Driver
August 21, 2009 2:26:15 PM

Only took you two years and 4 months to think of that witty response?

Thank you for being a fine example of Public Education in action.


Anonymous
a b U Graphics card
a b \ Driver
a b α HP
January 11, 2010 11:36:39 AM

I guess it is a bit late to answer but I found the thread when searching for a solution to the same problem and thought I should add my solution.

Description:
Had an Nvidia card and then switched to an ATI card for awhile and then went back to the Nvidia card and then couldn't couldn't install drivers for it with the reason being that access is denied after the installer copied the files to the windows folder. Updated the system from SP2 to SP3 as well and the problem persisted.

Solution:
Deleted all nv*.* files in Windows/system32 folder and installed the card again. I tried driver sweeper from guru3d but i could delete the nvidia files even in safe mode, but it was a good help in finding the driver files that should be deleted.



January 12, 2010 12:18:40 AM

There's a simple fix for this. When installing, select No to windows update. Then select INSTALL FROM A SPECIFIC LOCATION and then choose DON'T SEARCH. I WILL CHOOSE THE DRIVER TO INSTALL.
Go from there and select Display Driver as the type and then point it at the driver. It will then install fine
April 18, 2010 8:33:07 PM

after spending half my life fixing windows problems i'm going to buy a mac :hello: 
April 18, 2010 9:03:03 PM

Make sure to buy Apple Care.
April 19, 2010 6:30:08 AM

Reinstall windows?
Anonymous
a b U Graphics card
a b \ Driver
a b α HP
November 30, 2010 5:54:52 PM

I had the same problem with the sound device. I solved it just restoring the system for an earlier data point (about 3 months ago).
!