Sign in with
Sign up | Sign in
Your question

Linux ate my computer

Last response: in Linux/Free BSD
Share
October 7, 2006 8:57:09 PM

Hello

Last night I had decided that I'd put those Ubuntu Linux CD's to good use and I installed it. I had first opened partition magic and clicked on the "Install a new operating system" and created a 15 gig partition at the end of my drive. It told me that I should put that as my primary partition, so I did.

I then restarted and PT did its work and I put in the Ubuntu 64 bit cd. I played around with it for a while and it ended up not working. I did not touch the xp partition during installation, but Ubuntu said that it failed to install the primary components for some reason (error code 1). I then tried it with my x86 version and it worked all good. Then came the part that happened exactly the same when I tried using the live cds for both 64 bit and x86 versions. It gave me this error message about it not being able to start xserver because it could not find any graphics card (I'm thinking this is because it is older than my graphics card, a 7600gt). So I then restarted and went into windows XP.

Now this is sounding like I want to fix my Linux, which I do, but my main concern is Windows XP (since it has all my games, programs and files, which I don't have backed up as of right now). I will worry about getting Linux to work after XP.

I had forgotten to mention that it asked me if I wanted to install some kind of boot manager, and that if it had found all my installations that it would be a good idea to, so I clicked ok (winxp was there). That was during the installation of Ubuntu.

So when I restarted and clicked on XP on the funky boot manager. Windows was starting up as normal la de da until it came to a screen which I would assume was going to be for check disk, except it came up with two errors. It said that it could not find XMNT2002 or autochk. It then flashed a BSOD, too quickly for me to see what it was, and then restarted.

So I then proceeded to pop in my xp cd and go into a recovery console. I ran a chkdsk and it said that it found a few errors. Restart, no change. I then tried to do a repair install, but it came up with this.

partition C: (inactive OS/2 Boot Manager)

And when I chose that partition to install XP on, it says that it cannot install there because it does not recognise the partition. The Linux partition is in some weirdo format as well that xp doesn't recognise so when I'm in the recovery console I can't access the drives information.

If anyone knows how I could fix this problem, that'd be really cool. I'd like to at least get my XP partition back, because I REALLY don't want to have to reinstall everything after backing up onto my brothers computer, that would just suck.

Note: I also posted this in the XP support forum but since this is a joint Linux-Windows effort to mess with my head, I think it deserves to be in both. Also all the smart people use Linux anyways.

More about : linux ate computer

a b 5 Linux
October 8, 2006 8:17:35 PM

Just so everyone knows Linux didn't eat the computer :-D :lol: 
a b 5 Linux
October 9, 2006 7:17:39 PM

Ok, first things first:

I would boot a partition-checking tool (I suggest gparted livecd, same look-and-feel as PM but can handle many more types of filesystems). Check the layout of what's been done to your machine. If the NTFS XP partition isn't bootable or is marked as hidden, you can (and should) make it bootable and not-hidden. At this time I'd also suggest removing the Linux partitions and leaving the space emtpy (in case you want to try again later).

Then use the windows recovery console to reset the Windows MBR (fixmbr) to try to get just windows booting again. If that works, great, next time don't use PM as it can really screw stuff up, as you can see. Continue if things are still not working.

Next, it looks as if a similar issue is discussed here and it seems to be directly linked to resizing with PM. It may not be possible to follow these instructions (as you can't boot, but you can edit the reg from the recovery console I recall) but they are a start.

If things still don't look right to you, I'd suggest trying to do a recovery install like you already did. Only do this if there was something off previously about the NTFS partition like that it was hidden or non-bootable making it unusable to the Windows installer. If that's not the case and Windows still doesn't see the old install, I'm afraid you're looking pretty grim. One final thing to try before we get into trying to recover all of your important data.

One final attempt at rebuilding the core files without a reinstall is the so-called "bootcfg /rebuild" rebuild. Read on, he's a bit wordy, but the good stuff's in there. If this fails, I don't know of any other alternate means to get things back so it may be time to backup the important data, and if you need help doing that from a livecd environment, come back and we'll be glad to help.
Related resources
Can't find your answer ? Ask !
October 10, 2006 1:48:49 AM

Oh don't worry anymore, I got it all figured out, for the most part. I fixed the windows not booting thing by myself and the linux part I got help from Linux_0 (bless his soul).

Here's what had happened. Yes the partition was set as hidden, so on the linux bootloader (I can't remember what it's called right now and I don't feel like restarting just to find out) had turned my XP partition into a hidden partition for some reason, so I had to go into the bootloader console and change it to and active partition. XP still would've worked if it was a hidden partition, it was just that since I went straight from the partition resize to Linux, Partition magic hadn't finished for some reason, it still had to verify the partitions or something. Probably if I change this partition back to hidden, it would still boot fine.

As for the Linux thing, Linux_0 and I worked on it for a long time before he realised that I had quite an old version of Ubuntu (5.1) and so he told me to download Fedora Core 5. I think tonight I'm gonna try getting my wireless working (it would work with Ubuntu without needing more drivers so hopefully it wont be ridonculously hard with FC5) and then I'm gonna get the nvidia update that it was so crucial for Ubuntu to have.
a b 5 Linux
October 14, 2006 6:38:51 PM

Usually, marking a partition as hidden is a trick that PM plays, the bootloader (if anything) might just clear the "bootable" flag, but Iam glad to see things got straightened out.

If your wireless card worked fine with the older Ubuntu, I have no doubt it will either work out-of-the-box with a newer Fedora or it will be trivial to setup.

As for the nvidia stuff, it should be pretty easy to find a Fedora-specific guide (although with the installer it's pretty damn easy with or without a guide)
!