Please help with Asrock LAN issues.

I originally posted this in the Networking section, so I posted it here hoping for a response, as I have a limited time to get this fixed, mods, sorry for the double-post:

Okay, i've built several computers and never been stopped cold by a problem like this; I really need some help.
I am building new box for a friend, the components are as follows:

URLAsrock AM2NF6G-VSTA motherboard (nForce4 405 chipset with GeForce 6100 integrated Video)
AMD X2 64 5200+ CPU
2GB DDR2 800 Crucial Ballistix RAM
400GB Seagate 7200.10 SATA HDD
Samsung Dual Layer CD/DVD drive
Hauppage TV tuner PCI card
D-Link Wireless-G PCI card
URLAntec NSK3300 Case
I am using the integrated video as well.

My problem is after assembling the system, I cannot get the onboard LAN to load the driver for it.
I:
-Installed WinXP pro
-Inserted the Asrock Driver CD
-installed the AMD CPU driver, Audio Driver, then All-in-one Nforce driver, restarting between each.
-Downloaded the latest driver off the web, still won't work.
All devices install fine, but "Nforce ethernet controller" has a yellow/black exclamation mark next to it. When "properties" is clicked- under "device status it says- "This device cannot find enough free resources that it can use. (Code 12)
"If you want to use this device, you will need to disable one of the other devices in the system." So I disabled the floppy disk controller, COM & EPT printer ports, and the standard game port. No change. I have tried to right click on it and "update driver" then browse to the ethernet driver inside the all-in-one pack with no success.
I removed all the PCI cards, then re-formatted & reinstalled XP; loading the drivers off the Asrock disk immediately after the XP install was done. The new hardware wizard still says it could not find the driver. I even tried drivers from other boards using the same Realtek PHY RTL8201CL chip.
I then looked on their website and saw there were a few BIOS changes regarding LAN in their updates. the first BIOS version listed was 1.0, my board came with 1.2 loaded on it; with 2.1 being the latest version. I flashed the BIOS to 2.1, no change.
This is really a confusing problem, and am about to RMA the board. I emailed Asrock customer service, bu they have not gotten back to me. Does anyone have any ideas what the issue could be? Thanks
2 answers Last reply
More about please asrock issues
  1. I would remove the d-link and hauppage cards and try it again. You can also download the latest nvidia driver off their website. Install the cards after you load the lan driver and look for conflicts.
  2. I had already tried without the PCI cards installed. I found the problem though. The problem was that I was installing a nLited version od Windows that apparently cut too deep in the networking department. I used a full version, and all the drivers (including the ethernet) installed fine. Thanks for your response.
Ask a new question

Read More

Motherboards