Sign in with
Sign up | Sign in
Your question

SuSE 10.1 + nForce 5 problems

Last response: in Linux/Free BSD
Share
October 31, 2006 1:49:33 AM

**edit - title changed to reflect the fact that this is not a dualboot problem (see next post)**

firstly, i've been using the system in the siggy below for at least a year now, no problems (but then again, no windows either)

But I'm currently having problems in the process of setting up a new system, mostly the partitioning:
m2n-sli/dxe
athlon x2-3800
corsair 2gb twin2x-5400c4
(and the important specs):
80GB samsung sata2 (sda)
250GB seagate sata2 (sdb)


The original intention was thus:
sda1 ~1gb /boot
sda2 ~10gb win2000
sda3 ~2gb swap
sda4 ~10gb /
(rest of sda free for other / partitions, 1 each for suse/gentoo/whatever until i decide which one i liked best (been using suse for 2 years, boss convinced me to try gentoo), and for experimenting with xen etc)
sdb1 250gb /home

so i tried installing windows first (i don't like it overwriting grub). left 1gb free, and tried to install windows on the 1-11gb block.
no good, windows doesn't like not being first on the drive.

so i changed to:
sda1 10gb win2000
(rest of sda free)
been working fine for a week or two using windows.

the next step, add suse:
sda1 10gb win2000
sda2 2gb swap
sda3 15gb /
(rest of sda free)
sdb1 250gb /home
installed fine, but didn't boot, hung when trying to detect hdds.
booted on 'failsafe', got a 'waiting or /dev/sda2 to appear....', and timed out until kernel panic when it couldn't find /.
using the 'repair installed system' on the suse cd, it said 'could not find valid root partition'.

try again, with no swap:
sda1 10gb win2000
sda2 15gb /
(rest of sda free)
sdb1 250gb /home
again, it hung on boot, couldn't find the root partition

and again, this time using suse-suggested extended partitioning:
sda1 10gb win2000
sda2 70gb extended
sda5 15gb /
(rest of extended sda2 free)
sdb1 250gb /home
still no good.

(ps, i've also tried 'ide=nodma' at the grub prompt, still no good)

i seem to remember hearing about something wrong with trying to boot from a partition starting more than 10gb into a drive (i thought this was only a win/fat problem though, and even then, i thought using extended partitions should fix this)

so:
- would putting a /boot on sdb1 make any difference? i'd prefer not too, but will if i have to. (if this works, how can i change my sda boot record back to the standard windows booter (no grub))

- is there an order of installation i can do that will give me the 'original intended' setup up the top, without windows whinging about not being first on disk and/or overwriting my Grub? (or can i let it, and reinstall grub later?)

- the windows partition works fine, using it now actually. i don't have any majorly important data on it, except i'd prefer not to move it now because of the time to reinstall everything.

- or is it nothing to do with partition order/placement, and a hardware/driver/module problem?

cheers
Doc C

More about : suse nforce problems

November 2, 2006 2:09:58 AM

Quote:
i seem to remember hearing about something wrong with trying to boot from a partition starting more than 10gb into a drive (i thought this was only a win/fat problem though, and even then, i thought using extended partitions should fix this)

This used to be problem with older disk/BIOS/OS's (link), but I can assure you this is no longer an issue. For example, my disk has this layout...
[code:1:a3c94fd07e]Disk /dev/sda: 139.9 GB, 139978604544 bytes
255 heads, 63 sectors/track, 17018 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 7649 61440561 7 HPFS/NTFS
/dev/sda2 7650 7658 72292+ 83 Linux <<The /boot partition
/dev/sda3 7659 16413 70324537+ 83 Linux
/dev/sda4 16414 17018 4859662+ 82 Linux swap / Solaris[/code:1:a3c94fd07e]

I don't see that putting /boot on another disk will make anything any better. More than anything it kinda seems that there might be a corruption on the SuSE disc. I would try to check the media (instructions) to make sure it's error-free, if it is, then there's something else going on (probably something like different device naming order from the installation, for example during the install the disk was called /dev/sda, now it's /dev/sdb or something else).

If the disc is OK, try changing up the "root=/dev/..." setting in grub to see if it'll boot, also optionally shrink the console font so you can see more of the messages to see if the device mapping/initing matches what you are expecting. See what you can find out.
November 8, 2006 1:37:20 AM

thanks for that, i tried doing root=/dev/sda* for various combinations of partitions, still no good.

i've come to the conclusion that this, however, isn't a problem with dualbooting or partitions (pretty easy to tell, because i just disconnected the 80gb drive, installed cleanly on the 250gb drive only {sda1=2gb swap, sda2=15gb /, sda3=150gb /home}, and got the same error)



hopefully that image works, it's a screenshot of what happens whenever i boot (methinks that photo was taken using the extended-partitioning setup desribed above). so i'm thinking that it's a problem with something to do with the kernel and the nForce 570SLI chip on my (asus m2n-sli) motherboard. either that, or it's a problem with what tries to get loaded next (which i can't see, obviously).

one interesting thing is that it says hda,hdb=dma on the last line, even though my pata primary (& only) master is a dvd drive, slave empty. i don't know if that's relevant, in any case doing an ide=nodma doesn't work either

i haven't yet tried a pata-only install with one of many 8gb disks i have lying around, and i definately don't want to have to do that permanently.

i have tried disconnecting the pata dvd cable, to no avail, but haven't tried disabling the pata controller in bios (i might try that once i've posted this). i also don't want to have to buy a sata dvd drive or converter either.

i tried connecting the 250gb hdd to the JMicron sata controller instead of the nForce5 sockets, but then grub gives me "error 21" (even when i clean installed connected to the jmicron). can't really be bothered investigating this option further right now.

and one final thing to note is that the 32-bit version of suse 10.0 did work a month or two ago, it's only the 10.1 x86-64 version that isn't working now.


so, sorry for the longish post, anyone got any ideas now?



*wanders off to suse and/or asus support forums*
November 8, 2006 7:20:04 PM

Huh, is that the last screen before it stops? If so, I'm stuck (maybe try updating the BIOS?), otherwise either describe where the boot process ends or post a pic.

Also, just because it lists hda/hdb as being set to DMA, you shouldn't worry unless it lists device listings for both (i.e. the model info, etc.). If it does, then your BIOS may be set to report SATA devices as ATA (legacy mode).

Finally, when I said play with the "root=/dev/" settings, I meant try things like "root=/dev/sd[b,c,...]#", keeping the number the same (since the grub install should be at least pointing to the correct partition number even it the disk got renamed). Also, in the kernel messages, try to look for listings of the SATA disks.
!