Sign in with
Sign up | Sign in
Your question

Netflix DRM

Last response: in Opinions and Experiences
Share
December 13, 2011 1:42:09 AM

Good evening folks. So I have this nice, hot pizza in front of me, and I'm interested in eating some while I watch shows. Usually, my go to when I'm eating pizza is Archer- I know, I know, but it makes me happy. So I watch a few of them, and decide to head over to netflix to see if there's anything good going on there. I see Burn Notice and remember that my brother enjoys this show, so I click on it.

And then I see this:


No way, I think; I was just watching The Office last night. It can't be. I already have a deep hatred of DRM thanks to all my personal clashes in the past, so this was a gigantic slap in the face. For starters, it is definitely the twelfth of December, and it doesn't matter what side of the Atlantic I'm on- it's going to be 12/12/11 either way, so that shouldn't be a problem. I try going back to The Office- no go. I try about half a dozen shows, all with the same error. I try to report the error, Netflix tells me my hardware is not up to task. While I understand that a Phenom quad-core, HD 5770 and 8 GBs of memory is hardly NASA-worthy, I do believe it is sufficient for viewing a streamed video. I try to again report it again- this time my internet connection was too slow? Again, my 30 Mbps connection is pretty modest compared to most, but I think it's up to task.

Whatever, I'll just contact them about it. And I get a "The page isn't redirecting properly" for the 'contact us' button every single time. I understand the need for some restrictions with streamed video as I am arguably renting the product, but at least make sure the DRM works and doesn't hinder the product. And I can't even contact them to tell them because it isn't working. I would take fault somewhere, but I'm having zero issues with everything else I've tried to do online today, and it's my own freaking dollar that's giving me this experience.

I tried looking for a fix. Some suggested Silverlight was causing an issue and I do remember seeing that get an update this week. Others outlined a fix in the User Control Panel. I thought a minute, and decided it wasn't worth my time. It took me about 15 seconds to find the latest Archer episodes for free. No, I'm not proud of it, but I'll be buying them when they come out on DVD anyway so my conscience really isn't bothered all that much, and my pizza was getting less-than-hot and I needed to get the show rolling.

Phew, that felt good to rant. Has anyone else had this problem lately?

More about : netflix drm

December 14, 2011 1:11:02 PM

I agree with the drm hate. Companies need to wise up.

Probably a bug on their part if you didnt update on your side. Try in a few days.

This is why i buy or rent physical copies. Digital is such a pita at times and a blessing at others.

Cant fault you if you plan on buying it anyways. Good to rant once in awhile.
December 17, 2011 8:30:15 PM

So I waited a few days and finally bundled my pride and called the number. Here's the quick and dirty:

(on Windows 7)
Run: "%programdata%"
Then go through Microsoft->PlayReady-> Find a folder named "mspr.hds" and delete it.

Reload a netflix page, and it should work.

Easy fix, but it still leaves my feathers ruffled. At least the lady was really nice about it.
!