Sign in with
Sign up | Sign in
Your question

Problems installing linux

Last response: in Linux/Free BSD
Share
November 8, 2006 2:01:15 AM

i have a copy of suse linux 10 but i tried installing it and it didnt work. i got to the point where it says that it is going to restart the machine and then the screen goes black. i tried to install it again and it still doesnt work. how do i erase the partition that has the linux loaded on it and how do i install it correctly?
November 8, 2006 2:20:06 AM

10.0 or 10.1?
using cds or dvd? (also, live, eval, or install dvd?)
and how long ago did you download it?
(the reason i ask is that 10.1 had a problem with YaST that required a reissue, but in any case, this doesn't sound like your problem)

and where exactly is it crashing?

once the install has finished, it'll say "rebooting in 10 seconds" or whatever, as you've seen. once it gets to this point, the hard-disk is configured enough to boot on its own, so nothing after this point matters (ie, if this is where it's crashing, just hit the big Reset button).


The next time you boot your computer, boot from the hard-disk you installed to, not the cd/dvd. if you installed from a dvd, then you just have to configure your system at this point. if using the 5 cds, you have to sit through more package installations, then configuration. if it's not getting to this stage, check your bios to make sure you're booting from the right hard disk.

if neither of these, please post more info about your system...
November 8, 2006 5:58:32 AM

i get to the 10 seconds reboot screen. i boot it from the harddrive and the screen turns black and theres nothing. but i can load from the failsafe and i finished the instillatiojn there but i still cannot enter the regular desktop
November 8, 2006 9:03:15 PM

so it boots from the hdd, you get the GRUB menu, selecting the default just gives a black screen, and sits there indefinately? could be a problem with GRUB not pointing to the right partition. (try typing root=/dev/hda* or whatever manually at the GRUB menu)

another option is that there's an option in the 'failsafe' that you need to type in manually to the default (like ide=nodma, or acpi=off, or get rid of the splash=silent option). try some of them on the default to see if that works. did you just use the default package selections, or did you change stuff? (if so, let us know what you left out)

have you tried the inbuilt recovery on the cd/dvd?
boot from the cd/dvd, select 'installation'. select your language, accept the agreement, and you get the screen with 'new/update' options.
instead, click on 'other' down the bottom right, and select 'repair installed system', then select 'auto' and let it run through and let us know the results.


alternatively, this could (slight chance) be something like my problem in another thread. what's your system specs? (cpu/mobo/chipset/hdd/gfx card)?
!