Sign in with
Sign up | Sign in
Your question

Changing the drive letter and other CDROM questions.

Last response: in Windows XP
Share
December 2, 2006 9:21:34 PM

So here's my problem: I'm trying to play Diablo II: LoD, which requires that the LoD expansion CD be in my CDROM drive. I mounted an image of the disc with Daemon such that it's in (virtual) Drive E: (normal CDROM drive is D:). But the game seems to only be checking my D: Drive for the disc, and it won't let me point to the E: Drive.

So, is there a way to just switch the drive letters around, and if so, do you think this would even solve my problem? Perhaps there's a way I can just (temporarily I hope) set E: as my default CDROM drive, so that the game would check there?

Any help is appreciated. :D 
December 2, 2006 9:39:10 PM

hi.
most of new (if not all) games have been blacklist deamon tools.
December 2, 2006 9:55:03 PM

And reading the post, you'd notice my game is 5 years old. :?

Edit: Nevermind, it appears you were right. A quick google search told me all I had to do was check "Securom" in Daemon, and now it bypasses the protection. I guess Blizzard was a few years ahead of their time with that one. :) 
December 5, 2006 1:04:01 AM

you can always check dialbo's shortcut, the old games used to reference the CD drive letter in the shortcut launch path, so it may be showing up as D instead of E, since initially you installed it on D or something

there may also be a registry key or something at hand

to get around the blacklisting crap, download ASR 1.2 on the daemon tools website and use it to launch diablo's .exe to see if you can get around it
!