"my documents" system folder properties

Archived from groups: microsoft.public.windowsxp.basics (More info?)

For some reason, win xp has decided that the "my documents" folder is "music
folder," so that each time I open it, it spends several seconds caching it
before I can access any files/folders within it.

When I right-click the "my documents" folder and select "properties," there
is no "customize" tab, so I am not sure how I can change the properties of
this system folder.

Any ideas how to fix this?

Thanks,

Clem.
13 answers Last reply
More about documents system folder properties
  1. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    On Fri, 22 Apr 2005 16:41:16 -0400, C.M.G. wrote:

    > For some reason, win xp has decided that the "my documents" folder is "music
    > folder," so that each time I open it, it spends several seconds caching it
    > before I can access any files/folders within it.
    >
    > When I right-click the "my documents" folder and select "properties," there
    > is no "customize" tab, so I am not sure how I can change the properties of
    > this system folder.
    >
    > Any ideas how to fix this?
    >
    > Thanks,
    >
    > Clem.

    The desktop.ini for the folder needs to be edited. MVP Kelly Theriot
    explains how to correct the file for all of the special "My" folders on
    this page:
    http://www.kellys-korner-xp.com/xp_f.htm

    Scroll down to "Folder Backgrounds - Customizing." The info you're seeking
    is in the Q&A part of that section.

    --
    Sharon F
    MS-MVP ~ Windows Shell/User
  2. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    Dear Sharon,

    Thank you for your response.

    I looked up the info on Kelly Theriot's page. The description there matches
    the problem I have encountered, but the fix does not work!

    Specifically, the "My Documents" already contained the appropriate
    "desktop.ini" file with all the proper text within it. When I deleted it,
    the "My Documents" appearance and behavior did not change (in other words,
    it retained the wrong system folder properties and did not revert to a
    "plain" folder), and therefore, the "properties" menu did not offer a
    "customize" tab. I replaced the desktop.ini file and rebooted, still the
    same problem.

    Sharon, at this point, I am stuck. Do you have any other suggestions?

    Thanks,

    Clem.

    "Sharon F" <sharonfDEL@ETEmvps.org> wrote in message
    news:uSw$3iZSFHA.3496@TK2MSFTNGP12.phx.gbl...
    > On Fri, 22 Apr 2005 16:41:16 -0400, C.M.G. wrote:
    >
    >> For some reason, win xp has decided that the "my documents" folder is
    >> "music
    >> folder," so that each time I open it, it spends several seconds caching
    >> it
    >> before I can access any files/folders within it.
    >>
    >> When I right-click the "my documents" folder and select "properties,"
    >> there
    >> is no "customize" tab, so I am not sure how I can change the properties
    >> of
    >> this system folder.
    >>
    >> Any ideas how to fix this?
    >>
    >> Thanks,
    >>
    >> Clem.
    >
    > The desktop.ini for the folder needs to be edited. MVP Kelly Theriot
    > explains how to correct the file for all of the special "My" folders on
    > this page:
    > http://www.kellys-korner-xp.com/xp_f.htm
    >
    > Scroll down to "Folder Backgrounds - Customizing." The info you're seeking
    > is in the Q&A part of that section.
    >
    > --
    > Sharon F
    > MS-MVP ~ Windows Shell/User
  3. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    On Mon, 25 Apr 2005 21:21:28 -0400, C.M.G. wrote:

    > Dear Sharon,
    >
    > Thank you for your response.
    >
    > I looked up the info on Kelly Theriot's page. The description there matches
    > the problem I have encountered, but the fix does not work!
    >
    > Specifically, the "My Documents" already contained the appropriate
    > "desktop.ini" file with all the proper text within it. When I deleted it,
    > the "My Documents" appearance and behavior did not change (in other words,
    > it retained the wrong system folder properties and did not revert to a
    > "plain" folder), and therefore, the "properties" menu did not offer a
    > "customize" tab. I replaced the desktop.ini file and rebooted, still the
    > same problem.
    >
    > Sharon, at this point, I am stuck. Do you have any other suggestions?
    >
    > Thanks,
    >
    > Clem.

    Hmmm, Kelly's fixes are usually right on but if your desktop.ini file
    already had the correct information there is nothing to change.

    Once, a long time ago, I had this change in customization happen with my
    documents folder. What I did to fix it was move it to different drive and
    then back to the original location. I used the buttons in the My Documents
    properties sheets (Move Folder and Restore Default). Juggling the folder's
    location apparently updated the desktop.ini file and corrected whatever had
    gone awry within it. Not very scientific but it worked.

    Another fix at Kelly's site that you might try is from her "tweaks" page:

    Line 207 right hand side
    Restore Properties - My Computer & Documents
    http://www.kellys-korner-xp.com/xp_tweaks.htm

    --
    Sharon F
    MS-MVP ~ Windows Shell/User
  4. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    Sharon,

    Moving the folder did not fix the problem. Regarding the .reg file, I am a
    little leery of it, especially of what it might do to My Computer
    properties... any idea what settings this might change?

    Thanks,

    Clem.

    "Sharon F" <sharonfDEL@ETEmvps.org> wrote in message
    news:ehwJAdlSFHA.204@TK2MSFTNGP15.phx.gbl...
    > On Mon, 25 Apr 2005 21:21:28 -0400, C.M.G. wrote:
    >
    >> Dear Sharon,
    >>
    >> Thank you for your response.
    >>
    >> I looked up the info on Kelly Theriot's page. The description there
    >> matches
    >> the problem I have encountered, but the fix does not work!
    >>
    >> Specifically, the "My Documents" already contained the appropriate
    >> "desktop.ini" file with all the proper text within it. When I deleted it,
    >> the "My Documents" appearance and behavior did not change (in other
    >> words,
    >> it retained the wrong system folder properties and did not revert to a
    >> "plain" folder), and therefore, the "properties" menu did not offer a
    >> "customize" tab. I replaced the desktop.ini file and rebooted, still the
    >> same problem.
    >>
    >> Sharon, at this point, I am stuck. Do you have any other suggestions?
    >>
    >> Thanks,
    >>
    >> Clem.
    >
    > Hmmm, Kelly's fixes are usually right on but if your desktop.ini file
    > already had the correct information there is nothing to change.
    >
    > Once, a long time ago, I had this change in customization happen with my
    > documents folder. What I did to fix it was move it to different drive and
    > then back to the original location. I used the buttons in the My Documents
    > properties sheets (Move Folder and Restore Default). Juggling the folder's
    > location apparently updated the desktop.ini file and corrected whatever
    > had
    > gone awry within it. Not very scientific but it worked.
    >
    > Another fix at Kelly's site that you might try is from her "tweaks" page:
    >
    > Line 207 right hand side
    > Restore Properties - My Computer & Documents
    > http://www.kellys-korner-xp.com/xp_tweaks.htm
    >
    > --
    > Sharon F
    > MS-MVP ~ Windows Shell/User
  5. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    On Tue, 26 Apr 2005 16:24:59 -0400, C.M.G. wrote:

    > Sharon,
    >
    > Moving the folder did not fix the problem. Regarding the .reg file, I am a
    > little leery of it, especially of what it might do to My Computer
    > properties... any idea what settings this might change?
    >
    > Thanks,
    >
    > Clem.
    >

    You can open a .REG file with Notepad. The text will show exactly what
    changes will be made. If you prefer, use the text as a guide to edit the
    registry manually. You can compare keys/values as you work your way through
    the file and make notes of any discrepancies between the two.

    Remember, you can export a key before editing or deleting it. That way if
    you don't like the changes you've made, you can double click the .REG file
    and it will enter the exported values back into the registry (revert to
    what it was before you changed it).


    --
    Sharon F
    MS-MVP ~ Windows Shell/User
  6. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    Sharon,

    I used the .reg file, but there is no change in the "My Documents" behavior.
    Any other ideas of what I could try?

    Thanks,

    Clem.

    "Sharon F" <sharonfDEL@ETEmvps.org> wrote in message
    news:%23A$cJ5tSFHA.980@TK2MSFTNGP14.phx.gbl...
    > On Tue, 26 Apr 2005 16:24:59 -0400, C.M.G. wrote:
    >
    >> Sharon,
    >>
    >> Moving the folder did not fix the problem. Regarding the .reg file, I am
    >> a
    >> little leery of it, especially of what it might do to My Computer
    >> properties... any idea what settings this might change?
    >>
    >> Thanks,
    >>
    >> Clem.
    >>
    >
    > You can open a .REG file with Notepad. The text will show exactly what
    > changes will be made. If you prefer, use the text as a guide to edit the
    > registry manually. You can compare keys/values as you work your way
    > through
    > the file and make notes of any discrepancies between the two.
    >
    > Remember, you can export a key before editing or deleting it. That way if
    > you don't like the changes you've made, you can double click the .REG file
    > and it will enter the exported values back into the registry (revert to
    > what it was before you changed it).
    >
    >
    > --
    > Sharon F
    > MS-MVP ~ Windows Shell/User
  7. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    On Wed, 27 Apr 2005 17:35:45 -0400, C.M.G. wrote:

    > Sharon,
    >
    > I used the .reg file, but there is no change in the "My Documents" behavior.
    > Any other ideas of what I could try?

    Ramesh posted this earlier for another user with the same problem. It
    worked for them. Perhaps it will work for you too.
    Quote:

    Type this command in Start/Run:
    rundll32 mydocs.dll,PerUserInit
    This fixes the Desktop.ini for the My Documents and it's sub-folders for
    the currently logged on user. Run this command under every other user
    profile (login). Additionally, to fix the Desktop.ini for the Shared
    Documents folder, see:
    http://computers.douglasthrift.net/winxpfaq/#faq3_shared_documents

    End Quote.
    --
    Sharon F
    MS-MVP ~ Windows Shell/User
  8. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    Sharon,

    I ran the rundll32 mydocs.dll,PerUserInit command for all users, and I
    checked the desktop.ini files which were according to specs, still no luck.

    I then created a new user and copied all the files and folders in "My
    Documents" from the original user account to the new account. The "My
    Documents" folder in the new account behaved normally, as did the
    subfolders.

    I then deleted all files, including hidden and system files, in the "My
    Documents" folder in the original user account. At this point, the "My
    Documents" folder in the old user account still acted like a music folder
    (task pane, background image).

    I copied all the files and folders from the "My Documents" folder in the new
    account to that in the old account, but it did still display the wrong
    properties.

    It seems that the system ignores the desktop.ini file. Do you have any idea
    where the faulty instructions might be coming from?

    Thanks,

    Clem.


    "Sharon F" <sharonfDEL@ETEmvps.org> wrote in message
    news:evt2p54SFHA.3544@TK2MSFTNGP12.phx.gbl...
    > On Wed, 27 Apr 2005 17:35:45 -0400, C.M.G. wrote:
    >
    >> Sharon,
    >>
    >> I used the .reg file, but there is no change in the "My Documents"
    >> behavior.
    >> Any other ideas of what I could try?
    >
    > Ramesh posted this earlier for another user with the same problem. It
    > worked for them. Perhaps it will work for you too.
    > Quote:
    >
    > Type this command in Start/Run:
    > rundll32 mydocs.dll,PerUserInit
    > This fixes the Desktop.ini for the My Documents and it's sub-folders for
    > the currently logged on user. Run this command under every other user
    > profile (login). Additionally, to fix the Desktop.ini for the Shared
    > Documents folder, see:
    > http://computers.douglasthrift.net/winxpfaq/#faq3_shared_documents
    >
    > End Quote.
    > --
    > Sharon F
    > MS-MVP ~ Windows Shell/User
  9. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    On Thu, 28 Apr 2005 23:24:30 -0400, C.M.G. wrote:

    > It seems that the system ignores the desktop.ini file. Do you have any idea
    > where the faulty instructions might be coming from?

    Are the attributes for the existing desktop.ini file showing HSA (hidden,
    system and archive)? If no, try setting those attributes (especially hidden
    and system). Also, it never hurts to restart between changes or at least
    log off and then on again.

    --
    Sharon F
    MS-MVP ~ Windows Shell/User
  10. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    Sharon,

    The attributes are HSA. Restarting does not fix it, either!

    Any other suggestions?

    Thanks,

    Clem.

    "Sharon F" <sharonfDEL@ETEmvps.org> wrote in message
    news:uXjhAkQTFHA.3152@TK2MSFTNGP12.phx.gbl...
    > On Thu, 28 Apr 2005 23:24:30 -0400, C.M.G. wrote:
    >
    >> It seems that the system ignores the desktop.ini file. Do you have any
    >> idea
    >> where the faulty instructions might be coming from?
    >
    > Are the attributes for the existing desktop.ini file showing HSA (hidden,
    > system and archive)? If no, try setting those attributes (especially
    > hidden
    > and system). Also, it never hurts to restart between changes or at least
    > log off and then on again.
    >
    > --
    > Sharon F
    > MS-MVP ~ Windows Shell/User
  11. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    Hi C.M.G,

    >> At this point, the "My Documents" folder in the old user account still
    >> acted like a music folder (task pane, background image).

    From your recent description, I guess the problem is not with the
    Desktop.ini, but with the Folder type registry setting. Simply resetting all
    the folder view (from Folder Options applet, View tab) will help. You can
    find more information on this problem in the link below, illustrated by
    Keith Miller. BTW, an automated tool would be available shortly, based Keith
    Miller's excellent instructions.

    http://www.kellys-korner-xp.com/xp_common_tasks.htm

    More Information:
    ------------------

    The FolderType setting is once set in the registry and Windows XP does not
    change the setting dynamically. Here are your options:

    1. Reset all folder settings:

    Click Start, Run and type C:\
    Click Tools, Folder Options
    In the View tab, click "Reset all folders"
    Click OK.
    Close the folder

    2. To fix the FolderType setting for a particular folder, follow this advice
    by Keith Miller.
    http://groups.google.co.in/groups?hl=en&lr=&selm=ehgO1ffTCHA.1496%40tkmsftngp11

    -or-

    Using Process Explorer from www.sysinternals.com:

    1. Open My Pictures folder from Start Menu or using Start/Run dialog.
    2. Start Process Explorer
    3. Switch the lower pane view to Handles, in order to find the 'Bag Number'.
    4. Once you locate the Bag #, go to that key and change the FolderType value
    accordingly.

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "C.M.G." <cmg@ohiorepromed.moc> wrote in message
    news:ehMP7MTTFHA.3620@TK2MSFTNGP09.phx.gbl...
    >
    > Sharon,
    >
    > The attributes are HSA. Restarting does not fix it, either!
    >
    > Any other suggestions?
    >
    > Thanks,
    >
    > Clem.
    >
    > "Sharon F" <sharonfDEL@ETEmvps.org> wrote in message
    > news:uXjhAkQTFHA.3152@TK2MSFTNGP12.phx.gbl...
    >> On Thu, 28 Apr 2005 23:24:30 -0400, C.M.G. wrote:
    >>
    >>> It seems that the system ignores the desktop.ini file. Do you have any
    >>> idea
    >>> where the faulty instructions might be coming from?
    >>
    >> Are the attributes for the existing desktop.ini file showing HSA (hidden,
    >> system and archive)? If no, try setting those attributes (especially
    >> hidden
    >> and system). Also, it never hurts to restart between changes or at least
    >> log off and then on again.
    >>
    >> --
    >> Sharon F
    >> MS-MVP ~ Windows Shell/User
    >
    >
  12. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    Ramesh,

    Your answer (resetting all folders) worked like a spell!

    Thank you very much.

    Clem.


    "Ramesh, MS-MVP" <ramesh@online.mvps.org> wrote in message
    news:uR2rNpmTFHA.336@TK2MSFTNGP09.phx.gbl...
    > Hi C.M.G,
    >
    >>> At this point, the "My Documents" folder in the old user account still
    >>> acted like a music folder (task pane, background image).
    >
    > From your recent description, I guess the problem is not with the
    > Desktop.ini, but with the Folder type registry setting. Simply resetting
    > all the folder view (from Folder Options applet, View tab) will help. You
    > can find more information on this problem in the link below, illustrated
    > by Keith Miller. BTW, an automated tool would be available shortly, based
    > Keith Miller's excellent instructions.
    >
    > http://www.kellys-korner-xp.com/xp_common_tasks.htm
    >
    > More Information:
    > ------------------
    >
    > The FolderType setting is once set in the registry and Windows XP does not
    > change the setting dynamically. Here are your options:
    >
    > 1. Reset all folder settings:
    >
    > Click Start, Run and type C:\
    > Click Tools, Folder Options
    > In the View tab, click "Reset all folders"
    > Click OK.
    > Close the folder
    >
    > 2. To fix the FolderType setting for a particular folder, follow this
    > advice by Keith Miller.
    > http://groups.google.co.in/groups?hl=en&lr=&selm=ehgO1ffTCHA.1496%40tkmsftngp11
    >
    > -or-
    >
    > Using Process Explorer from www.sysinternals.com:
    >
    > 1. Open My Pictures folder from Start Menu or using Start/Run dialog.
    > 2. Start Process Explorer
    > 3. Switch the lower pane view to Handles, in order to find the 'Bag
    > Number'.
    > 4. Once you locate the Bag #, go to that key and change the FolderType
    > value accordingly.
    >
    > --
    > Ramesh, Microsoft MVP
    > Windows XP Shell/User
    > http://windowsxp.mvps.org
    >
    >
    > "C.M.G." <cmg@ohiorepromed.moc> wrote in message
    > news:ehMP7MTTFHA.3620@TK2MSFTNGP09.phx.gbl...
    >>
    >> Sharon,
    >>
    >> The attributes are HSA. Restarting does not fix it, either!
    >>
    >> Any other suggestions?
    >>
    >> Thanks,
    >>
    >> Clem.
    >>
    >> "Sharon F" <sharonfDEL@ETEmvps.org> wrote in message
    >> news:uXjhAkQTFHA.3152@TK2MSFTNGP12.phx.gbl...
    >>> On Thu, 28 Apr 2005 23:24:30 -0400, C.M.G. wrote:
    >>>
    >>>> It seems that the system ignores the desktop.ini file. Do you have any
    >>>> idea
    >>>> where the faulty instructions might be coming from?
    >>>
    >>> Are the attributes for the existing desktop.ini file showing HSA
    >>> (hidden,
    >>> system and archive)? If no, try setting those attributes (especially
    >>> hidden
    >>> and system). Also, it never hurts to restart between changes or at least
    >>> log off and then on again.
    >>>
    >>> --
    >>> Sharon F
    >>> MS-MVP ~ Windows Shell/User
    >>
    >>
    >
  13. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    You're welcome Clem.

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "C.M.G." <cmg@ohiorepromed.moc> wrote in message
    news:uJhqUr3TFHA.3184@TK2MSFTNGP15.phx.gbl...
    >
    > Ramesh,
    >
    > Your answer (resetting all folders) worked like a spell!
    >
    > Thank you very much.
    >
    > Clem.
    >
    >
    > "Ramesh, MS-MVP" <ramesh@online.mvps.org> wrote in message
    > news:uR2rNpmTFHA.336@TK2MSFTNGP09.phx.gbl...
    >> Hi C.M.G,
    >>
    >>>> At this point, the "My Documents" folder in the old user account still
    >>>> acted like a music folder (task pane, background image).
    >>
    >> From your recent description, I guess the problem is not with the
    >> Desktop.ini, but with the Folder type registry setting. Simply resetting
    >> all the folder view (from Folder Options applet, View tab) will help. You
    >> can find more information on this problem in the link below, illustrated
    >> by Keith Miller. BTW, an automated tool would be available shortly, based
    >> Keith Miller's excellent instructions.
    >>
    >> http://www.kellys-korner-xp.com/xp_common_tasks.htm
    >>
    >> More Information:
    >> ------------------
    >>
    >> The FolderType setting is once set in the registry and Windows XP does
    >> not change the setting dynamically. Here are your options:
    >>
    >> 1. Reset all folder settings:
    >>
    >> Click Start, Run and type C:\
    >> Click Tools, Folder Options
    >> In the View tab, click "Reset all folders"
    >> Click OK.
    >> Close the folder
    >>
    >> 2. To fix the FolderType setting for a particular folder, follow this
    >> advice by Keith Miller.
    >> http://groups.google.co.in/groups?hl=en&lr=&selm=ehgO1ffTCHA.1496%40tkmsftngp11
    >>
    >> -or-
    >>
    >> Using Process Explorer from www.sysinternals.com:
    >>
    >> 1. Open My Pictures folder from Start Menu or using Start/Run dialog.
    >> 2. Start Process Explorer
    >> 3. Switch the lower pane view to Handles, in order to find the 'Bag
    >> Number'.
    >> 4. Once you locate the Bag #, go to that key and change the FolderType
    >> value accordingly.
    >>
    >> --
    >> Ramesh, Microsoft MVP
    >> Windows XP Shell/User
    >> http://windowsxp.mvps.org
    >>
    >>
    >> "C.M.G." <cmg@ohiorepromed.moc> wrote in message
    >> news:ehMP7MTTFHA.3620@TK2MSFTNGP09.phx.gbl...
    >>>
    >>> Sharon,
    >>>
    >>> The attributes are HSA. Restarting does not fix it, either!
    >>>
    >>> Any other suggestions?
    >>>
    >>> Thanks,
    >>>
    >>> Clem.
    >>>
    >>> "Sharon F" <sharonfDEL@ETEmvps.org> wrote in message
    >>> news:uXjhAkQTFHA.3152@TK2MSFTNGP12.phx.gbl...
    >>>> On Thu, 28 Apr 2005 23:24:30 -0400, C.M.G. wrote:
    >>>>
    >>>>> It seems that the system ignores the desktop.ini file. Do you have any
    >>>>> idea
    >>>>> where the faulty instructions might be coming from?
    >>>>
    >>>> Are the attributes for the existing desktop.ini file showing HSA
    >>>> (hidden,
    >>>> system and archive)? If no, try setting those attributes (especially
    >>>> hidden
    >>>> and system). Also, it never hurts to restart between changes or at
    >>>> least
    >>>> log off and then on again.
    >>>>
    >>>> --
    >>>> Sharon F
    >>>> MS-MVP ~ Windows Shell/User
    >>>
    >>>
    >>
    >
    >
Ask a new question

Read More

My Documents Microsoft Windows XP