Sign in with
Sign up | Sign in
Your question

Missing Hard Drive

Last response: in Windows Vista
Share
February 5, 2007 11:49:14 AM

I've recently installed Vista Ultimate on a clean hard disc but upon entering the system discovered a problem. My other, larger hard disc now seems to have disappeared. It still shows up fine in the system BIOS but under Vista there is no mention of it.

I've looked in Device Manager and in Disk Manager but there's no sign. It's like it doesn't exist.

I'm wondering if the drive could have become dismounted?

Does anyone have any idea what could have happened, and how i could go about getting it back? I have a lot of data on there so don't want to format it.

I'm pretty sure it's not a compatibility problem, my hardware seems to be listed in the compatible products list, it's all fairly new, and the upgrade advisor didn't mention any problems before installing.

More about : missing hard drive

February 6, 2007 1:51:07 PM

Anyone have any ideas?
m
0
l
Anonymous
February 6, 2007 3:30:20 PM

Whats is you motherboard and on what port is the HD connected?

Is it on a SATA port? if so do you think it's on the same controller as the OS hd?
Was it selectable when you installed vista? did you try removing the hd(disconnecting it) booting in vista, rebooting, removing the HD and boot back again?
m
0
l
Related resources
February 6, 2007 4:27:00 PM

Hi

My motherboard is an ASUS A8N SLI Deluxe. The drive in question is attached to SATA 3 and the OS is installed on a stripe occupying SATA 1 & 2.

The drive does show up in the BIOS, and i think they all use the same controller.

The drive was present and working in XP before i installed Vista.
I have tryied unplugging, rebooting, plugging in and rebooting, but still no luck.

Are there any programs i could try downloading to determin the status of the drive?
m
0
l
Anonymous
February 7, 2007 2:52:38 AM

Looking quickly at Asus web site,
Silicon Image 3114 SATA RAID driver for Vista is what you would want!

I am trying to download you motherboard manual but the web site is uber slow!So I will say: I am almost certain you SATA3-4 are on a different controller that isnt natively supported by Vista, you would probably need the drivers for the controller and try to install it somehow. I wouldn't think so but maybe you needed to load them when you installed(sayign it because you dont see problems in task manager).

Look to see if you have 2 SATA controller, from there you might start hunting the proper driver.
m
0
l
February 7, 2007 10:13:03 AM

Hi, thanks for your help with this. It's more than Microsoft technical support have managed, 3 days and counting....

Right, I've downloaded the 3114 drivers from ASUS website and tried installing them. The first set warned me it would cause non RAID disc's to become invalid. As my disc is not part of an array i decided against that. The second set said it would install RAID 10 drivers, i'm not sure what that is but went with it.

I tried rebooting after this but nothing was detected and nothing shows up in device manager.

The fact that device manager is showing nothing is what's confusing me. Surely it should be present, even if it's listed as not working?
m
0
l
Anonymous
February 7, 2007 5:00:06 PM

When I checked on asus website I did not see any vista drivers. Which driver di d you get?

I am not at home I got the manual of themobo now, I will get back to you tonight...

In the mean time good luck
m
0
l
February 7, 2007 5:42:58 PM

Thanks, i really appreciate your help with this.

I got the drivers from ASUS website, they don't specify vista compatibility though, but i figured may as well try.

I've checked that i have the latest version of the BIOS installed just incase that could be affecting it.

I've also posted the same question to their boards over there but so far no response. I don't think they're quite as active as these ones.
m
0
l
Anonymous
February 7, 2007 7:05:17 PM

They usually only adress issues that are of "high visibility" fast...

Anyway, in the mean time I think you shoudl try that:
Silicone Image 3114 Drivers

Notice there's some Vista drivers...
Also do you get anything in new in device manager when you right click on you computer and use scan for hardware change?
Can you find the Raid controllers and see if there is more then one in device manager ?
m
0
l
February 7, 2007 7:35:33 PM

Ok got the drivers, only problem is i can't find out how to install them. They're mainly .sys and .inf files so would need to be installed through a device in device manager. Problem is i don't have a device.

I've located what i assume are the controllers, they're listed as 'ATA Channel 0' and 'ATA Channel 1', there is also a 'Standard Dual Channel PCI IDE Controller' which i imagine is the controller for the IDE drives.

All these are listed as functioning normally.

Running a scan for hardware changes doesn't reveal any new devices.

Any ideas how i could use those drivers? Or where?
m
0
l
Anonymous
February 7, 2007 8:52:32 PM

Then if you can't find them in device manager maybe we are down the wrong path.

Loking at the pdf version of the A8N-SLI Deluxe, page 29, I see that there is 8 Sata port, I would try putting the storage hd in the same groupe of 4 if that's not the case.

If you can't find the Device in device manager, then the only solution I see is a clean install where you provide the drivers either with a floppy or a USB disk drive righht before windows installation, this way it might work.
m
0
l
February 8, 2007 7:08:29 AM

It is in the same group of SATA ports so i don't think it can be that.

Now you come to mention it the drive wasn't detected when i installed Vista. I just assumed it would show up in device manager after installation but that obviously wasn't the case.

I guess the next step is to do a clean install and try those drivers you found when doing it.
m
0
l
February 8, 2007 6:06:17 PM

Well i've done it, problem solved. I didn't have to reinstall everything.

I plugged the drive into the Silicon controller and it detected it first time. It's a little worrying that Vista doesn't detect it when plugged into the other SATA's but at least it's working now.

Thanks for all your help, it was very much appreciated. Microsoft technical support have yet to get back to me! So much for their 24 hour promise.
m
0
l
Anonymous
February 8, 2007 7:21:15 PM

Glad it worked out! it's always a pleasure to help out people on the forum! Pass it on :) 
m
0
l
!