Sign in with
Sign up | Sign in
Your question

Ridiculously slow install

Last response: in Linux/Free BSD
Share
February 11, 2007 1:07:45 PM

I've tried to install many versions of Linux, including Damn Small Linux, Fedora Core 6, Ubuntu, and many others, but each time I attempt to install, the process is ridiculously slow, to the point where it'll spend 6 hours loading one driver. At one point, I left my Fedora install running overnight, but oddly when I checked it in the morning my monitor said "Cannot display this video mode". This happens with every version of Linux I've tried, except for Ubuntu, which fails the install within 10 minutes of starting it.

Anyone know why this happens?

Other than the hardware in my signature, I have a Micro Advantage DVD drive.
a b 5 Linux
February 11, 2007 1:44:16 PM

As this is happening with Every version of Linux that you have tried I suspect that the problem is either the CD/DVD's that you are creating or something with the Hardware itself.

When you create the Ubuntu DVD did you run the MD5 sum check to ensure no corruption during the download? You can boot the DVD and select the option to check disc integrity. This available with a lot of linux distributions.


Have you tried any of the discs you have burned in a different PC to see if they boot ok?
February 11, 2007 3:28:18 PM

well its not the discs ive burned, because ive also got official linux discs from magazines, a double sided one with ubuntu and fedora core 6, in addition to home burned isos. everythings exackly the same on those discs, so i figure its something in my hardware.
Related resources
a b 5 Linux
February 11, 2007 5:15:55 PM

Do any of the discs allow you to boot to the liveCD enviornment or is the problem using the discs just for installation? It might be some issue with the drivers for the SATA controller that you are using.

Can you answer the following:

1. Which drive are you trying to install to and what it it connected to?
2. What is the DVD drive connected to?
3. Can you boot a LiveCD and if so does it let you see your disk?

If you are able to boot a liveCD if you could post the output of:

>lspci

Then we can see what controller you are running.

Also useful would be the output from:

>fdisk -l

so that we could see if there is anything screwy with the disc layout that might be causing problems.

My suspicion is the SATA controller not having the right drivers.
February 11, 2007 7:24:51 PM

i cant boot a livecd, that fails also. and i dont even get to the point where i get to choose a drive to install to, it just becomes ridiculously slow right at the beginnign. and my dvd drive is connected to my motherboard? is that what you mean? and none of my hdds use sata at all, they all are connected by IDE.
a b 5 Linux
February 11, 2007 8:49:00 PM

Looking at this page, it seems as though a possible issue is the secondary IDE channel controller seems to not want to work. I would suggest trying to remove one of the hard drives and (yes, commit the ultimate cardinal sin) have both your hard disk and optical disk on the same (primary) IDE channel, disabling the secondary channel in BIOS. It shouldn't slow things down much, and should definately be an improvement over what you are describing if the hardware is in fact the issue.

If this is the case, you may want to look into SATA cable to IDE drive converters, I have one on a 200GB Seagate and it works excellent (I actually saw a performance increase on drive IO from about 45 MB/s to about 60 MB/s) if you are serious about using Linux.
a b 5 Linux
February 11, 2007 9:11:34 PM

Could you post the full specs of the machine you are trying to install on?

:-D
February 11, 2007 9:29:25 PM

ok heres the full specs

Processor: Core 2 Duo e6300 OCed to 2.8 gHz

Motherboard: Asus P5W DH Deluxe

Ram: 2 x 512 Corsair XMS2 DDR2-800 @ 4-4-4-12

Video Card: XFX Geforce 6800GS

Sound Card: Soundblaster Audigy 2 ZS Platinum

Hard drives: 1 x 250 gb Maxtor IDE master, 1 x 40 gb Maxtor IDE slave, the two are set on cable select because I don't have any jumpers.

Disc Drive: MicroAdvantage (Manufactured by AOpen) DVD-RW drive

Cooling: Don't think its important, but 4x80 mm case fans, 1xZalman 9500 CPU cooler

Case: Lian Li PC-65B

uhhhh i think thats it hopefully im not missing anything.


bmouring, i dont fully understand what your saying, could you tell me how i might go about doing that? it sounds like it could work, especially with that link, but im not sure how to do it.
a b 5 Linux
February 11, 2007 10:01:25 PM

I would suggest saving the old BIOS and then upgrading to the latest BIOS.

Also try removing 1 or both IDE drives and see if it gets any further.

If that doesn't help try to install from a USB optical drive instead.

If you have another non-Core2 system install on that system, make sure you have all the modules for your P5B installed and move the HDD to your new system.

GL :-D
February 11, 2007 10:13:33 PM

well ive ackshally tried all those things except the bios update, cause teh last time i updated my bios everything broke, so i had to downgrade.
a b 5 Linux
February 11, 2007 10:24:59 PM

:-D

That's why I suggested backing up your old BIOS.

Sometimes the BIOS really helps and sometimes it breaks things.

Your best bet may be to install on another similar system that uses the same IDE kernel module and then move the drive over to your P5B.

GL :-D



Quote:
well ive ackshally tried all those things except the bios update, cause teh last time i updated my bios everything broke, so i had to downgrade.
February 11, 2007 11:23:29 PM

yeah i considered that, i spose ill do it, just involves using someone elses compy.
a b 5 Linux
February 11, 2007 11:35:09 PM

Something else you could try is PATA to SATA converters or just purchase an SATA drive ( about $55 bucks for a 160GB on newegg ).

Then you can disable the PATA IDE controller in the BIOS and try the SATA controller ( s ).

You can use a PATA to SATA or USB converter for the DVD drive.

GL :-D
a b 5 Linux
February 12, 2007 5:45:43 PM

You know.. When I buy a piece of kit that advertises that it does something and then it turns out it doesn't.. I take it back. Seriously, I'd say its an option. Why mess around like this? If a BIOS update does not solve the problem return the board.
February 12, 2007 5:56:17 PM

its an option, but its been forever since i bought it, and id need another board anyhow, so ill try to get it working w/ another computer.
a b 5 Linux
February 12, 2007 6:03:31 PM

I really would look at going the BIOS flashing route then. I appreciate that you have had problems before but it is not normally that much of a chore. Personally I'd not feel comfortable using a rig that I could not confidently restore myself in case of future trouble.

If you need a hand to do this I'm sure we will all help.
February 12, 2007 6:57:33 PM

aight ill give that a try. dont really expect it to work, cause linux failed on my last version also, but you never know.
a b 5 Linux
February 12, 2007 7:11:46 PM

Which version of the BIOS are you using at the moment. If it is pre 1602 (November 06) then you might well find it helps.

Try here for the latest version (1901) which was only released the other day.
February 12, 2007 7:25:05 PM

oooh im on 1602. recently they were on 17xx, which totally ruined it, so ill update hoorays.
a b 5 Linux
February 12, 2007 7:35:08 PM

Hmmm.. I thought 1602 or above should fix it... However I see they also have updates in the later bits to the SATA controller and they will doubtless have been tweaking other areas.. Like I said it is worth a shot.

Good luck!
February 12, 2007 8:05:32 PM

yeah i updated it, and weird shit happened to my computer. it wont allow me to go back to my overclocked settings. also i cannot change vcore, even if c1e and eist are disabled. whenever i change anything, it says cmos settings invalid.

however, it has POSSIBLY somehow unlocked the multiplier on my e6300. im not sure yet, but used to be if you typed in 8 as the multiplier as soon as you moved the selection, it went back to 7. now, it stays at 8. im gonna reboot and see if i can get it to stay at 8.

dammit i forgot to back up my old bios. UGH.
February 12, 2007 8:21:50 PM

ok, i found out why the cmos values were bad. i used the asus overclocking profile utility, cause it had my old OCing values saved, but for some reason it didnt like the bios update. very odd indeed.

however, after clearing my cmos, it will no longer allow me to change the cpu multiplier above 7 or below 6. it says those are the limits. it used to say it was 20 and 6 a moment ago. i think i successfully unlocked the c2d multi, and then lost it. it was some glitch of the cmos. wow. ill have pics up in a few minutes, as proof. the linux test will come later.
February 12, 2007 8:38:32 PM








anyone wanna tell me if im like the first person to do this or anything??
a b 5 Linux
February 12, 2007 8:39:13 PM

I seriously doubt that you unlocked the multiplier. That is set in hardware in the CPU. The bios has no control over this. Most probably the changes had not applied following your flashing of the BIOS until you re-set.

Now that you have cleared your CMOS are you able change other BIOS settings correctly?
February 12, 2007 8:49:07 PM

see thats what i thought, but idk now.

yeah everythings back to normal now, ill try the linux test later.
a b 5 Linux
February 12, 2007 11:06:57 PM

Have you tried

noapic acpi=off


at boot time?
February 13, 2007 12:38:28 AM

whats that do, and where do i input it?
a b 5 Linux
February 13, 2007 12:55:42 AM

http://fedora.redhat.com/docs/install-guide/fc6/en/sn-b...


When you first boot from the installation disk you get a boot: prompt


At the boot: prompt you can use a variety of options including those described in the documentation linked above.


For example:


boot: linux noapic acpi=off


This may or may not work


GL :-D
February 13, 2007 1:35:19 PM

aight thank you all very much for helping me out with this!
!