Sign in with
Sign up | Sign in
Your question

Slow Seagate 320GB

Last response: in Storage
Share
April 26, 2007 6:07:26 AM

Hi,

I've got a E6600 with two Seagate 320GB drives (ST3320620AS) and the drives seem slow when copying large files either within one of the disks or to the other one.

I ran HD Tune and received the following numbers, how do they look?

Transfer Rate Minimum : 30.9 MB/sec
Transfer Rate Maximum : 59.5 MB/sec
Transfer Rate Average : 55.4 MB/sec
Access Time : 13.4 ms
Burst Rate : 155.2 MB/sec
CPU Usage : 3.6%

I do some video editing with MS Movie Maker and my P3 733 opened and processed movies faster.

When I copy files through Explorer it is noticeably very slow.

The motherboard is an ASUS P5W DH Deluxe, bios ver 1305.

I really appreciate any help.

chris

More about : slow seagate 320gb

April 26, 2007 10:24:03 AM

Did you check the HDD's jumper ?
April 26, 2007 4:10:02 PM

Yes, it's set on 3gbits/s...

Thanks,
chris
Related resources
April 26, 2007 5:05:47 PM

Quote:
Yes, it's set on 3gbits/s...

Not that that would make a noticeable difference on any existing SATA drive... :roll:
But yeah there is something wrong. I have an old Seagate 7200.7 that does better than that. Maybe try hooking the drives up to different SATA ports? Check settings in BIOS to see if something stupid is checked on for some reason. Do you have the latest drivers/BIOS?

-mcg
April 26, 2007 5:08:31 PM

Wow, theyre sucky transfer rates, i have the exact same drive and get 72-78 Meg a second in HDTach :) , BUT i had to reinstall XP( grrr ) and when asked to install a SCSI drive i pressed F6 and installed the JMicron driver from my USB stick, so check your mobo for a specific sata driver

If i added the SATA 2 driver in XP after XP installation it was much slower, gotta love XP

The only downer was if anything goes wrong with your XP installation it wont be able to recognise XP( but will recognise the drive in the BIOS ), only way to fix that is to plug it into the SATA 1 connector

You didnt say if you have the 16Mb cache one or the 8mg one( although my 320 is 8Mb, and my Seagate 7200.10 400Gig is 16Mb )
April 26, 2007 6:37:41 PM

i have seagate 320gb SATA 16mb cache and i got the following benchmarks:
Transfer Rate Minimum : 0.7 MB/sec
Transfer Rate Maximum : 78.6 MB/sec
Transfer Rate Average : 51.2 MB/sec
Access Time : 13.8 ms
Burst Rate : 163.5 MB/sec
CPU Usage : 9.9%
my specs are:
pentium D 820(2.8ghz)
Asus P5B Deluxe
Connect 3D Ati Radeon x700 256mb
256mb Corsair Value Select DDR2 533
Seagate 320 GB SATA 16mb cache
470W Thermaltake Tru2
MSI TV@nywhere
Sony DVD Writer
Is My Benches Good Or Not?
April 26, 2007 7:14:22 PM

What controller do you have it plugged into and how is that controller setup ?
(I assume like my ab9 pro it has multiple Sata controllers)

It might be a driver issue under windows. Try an updated driver for the controller.
April 26, 2007 7:30:25 PM

Thanks a lot guys for all the help!

I definitely have something to go on now.

That reminds, the drives did seem fast when I first installed XP after getting the PC in January. MS Movie Maker seemed to fly importing AVI's and creating clips. Same with copying 14gb DV AVI files.

I had to re-install XP after some dumb mistake and it was slow after that. I hope I don't have to re-install XP. I thought it might have been something to do with the installation as well. If I do have to re-install I think I'll go the nliteOS route...

Yes, I didn't think the jumper setting would do anything either. It was set at 1.5gb in the first installation of XP when the drive was fast. Changing it to 3gb after the second installation didn't make any difference. Not that I expected it to.

Yese, 16MB cache.

I'm going to have to read up on this controller stuff.

I'll reply if I get any improvement. Perhaps this will help others.

Thanks again!
chris
April 26, 2007 7:39:22 PM

The last seagate drive I got, 4 x 400gig for a raid5. One of the drives had a very bad seek problem, along with a lot of bad sectors. I ran SpinRite to do maintance run. It was what reported all kind of the problems. It also did a complete surface scan, mapping out all of the bad sectors. Still has the bad seek times with the one drive, but not near as bad. This may be the reason for the poor performance. Smart is trying to do repairs at the same time. BAD SEEK's will kill any drive performance.
April 26, 2007 7:51:19 PM

Mombassa is getting 51 Megabytes per second, Lordszone 55 Megabytes per second, my own 7200.10s transfer data between them at 54 Megabytes per second. I don't see the problem since I've never seen faster rates on any drive. For realtime monitoring of speed while working with files use Total Commander.
a b G Storage
April 26, 2007 7:52:22 PM

I have the exact same hard drive. Here's my HDTach results for you to compare. This is on an Intel ICH8R controller, NCQ enabled, 3.0Gb/s enabled:



Hope you figure out the problem.
April 26, 2007 9:07:44 PM

Quote:
I have the exact same hard drive. Here's my HDTach results for you to compare. This is on an Intel ICH8R controller, NCQ enabled, 3.0Gb/s enabled:


Same controller here and pretty much the same result. No NCQ on mine though.
April 29, 2007 6:38:36 PM

I have a pair of these on an ICH8R RAID0. No HDTach screenshot available, but:

Min: ~80MB/s
Avg: ~90MB/s
Max: ~100MB/s
Burst: ~312MB/s
a b G Storage
April 30, 2007 12:39:44 AM

Quote:
I have a pair of these on an ICH8R RAID0. No HDTach screenshot available, but:

Min: ~80MB/s
Avg: ~90MB/s
Max: ~100MB/s
Burst: ~312MB/s

Go to your intel matrix control panel and enable write caching, that should improve your scores a bit if you haven't already done so. It's turned off by default.

April 30, 2007 5:11:05 AM

Hmm, maybe I should do a RAID0 setup, seeing as I've got two exact same drives...
April 30, 2007 5:19:20 AM

I ran HD Tach and got results almost the same as yours, meaning different than with HD Tune. Weird.

Seeing the results that others are getting it seems that mine are not bad at all, just average, though I was hoping I could get better results.

I will try the caching. I think I turned it off =|

chris[/img]
!