Sign in with
Sign up | Sign in
Your question

Windows XP Setup / GRUB problem, PLS HELP!!!

Last response: in Linux/Free BSD
Share
February 28, 2007 12:56:05 PM

I'm having a problem with windows setup, when I power up, I get the "Press any key to boot from cd", which I do, then I get the "Windows setup is detecting your system's hardware ", then, instead of the blue loading screen, it just goes black.

I can hear the drive working, but nothing happens. I have the Corsair RAM with the 'ram access' lights that light up when the ram is being accessed, and they don't change, thereby telling me that there is no memory activity.

Windows and Linux boot fine however, when there is no CD in the drive, and the cd-rom drive works fine as well, when used after the OSes boot. It even boots with my Linux setup disc, just not with the Windows disc. I have tried updating the BIOS to the latest, with no result. The correct boot device priority is also set (cdrom - harddrive - removable) in that order.



My system specs are:

ASUS A8N-SLI Deluxe MB
AMD Athlon 64 +1800 1.8GHz
ASUS E616P3 DVD-ROM (Primary)
ASUS 1608P DVD-RW (Secondary)

Win XP Home SP2/ Fedora 6 dual OS w/ GRUB bootloader

Fedora occupies hda1 and hda2 partitions
Windows occupied hda3 and hda4 partitions

GRUB is installed on the MBR, as opposed to the First sector of the Boot partition.

Any help greatly appreciated.
February 28, 2007 10:16:12 PM

I had something similar to this happen to me a few years ago.

I was updating XP Pro to SP2, it didn't like something during the upgrade since on the next boot, the system bluescreened. I tried recovering multiple different ways, all of which yielded no results, so I decided to use the install disk to try to reinstall the system files (the old fixmbr+ bootcfg /rebuild +etc. jazz)

When trying to get into the recovery console, booting the Windows CD id the same thing, Detecting hardware, then blackscreen. Nothing thereafter.

The only way I got things to come back was to use a linux livecd to zero-out the entire drive (although simply destroying the MBR and as such the partition table should do the same job), it seems that the installer tries to detect a previous Windows install and got hung up, at least in my case.

One option you might want to try if you don't see a more likely cause or destructive recovery method would be to use something like the GParted livecd to resize the NTFS, create a FAT32, then copy over the important data (if you don't already have it backed up)
March 2, 2007 11:46:55 AM

Is the CD scratched?

[code:1:D 93b47ae16]
cat /dev/hdc > /dev/null
[/code:1:D 93b47ae16]

Do you get IO errors?

Also some early versions of the XP CD may have trouble running on new hardware.

You may be able to get it to work if you disable or unplug some of the devices.

Unplug/disable everything but the CDROM drive and see if it starts up.

GL :-D
Related resources
March 8, 2007 11:08:48 AM

The CD is brand new, and this happens whether I use an XP Pro Corp SP1, SP2 or Home CD

Thank you everyone for the suggestions.
March 8, 2007 3:30:49 PM

Have you tried it with the HDD unplugged?

Just to see what happens.

GL :-D
March 8, 2007 5:36:20 PM

Translation

[code:1:473a7f3413]
dd if=/dev/zero of=/dev/sda
[/code:1:473a7f3413]

This wipe not the other wipe :lol: 
March 9, 2007 3:10:50 AM

Knoppix comes with wipe

which actually wipes drives clean and is better than zero'ing them with dd but a lot more time consuming.

Boot knoppix or your favorite distro that has wipe and run

[code:1:e5a09fd89e]
man wipe
[/code:1:e5a09fd89e]

:-D
!