Life w/ Linux

Okay, so, I got the boot thing up and running. I get to KDE or Gnome.

The problem is, that, when I try to access CD or Floppy it just notes out that I don't have user access. No matter if I try as ROOT or just user... I've tried in SuperUser Terminal /mnt/cdrom but it just posts a Input/Output error. I managed to make a bootdisk... but that's all I have done. I can access win_c etc. but NOT Floppy nor CD-Rom (either one). CD's are ISO9660 written (in Windows w/ Nero 5.x)... I tried to look in /dev/cdrom but I can't access it that way either (dunno what I was doing there =) I tried the KDE help thingy, but it was of no help.

I bet there is a simple solution for this, but I just can't figure out, what I'm doing wrong... It's tedious to get stuck in these trivial stuff...

Also, I'm pretty sure that I've changed my monitor to 1024*768 resolution (in Configuration - Display), but how do I change the desktop to that one too? It looks a lot like 800*600... Too lot...

Using:

AMD 1 GHz
MSI K7T Pro 2 (VIA KT133)
512 MB RAM (133 MHz)
Gainward CardXpert GF2MX (32 MB)
20 GB + 6 GB HDD's
SBLive! 1024
Win98SE/ Mandrake Linux 8.0

- Jan :)
1 answer Last reply
More about life linux
  1. In your /etc/fstab file, there should be a whitespace-delimited line that looks something like this:

    <pre>/dev/cdrom /mnt/cdrom iso9660 noauto,user 0 0</pre><p>The "user" bit in that line enables non-root users to mount the drive. If you already have a line with /mnt/cdrom in it, make sure it matches the above line. If you don't have anything with /mnt/cdrom in it, add the above line to the end of /etc/fstab.

    If you're not using devfs (i.e. you don't have "devfs" anywhere in /etc/fstab), make sure /dev/cdrom links to the "real" device for your CD-ROM (/dev/hda for pri. master, /dev/hdb for pri. slave, /dev/hdc for sec. master, etc. etc. Or /dev/scd0 for a SCSI CD-ROM). I'm not sure what file to use if you have devfs enabled...but in that case, you should change "/dev/cdrom" in /etc/fstab to reflect the real device.

    As for your display...if you run "xdpyinfo | less" and scroll through the output, you should see a line that says something like:

    <pre> dimensions: 1920x1200 pixels (650x406 millimeters)</pre><p>Also, one of the things that's always annoyed me about XFree86 is the "panning" feature. This means you can have a virtual screen that's larger than your physical screen, and you can "pan" the physical screen in a certain direction by moving your mouse to the edge of the screen. Some may find it cool, but I find it annoying. If your screen moves when your mouse hits the edge, you've got panning! (grr) My solution is to simply decide on a single resolution (usually close to my hardware's max res) and have X default to that resolution, with no larger resolutions enabled. You should also be able to cycle through resolutions with Ctrl+Alt+NumpadPlus and Ctrl+Alt+NumpadMinus, though this is sometimes disabled.

    Kelledin

    "/join #hackerz. See the Web. DoS interesting people."
Ask a new question

Read More

CD-Rom