Sign in with
Sign up | Sign in
Your question

Vista Audio issues.

Last response: in Windows Vista
Share
March 13, 2007 12:18:18 PM

I'm trying my best to like Vista, but issues like this keep ruining it for me....


I have a Soundblaster Audigy 1 Platinum, although the front bay isnt even in my PC anymore so I suppose that makes it just a Soundblaster Audigy :) 

This feeds my speakers, a Cambridge Soundworks Gigaworks 5.1 set.

In XP, I used to either use the front panel connectors of my onboard Realtek HD Audio device, or a little plantronics USB->3.5mm jack adaptor for my VoIP/Ventrillo headset.

This allowed me to have game sounds through the speakers, and VoIP through the headset without having to keep plugging things in and unplugging them.


However, in Vista....

The Plantronics USB thing doesnt work at all. If I plug it in it sets itself as the default audio device, a little red X appears next to the speaker in the system tray, and I get no sound in or out of it, and cant even get sound out the Audigy. Lovely.

The Realtek HD Audio doesnt fare much better. While it "sees" the headset/mic connected to its front panel connectors, it complains that no speakers are plugged into the back of it (the headset cable isnt long enough for this) and refuses to work. I cannot set the mic or headset as default, and they dont show up in the list of audio devices in Google Talk, Ventrillo, or anything else.

This issue is so major to me that it looks like I shall be going back to XP if I cant fix it :( 

More about : vista audio issues

March 13, 2007 12:26:33 PM

One thing you could try, but I couldn't say if it will work or not:

In the Realtek HD Audio Manager, click the Advanced Settings, set Playback options to Make Front and Rear Output devices playback two different audio streams simultaneously.

Then click on the little folder icon above the picture of all the ports, and check "disable front jack detection" (this doesn't disable the output, just the device detection). Plug your main speakers into the rear, and plug your headset into the front.
March 13, 2007 3:15:09 PM

I want my speakers plugged into the Audigy not the onboard sound :p 

It doing its thing where it wont let me select a default device now, and I still cant get sound from the Realtek (although that is what it insists on keeping as default).

Strangely, windows still makes its little noises through the Audigy, but media play complains about an audio device error.

It all works fine when the Realtek is disabled in the BIOS and the Plantronics adaptor is not connected....
Related resources
March 13, 2007 3:24:14 PM

Ah, gotcha. So effectively you have three separate audio devices? If you disable the onboard sound in the BIOS, does that help at all? What devices show up in Control Panel/Sound when you plug the Plantronics device in?
March 13, 2007 7:29:27 PM

Does this help?

Right-click on the sound icon in the system tray and select Playback Devices (or alternatively, go to Control Panel and select Sounds). Once in the Sounds window, double-click the Speakers options, then go to the Levels tab, and there you'll find the available options. Why oh why did they make it so complicated?
!