Cannot boot from new sata drive

I recently purchased a 500gb Seagate barracuda hard drive (http://www.dabs.com/productview.aspx?QuickLinx=3W4M), I can format the drive and use it as normal, but as soon as I try to boot from the drive it fails, I normally get a non-system disk error upon boot up after installing windows xp 64, I know there is nothing wrong with my xp cd as well as I can install from the cd on other machines without a problem.

I've tried repartitioning and re-formatting using the windows management tools but this doesn't make a difference, the problem still remains, I've also tried using the windows fixmbr utility to no avail.

I have two 250gb sata drives in a raid array already installed, these work fine and I can boot from them without problem, so my motherboard has no problem with sata drives, I usually disconnect these when I'm fiddling around with the new drive.

I've now tried using the various file system utilities off the ultimate boot cd (which includes seagates dos utilities) and that hasn't helped.

I really can't figure this problem out, any ideas as to what could be wrong? Like I said, I can access the drive normally without a problem, it's just when I boot from it that things go wrong.

My specs are:

AMD athlon 64 3200+
1gb unbranded memory
Asus A8n-sli motherboard
Radeon X850 XT
Creative audigy 2
windows XP 64 pro
7 answers Last reply
More about cannot boot sata drive
  1. Is it plugged into a sata 2 connector? If you plug it into a SATA 1 connector then it should work, what you need to do then is download the SATA 2 driver for your mobo and install it, its probably JMicron?

    What you should have done initially before XP install( XP is a pain for such things ) is download the SATA 2 driver for your mobo, copy it onto a floppy partition on a USB drive( in bios make sure drive A: is your floppy partition ), at the begining of the XP install it says press F6 to install SCSI drivers( but its also for the sata ones ), then press F6 and follow the instructions, it should install the driver and allow you to see the drive
  2. Ah ok thanks for that, I'll try installing again with the latest sata driver, the one I'm using is probably over a year or so old. The thing is, would an old sata driver result in the 'non system disk' error that I'm getting after I install?
  3. Actually I've been told that I shouldn't need sata drivers for the controller on my motherboard (with xp that is), so it looks like I'm back to square one. I'm going to make an entry in my journal tonight, it will simply say...bugger.
  4. lol, have you got a sata 1 connector on your mobo? connect it to that and xp will boot up, then install the sata 2 driver from there

    I dunno about the versioning it shouldnt make a diference, i had the exact same problem as you last week because the drive got corrupted on boot, i couldnt even get it to detect it for the xp install
    ( and it wouldnt recognise the damn usb device ) , so i just put it on sata 1, loaded up xp( i had to fix the boot.ini first but that was because of my corruption ) and installed the driver and worked a charm, hold out on the journal entry yet
  5. oops, double post
  6. Ok I solved the problem, what I had to do is put the drive into it's own raid array and now it works fine. I'd imagine that I had to do this because my original raid array was set to be bootable, and even though my raid controller was disabled it might have been confusing things somewhat, well thats the only explanation I can think of anywho's. Thanks for all the help :)
  7. actually i never thought about that, good work
Ask a new question

Read More

Boot Storage