Sign in with
Sign up | Sign in
Your question

Grub and installation errors

Last response: in Linux/Free BSD
Share
March 26, 2007 4:24:30 AM

Ok, I got my pc workstation set up with XP x64. I now want to install Linux. But, when installing Fedora Core 6 using a Live CD, I get the following error:



When installing Fedora 7 using a burned ISO DVD, I get the following error:

"Kernel panic: Aiee, killing interrupt handler!"

When trying to load GParted using SystemRescueCd 0.3, it freezes at:



The hard drives are as follows:

150GB WD Raptor (System Disk)
320GB WD (Storage)

The system disk is partitioned with XP on 50GB (0,1); the rest is unallocated

The 320WD has a FAT32 100MB partition(1,1); the rest is unallocated



SATA drives using the Intel Matrix storage manager controller (ICH8R)

I'm assuming there is Grub command I must enter at CD boot in order to have Grub recognize the SATA confirguration?
March 26, 2007 11:11:35 PM

This is very new hardware and as such support is still in progress. We had a similar question here a few weeks back which the two uber geeks managed to answer.

It would seem that you need to be running kernel 2.6.18 or later to get support. FC6 is older than this hence the panic that you got. The articles I did find were all a little confused and I hope you get a better explanation but there might be some good pointers here.

It must be possible as people report OpenSUSE 10.2 works straight of the boot disc.
March 27, 2007 6:15:35 PM

I believe AudioVoodoo is spot-on here, but just to be certain, can you post your specs (specifically motherboard chipset(s) or, more generally, motherboard model)?
Related resources
March 27, 2007 8:07:48 PM

ICH8R chipset is normally found on 965 motherboards but it would be good to know the specifics. I know it can be made to work it's just knowing if the Martrix raid would be supported. On my hunt for some info I didn't see anything on RAID support.
March 27, 2007 10:19:58 PM

Motherboard: Gigabyte 965P DQ6 rev. 3.3

Chipset: Intel P965

Raid controller: Intel Matrix Storage ICH8R chipset plus Gigabyte SATA2 Raid chipset

No actual raid used in configuration, just needed to use these drivers for XP to recognize my SATA drives natively, and not as simulated IDE.

All drivers up to date. Fresh clean install of XP x64 this past weekend (it took me about 10 times to get it right, I think... :roll: )

So far have tried installing with Fedora Core LiveCD, Fedora 7 ISO DVD, and Fedora Core 6 ISO DVD.

Tried:

linux pci=nommconf ide0=0x1018,0x1010

linux all-generic-ide

I'm at work right now, but later tonight will try at boot:

noapic acpi=off

ide=nodma

nodmraid

I will post pics of what I get...while I still research this issue. (As an aside, I'm trying to DL the openSUSE 10.2 torrent as we speak, but at ~40kbps it will take a day or two. I'll check my connections tonight.)

The rest of the PC:

Lian Li PC-A16
Corsair HX620W
WD Drives
Pioneer DVR-112 IDE drive
QX6700
XFX 7950GT XXX
Koutech 1394B FW PCIe
FusionHDTV5 Express PCIe
Dell 3007WFP-HC

The image gallery
March 27, 2007 11:29:49 PM

Did you also try changing the BIOS settings as per the comments?
March 28, 2007 4:29:13 AM

Bios:





Result of kernel comments:







????
March 31, 2007 4:46:13 PM

From the sounds of a couple of bugreports that I read over, there seems to be many issues (that should have been fixed in the newer kernels) with the newer Intel boards, and we've already had a few threads about them (namely JMicro stuff is finicky and the so-called "Gigabyte SATA2" is actually a rebadged JMicro affair).

My suggestion would be to try out other distributions to see if any of them work any better for you. If they all behave in the same manner, then re-examine your hardware, there may be something awry there as there are Ubuntu users who have things running on your board. You don't need to try for a full-up install, just pick some liveCD's to check that they can boot on your system, once you've worked that out you can move on from there.

Good luck and let us know what you find out.
March 31, 2007 7:19:42 PM

After not getting anywhere with Fedora, I tried openSUSE. First I tried 10.3 64bit DVD ISO. Then I tried a ready made DVD 10.2 64bit from Linux+ mag.

The 10.2 DVD went directly into text mode but complained it couldn't find the installation files??

The 10.3 DVD got me to the end of installation, but at reboot and right before I'm required to set up password info, it just stalls. No access to the remainder of the install. I can boot into XP from the splash screen, but when I ask it to boot 10.3 from hard disk, nothing.

From my understanding, several people had this same problem, and the solution in some cases was to replace Grub with LILO. Tried that, but also didn't work for me.

I must say this has been very frustating (especially, since others have installed on similar hardware), and I have invested quite a bit of time to make this work, and lost a bit of sleep.

So, I'm moving on and will revisit dual booting later on when I install Vista (after the release of SP1).
March 31, 2007 7:29:26 PM

You do seem to have gotten the crappy end of the stick with this one I must say. Thats a nice rig you have and its a crying shame that you can't get Linux running on it. Hopefully as more companies open up to Linux like Dell seems to be doing situations like this may disappear. We can but hope..

I must say reading you story has dulled my upgrade lust this week.. :?
March 31, 2007 9:05:59 PM

In my opinion wait for newer version is the best thing what you can do. Maybe final version of Fedora Core 7?

btw. Sysresccd looks like booted correctly.
March 31, 2007 9:28:19 PM

yep, I going to wait for the official Fedora 7 release. My focus on this workstation is both Fedora and openSUSE. Those are the distributions I want to work with.

I already have Ubuntu on my iBook; and will be replacing it with Fluxbuntu next month when its released for ppc.

So, hopefully in 9 months time I'll give it a go again.
!